aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-27 13:24:20 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-27 13:24:20 +0100
commit3ca3814a177dda5ab4010bd76e07087493495ab3 (patch)
tree270db1300facee0a35ebd3f4fff63aa129dd56c5
parentef181971ae543a794667ebbd04f882e10b5c6430 (diff)
testing/kexec-tools: remove unnecessary dependencies and fix license
-rw-r--r--testing/kexec-tools/APKBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/testing/kexec-tools/APKBUILD b/testing/kexec-tools/APKBUILD
index 81e755fe94d..d42b6556290 100644
--- a/testing/kexec-tools/APKBUILD
+++ b/testing/kexec-tools/APKBUILD
@@ -2,23 +2,20 @@
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=kexec-tools
pkgver=2.0.20
-pkgrel=0
+pkgrel=1
pkgdesc="Directly boot into a new kernel over a currently running one"
url="https://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git/"
arch="all"
-license="GPL-2.0"
-depends="xz zlib"
+license="GPL-2.0-only"
makedepends="zlib-dev xz-dev linux-headers"
subpackages="$pkgname-doc"
-source="https://www.kernel.org/pub/linux/utils/kernel/kexec/$pkgname-$pkgver.tar.xz
+source="https://www.kernel.org/pub/linux/utils/kernel/kexec/kexec-tools-$pkgver.tar.xz
kexec-tools-2.0.16-fix-config-sub.patch
fix-build-on-Alpine-linux.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
options="!check"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,12 +24,11 @@ build() {
--mandir=/usr/share/man \
--localstatedir=/var \
--with-zlib \
- --with-lzma
+ --with-lzma
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}