aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-10-02 16:30:30 +0000
committerpsykose <alice@ayaya.dev>2022-10-02 18:38:25 +0200
commit3ed60b0afb1abc81a0fd51d2bf19550269d9a67a (patch)
treeaaa6f60a75d5e758d6fd17dc2c9c0aced6f234bc
parent34ea858c7043b399b671bc04c157e07d0de7140c (diff)
community/py3-rich: upgrade to 12.6.0
-rw-r--r--community/py3-rich/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/community/py3-rich/APKBUILD b/community/py3-rich/APKBUILD
index a19728665b8..82db77af119 100644
--- a/community/py3-rich/APKBUILD
+++ b/community/py3-rich/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: psykose <alice@ayaya.dev>
pkgname=py3-rich
_pkgname=rich
-pkgver=12.5.0
+pkgver=12.6.0
pkgrel=0
pkgdesc="Python library for rich text formatting and terminal formatting"
url="https://rich.readthedocs.io/en/latest/"
@@ -15,14 +15,16 @@ depends="
py3-typing-extensions
python3
"
-makedepends="py3-build py3-installer py3-poetry-core py3-wheel"
+makedepends="py3-gpep517 py3-installer py3-poetry-core py3-wheel"
checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://github.com/willmcgugan/rich/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- # XXX: hack for poetry to not ignore files
- GIT_DIR=. python3 -m build --no-isolation --wheel
+ mkdir dist
+ gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 1
}
check() {
@@ -37,5 +39,5 @@ package() {
}
sha512sums="
-7aa9448d3ef14258083cbc295970fa1e184f00e2cf7a67a9bdee80cc60677ca161acdd2d570940656bf7cff9a00927a7d3e1d3bc7181a01e7e91d8e88787fded py3-rich-12.5.0.tar.gz
+e05a0ad1d6b4f1e4f7e5e3d09c70d5892a618707ae0952e34274c5ffb18a833fe85a4ac15024cc34915515b63059c02f0df32a6c97cbe91e9ac96928c7134fb0 py3-rich-12.6.0.tar.gz
"