aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 19:08:49 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-12 15:31:21 +0000
commit3ee2dbe9737e86f9432a72e9cf49f41de7e5804b (patch)
treed7c33f90ea1c5515c06c3e3042a99cfd9498dcc8
parentb7b434955c8405dac65fcec3289185a5ecad40e1 (diff)
main/uwsgi: switch to python3
-rw-r--r--main/uwsgi/APKBUILD20
1 files changed, 4 insertions, 16 deletions
diff --git a/main/uwsgi/APKBUILD b/main/uwsgi/APKBUILD
index cf30c6e5835..13501aaf899 100644
--- a/main/uwsgi/APKBUILD
+++ b/main/uwsgi/APKBUILD
@@ -27,13 +27,11 @@ makedepends="
paxmark
pcre-dev
postgresql-dev
- python
- python2-dev
python3-dev
zeromq-dev
zlib-dev
"
-source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz
+source="http://projects.unbit.it/downloads/uwsgi-$pkgver.tar.gz
uwsgi.initd
uwsgi.ini
readme.emperor
@@ -41,13 +39,12 @@ source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz
musl-fix-python.patch
"
options="!check"
-builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 2.0.16-r0:
# - CVE-2018-6758
-# Plugins for Python 2 or without compile dependency on Python.
+# Plugins for Python 3 or without compile dependency on Python.
# You may specify a custom name for so lib and subpackage after a colon.
_plugins="
alarm_curl
@@ -122,18 +119,12 @@ _plugins="
zabbix
zergpool
"
-# Plugins for Python 3.
-# You may specify a custom name for so lib and subpackage after a colon.
-_plugins3="gevent:gevent3 python:python3"
-subpackages=""
-for _p in $_plugins $_plugins3; do
+for _p in $_plugins; do
subpackages="$subpackages uwsgi-${_p#*:}:_plugin"
done
-_desc_gevent="uWSGI plugin for gevent (Python 2)"
_desc_gevent3="uWSGI plugin for gevent (Python 3)"
-_desc_python="uWSGI plugin for Python 2"
_desc_python3="uWSGI plugin for Python 3"
@@ -147,15 +138,12 @@ build() {
msg "Building core"
# ccache seems to trigger some weird bug on musl
- CC="gcc" python2 uwsgiconfig.py --build alpine
+ CC="gcc" python3 uwsgiconfig.py --build alpine
export UWSGICONFIG_LUAPC="lua5.3"
local item
for item in $_plugins; do
- _build python "$item"
- done
- for item in $_plugins3; do
_build python3 "$item"
done
}