aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-03-22 18:00:35 +0000
committerpsykose <alice@ayaya.dev>2023-03-22 19:00:35 +0100
commit3f8806a83bef9da03953cbd116de364c6f52d50d (patch)
tree2867227f47308ee97031a9e0bd74355da8f5023c
parent76b528ae82f50b59c6a4cdfdd629834c496f2b69 (diff)
main/links: upgrade to 2.29
-rw-r--r--main/links/APKBUILD9
-rw-r--r--main/links/configure.patch57
2 files changed, 63 insertions, 3 deletions
diff --git a/main/links/APKBUILD b/main/links/APKBUILD
index a5893f1e9e3..6a875a2b391 100644
--- a/main/links/APKBUILD
+++ b/main/links/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=links
-pkgver=2.28
+pkgver=2.29
pkgrel=0
pkgdesc="Web browser running in both graphics and text mode"
url="http://links.twibright.com/"
@@ -9,7 +9,9 @@ options="!check" # No test suite.
license="GPL-2.0-or-later WITH OpenSSL-Exception"
subpackages="$pkgname-doc"
makedepends="bzip2-dev openssl-dev>3 zlib-dev libevent-dev zstd-dev"
-source="http://links.twibright.com/download/links-$pkgver.tar.bz2"
+source="http://links.twibright.com/download/links-$pkgver.tar.bz2
+ configure.patch
+ "
build() {
./configure \
@@ -29,5 +31,6 @@ package() {
}
sha512sums="
-090bc770f78f8b57358ac0c6f31ad12f3d5f4eb9bbf74913ac8fa254e5ed63ec289c8a7990879983ace7427e20fb2de1271820f025b630c5a0ca599cf697b754 links-2.28.tar.bz2
+5ea8b2fd0eb74d9dc2b45614aef6ee878fe686dff9bcee75ac6ea01f6a7331670f7709233d31986fc64ad86ce549616a4471057837b6caf15af6d1c5c503ac75 links-2.29.tar.bz2
+b56fcfb6165b3a3340672b25b83826ae32ab5a36673ac90207a40afa5e1e4e5fe21cd958bfb9600035dd84a9b8af1b68ad5be97d794840796d4d2deb992ffa4c configure.patch
"
diff --git a/main/links/configure.patch b/main/links/configure.patch
new file mode 100644
index 00000000000..dcd20c452b8
--- /dev/null
+++ b/main/links/configure.patch
@@ -0,0 +1,57 @@
+werror=implicit-int
+diff --git a/confdefs.h b/confdefs.h
+new file mode 100644
+index 0000000..260c62f
+--- /dev/null
++++ b/confdefs.h
+@@ -0,0 +1,3 @@
++
++#define PACKAGE "links"
++#define VERSION "2.29"
+diff --git a/config.cache b/config.cache
+new file mode 100644
+index 0000000..e69de29
+diff --git a/config.log b/config.log
+new file mode 100644
+index 0000000..7bf8995
+--- /dev/null
++++ b/config.log
+@@ -0,0 +1,25 @@
++This file contains any messages produced by compilers while
++running configure, to aid debugging if configure makes a mistake.
++
++configure:640: checking for a BSD compatible install
++configure:693: checking whether build environment is sane
++configure:750: checking whether make sets ${MAKE}
++configure:796: checking for working aclocal-1.4
++configure:809: checking for working autoconf
++configure:822: checking for working automake-1.4
++configure:835: checking for working autoheader
++configure:848: checking for working makeinfo
++configure:880: checking for gcc
++configure:993: checking whether the C compiler (clang -O3 -flto=thin -DNDEBUG -march=native -fPIC -fstack-clash-protection -fstack-protector-strong -fcf-protection -pipe -fomit-frame-pointer -fdiagnostics-color=always -fno-semantic-interposition -flto=thin -fuse-ld=lld -Wl,-O2,--as-needed,--gc-sections,-z,defs,-z,relro,-z,now,--icf=safe,-z,pack-relative-relocs,--Bsymbolic) works
++configure:1009: clang -o conftest -O3 -flto=thin -DNDEBUG -march=native -fPIC -fstack-clash-protection -fstack-protector-strong -fcf-protection -pipe -fomit-frame-pointer -fdiagnostics-color=always -fno-semantic-interposition -flto=thin -fuse-ld=lld -Wl,-O2,--as-needed,--gc-sections,-z,defs,-z,relro,-z,now,--icf=safe,-z,pack-relative-relocs,--Bsymbolic conftest.c 1>&5
++configure:1006:1: error: type specifier missing, defaults to 'int'; ISO C99 and later do not support implicit int [-Wimplicit-int]
++main(){return(0);}
++^
++int
++1 error generated.
++configure: failed program was:
++
++#line 1004 "configure"
++#include "confdefs.h"
++
++main(){return(0);}
+diff --git a/configure b/configure
+index 354c422..88e0d53 100755
+--- a/configure
++++ b/configure
+@@ -1001,7 +1001,7 @@ cat > conftest.$ac_ext << EOF
+ #line 1004 "configure"
+ #include "confdefs.h"
+
+-main(){return(0);}
++int main(){return(0);}
+ EOF
+ if { (eval echo configure:1009: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ ac_cv_prog_cc_works=yes