aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-10 21:21:39 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-11 03:03:25 +0100
commit401fbc89f118168df196607ded6934b583063029 (patch)
tree39da444255a7c8dc1562f7a2a05ef5c028dc5643
parent8b8fc7f08aabe92d67543383e5fe2e515fbc3eea (diff)
main/seabios: upgrade to 1.13.0
-rw-r--r--main/seabios/0003-vgabios-Reorder-video-modes-to-work-around-a-Windows.patch124
-rw-r--r--main/seabios/APKBUILD6
2 files changed, 2 insertions, 128 deletions
diff --git a/main/seabios/0003-vgabios-Reorder-video-modes-to-work-around-a-Windows.patch b/main/seabios/0003-vgabios-Reorder-video-modes-to-work-around-a-Windows.patch
deleted file mode 100644
index 6394b1f56fb..00000000000
--- a/main/seabios/0003-vgabios-Reorder-video-modes-to-work-around-a-Windows.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-From 4d08ebd4f8dc19dfc36495473b34c34d53650632 Mon Sep 17 00:00:00 2001
-From: Ladi Prosek <lprosek@redhat.com>
-Date: Mon, 31 Oct 2016 19:33:05 +0100
-Subject: vgabios: Reorder video modes to work around a Windows bug
-
-RH-Author: Ladi Prosek <lprosek@redhat.com>
-Message-id: <1477924385-6169-1-git-send-email-lprosek@redhat.com>
-Patchwork-id: 72677
-O-Subject: [RHEL-7.4/7.3.z seabios PATCH] vgabios: Reorder video modes to work around a Windows bug
-Bugzilla: 1392028
-RH-Acked-by: Laszlo Ersek <lersek@redhat.com>
-RH-Acked-by: Gerd Hoffmann <kraxel@redhat.com>
-RH-Acked-by: vrozenfe <vrozenfe@redhat.com>
-
-Windows Server 2016 and Windows 10 RS1 come with a bug in its blue screen
-of death rendering logic which prevents it from generating crash dumps.
-
-The bug does not manifest if Windows sees a suitable 32 bpp video mode
-before a suitable 24 bpp video mode in the list of modes returned from
-vgabios. This commit moves all 32 bpp modes to the front of the list to
-make sure that this is always the case.
-
-Upstream patch:
-https://www.coreboot.org/pipermail/seabios/2016-October/010963.html
-
-There are valid concerns upstream about the breaking nature of the fix
-but for the limited set of operating systems supported by RHEL/RHEV we
-can easily verify that they are unaffected. So as things stand now, this
-is a downstream-only patch which will be reverted in the near future;
-the exact time will depend on Windows 10 RS2 schedule and other factors.
-The goal is to make sure that our customers running Windows 10 VMs can
-generate crash dumps.
-
-Signed-off-by: Ladi Prosek <lprosek@redhat.com>
-Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
----
- vgasrc/bochsvga.c | 39 ++++++++++++++++++++-------------------
- 1 file changed, 20 insertions(+), 19 deletions(-)
-
-diff --git a/vgasrc/bochsvga.c b/vgasrc/bochsvga.c
-index ec5d101..c5d1511 100644
---- a/vgasrc/bochsvga.c
-+++ b/vgasrc/bochsvga.c
-@@ -28,6 +28,25 @@ static struct bochsvga_mode
- u16 mode;
- struct vgamode_s info;
- } bochsvga_modes[] VAR16 = {
-+ /* 32 bpp BOCHS modes */
-+ { 0x140, { MM_DIRECT, 320, 200, 32, 8, 16, SEG_GRAPH } },
-+ { 0x141, { MM_DIRECT, 640, 400, 32, 8, 16, SEG_GRAPH } },
-+ { 0x142, { MM_DIRECT, 640, 480, 32, 8, 16, SEG_GRAPH } },
-+ { 0x143, { MM_DIRECT, 800, 600, 32, 8, 16, SEG_GRAPH } },
-+ { 0x144, { MM_DIRECT, 1024, 768, 32, 8, 16, SEG_GRAPH } },
-+ { 0x145, { MM_DIRECT, 1280, 1024, 32, 8, 16, SEG_GRAPH } },
-+ { 0x147, { MM_DIRECT, 1600, 1200, 32, 8, 16, SEG_GRAPH } },
-+ { 0x14c, { MM_DIRECT, 1152, 864, 32, 8, 16, SEG_GRAPH } },
-+ { 0x177, { MM_DIRECT, 1280, 768, 32, 8, 16, SEG_GRAPH } },
-+ { 0x17a, { MM_DIRECT, 1280, 800, 32, 8, 16, SEG_GRAPH } },
-+ { 0x17d, { MM_DIRECT, 1280, 960, 32, 8, 16, SEG_GRAPH } },
-+ { 0x180, { MM_DIRECT, 1440, 900, 32, 8, 16, SEG_GRAPH } },
-+ { 0x183, { MM_DIRECT, 1400, 1050, 32, 8, 16, SEG_GRAPH } },
-+ { 0x186, { MM_DIRECT, 1680, 1050, 32, 8, 16, SEG_GRAPH } },
-+ { 0x189, { MM_DIRECT, 1920, 1200, 32, 8, 16, SEG_GRAPH } },
-+ { 0x18c, { MM_DIRECT, 2560, 1600, 32, 8, 16, SEG_GRAPH } },
-+ { 0x18f, { MM_DIRECT, 1280, 720, 32, 8, 16, SEG_GRAPH } },
-+ { 0x192, { MM_DIRECT, 1920, 1080, 32, 8, 16, SEG_GRAPH } },
- /* standard modes */
- { 0x100, { MM_PACKED, 640, 400, 8, 8, 16, SEG_GRAPH } },
- { 0x101, { MM_PACKED, 640, 480, 8, 8, 16, SEG_GRAPH } },
-@@ -56,50 +75,32 @@ static struct bochsvga_mode
- { 0x11D, { MM_DIRECT, 1600, 1200, 15, 8, 16, SEG_GRAPH } },
- { 0x11E, { MM_DIRECT, 1600, 1200, 16, 8, 16, SEG_GRAPH } },
- { 0x11F, { MM_DIRECT, 1600, 1200, 24, 8, 16, SEG_GRAPH } },
-- /* BOCHS modes */
-- { 0x140, { MM_DIRECT, 320, 200, 32, 8, 16, SEG_GRAPH } },
-- { 0x141, { MM_DIRECT, 640, 400, 32, 8, 16, SEG_GRAPH } },
-- { 0x142, { MM_DIRECT, 640, 480, 32, 8, 16, SEG_GRAPH } },
-- { 0x143, { MM_DIRECT, 800, 600, 32, 8, 16, SEG_GRAPH } },
-- { 0x144, { MM_DIRECT, 1024, 768, 32, 8, 16, SEG_GRAPH } },
-- { 0x145, { MM_DIRECT, 1280, 1024, 32, 8, 16, SEG_GRAPH } },
-+ /* 8, 15, 16, and 24 bpp BOCHS modes */
- { 0x146, { MM_PACKED, 320, 200, 8, 8, 16, SEG_GRAPH } },
-- { 0x147, { MM_DIRECT, 1600, 1200, 32, 8, 16, SEG_GRAPH } },
- { 0x148, { MM_PACKED, 1152, 864, 8, 8, 16, SEG_GRAPH } },
- { 0x149, { MM_DIRECT, 1152, 864, 15, 8, 16, SEG_GRAPH } },
- { 0x14a, { MM_DIRECT, 1152, 864, 16, 8, 16, SEG_GRAPH } },
- { 0x14b, { MM_DIRECT, 1152, 864, 24, 8, 16, SEG_GRAPH } },
-- { 0x14c, { MM_DIRECT, 1152, 864, 32, 8, 16, SEG_GRAPH } },
- { 0x175, { MM_DIRECT, 1280, 768, 16, 8, 16, SEG_GRAPH } },
- { 0x176, { MM_DIRECT, 1280, 768, 24, 8, 16, SEG_GRAPH } },
-- { 0x177, { MM_DIRECT, 1280, 768, 32, 8, 16, SEG_GRAPH } },
- { 0x178, { MM_DIRECT, 1280, 800, 16, 8, 16, SEG_GRAPH } },
- { 0x179, { MM_DIRECT, 1280, 800, 24, 8, 16, SEG_GRAPH } },
-- { 0x17a, { MM_DIRECT, 1280, 800, 32, 8, 16, SEG_GRAPH } },
- { 0x17b, { MM_DIRECT, 1280, 960, 16, 8, 16, SEG_GRAPH } },
- { 0x17c, { MM_DIRECT, 1280, 960, 24, 8, 16, SEG_GRAPH } },
-- { 0x17d, { MM_DIRECT, 1280, 960, 32, 8, 16, SEG_GRAPH } },
- { 0x17e, { MM_DIRECT, 1440, 900, 16, 8, 16, SEG_GRAPH } },
- { 0x17f, { MM_DIRECT, 1440, 900, 24, 8, 16, SEG_GRAPH } },
-- { 0x180, { MM_DIRECT, 1440, 900, 32, 8, 16, SEG_GRAPH } },
- { 0x181, { MM_DIRECT, 1400, 1050, 16, 8, 16, SEG_GRAPH } },
- { 0x182, { MM_DIRECT, 1400, 1050, 24, 8, 16, SEG_GRAPH } },
-- { 0x183, { MM_DIRECT, 1400, 1050, 32, 8, 16, SEG_GRAPH } },
- { 0x184, { MM_DIRECT, 1680, 1050, 16, 8, 16, SEG_GRAPH } },
- { 0x185, { MM_DIRECT, 1680, 1050, 24, 8, 16, SEG_GRAPH } },
-- { 0x186, { MM_DIRECT, 1680, 1050, 32, 8, 16, SEG_GRAPH } },
- { 0x187, { MM_DIRECT, 1920, 1200, 16, 8, 16, SEG_GRAPH } },
- { 0x188, { MM_DIRECT, 1920, 1200, 24, 8, 16, SEG_GRAPH } },
-- { 0x189, { MM_DIRECT, 1920, 1200, 32, 8, 16, SEG_GRAPH } },
- { 0x18a, { MM_DIRECT, 2560, 1600, 16, 8, 16, SEG_GRAPH } },
- { 0x18b, { MM_DIRECT, 2560, 1600, 24, 8, 16, SEG_GRAPH } },
-- { 0x18c, { MM_DIRECT, 2560, 1600, 32, 8, 16, SEG_GRAPH } },
- { 0x18d, { MM_DIRECT, 1280, 720, 16, 8, 16, SEG_GRAPH } },
- { 0x18e, { MM_DIRECT, 1280, 720, 24, 8, 16, SEG_GRAPH } },
-- { 0x18f, { MM_DIRECT, 1280, 720, 32, 8, 16, SEG_GRAPH } },
- { 0x190, { MM_DIRECT, 1920, 1080, 16, 8, 16, SEG_GRAPH } },
- { 0x191, { MM_DIRECT, 1920, 1080, 24, 8, 16, SEG_GRAPH } },
-- { 0x192, { MM_DIRECT, 1920, 1080, 32, 8, 16, SEG_GRAPH } },
- };
-
- static int dispi_found VAR16 = 0;
---
-1.8.3.1
-
diff --git a/main/seabios/APKBUILD b/main/seabios/APKBUILD
index 150f5641c49..92e464bab80 100644
--- a/main/seabios/APKBUILD
+++ b/main/seabios/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=seabios
-pkgver=1.12.1
+pkgver=1.13.0
pkgrel=0
pkgdesc="Open-source legacy BIOS implementation"
url="http://www.coreboot.org/SeaBIOS"
@@ -12,7 +12,6 @@ subpackages="$pkgname-bin:_seabios seavgabios-bin:_seavgabios"
source="$pkgname-$pkgver.tar.gz::https://github.com/coreboot/seabios/archive/rel-$pkgver.tar.gz
0001-Workaround-for-a-win8.1-32-S4-resume-bug.patch
0002-reserve-more-memory-on-fseg.patch
- 0003-vgabios-Reorder-video-modes-to-work-around-a-Windows.patch
config.coreboot
config.csm
@@ -92,10 +91,9 @@ _seavgabios() {
mv "$pkgdir"/usr/share/seavgabios "$subpkgdir"/usr/share/
}
-sha512sums="58755ce842adcb99c0f2f3ebbf9ec6d4a5072753966ab46805a96db1570847b109a90e6e03d61f9088ef877ca8ba96a8006777dc38ec434fce6b487f6c1f91d0 seabios-1.12.1.tar.gz
+sha512sums="7f158badf7deecc2998eab2a08f3615dfe5a7c0a51323f7b4568a4d1280935bc32bb466c8226d87d2ca7e13f9f117ff0092befcc0699bc31c5018e84754e8393 seabios-1.13.0.tar.gz
cb8d74650e3b7136cfb62cd63e4bb5db16664dc6207cff034e17f0ae89b21b350994d375ba40a16037951a5c6d924cf517afa5eae1365b279478216e9a64a0c7 0001-Workaround-for-a-win8.1-32-S4-resume-bug.patch
56d0120bb84dc9dad863438d5651d220ca8d84e272427b1d5e7cd143b69d7ccde6d2dd9b950062fa81b5892fb4afb7ab3cfad3a461b696c600770b243622af42 0002-reserve-more-memory-on-fseg.patch
-a998a1393fafbdaace061afdfdd8be020a48e0ef9e03bfb51dbc2efab7f8c75b79cab32c53a3fb2fea72d53230265144664c7a45cf850afc9706988d0bf6a191 0003-vgabios-Reorder-video-modes-to-work-around-a-Windows.patch
dc77f693e2426a8a9b084f22d607d9bf6dfd0776cb86373a55d6e02f154f546b6fd616bb981783e914be51eb843311652a90b111fb573e32b3a8207d66aea218 config.coreboot
a2238723fbbb96184bb52b018633701aeb929bfae43f50659258dee854acaf4f1bdf2c201c65fb46d2712372d11ab345eac1c41068f82d6dcbef91ef9d1d39cd config.csm
6f6659dc7e6a14b4a9ab14ebb2c1769cc8ec5d520dc1ab5125437e213baa660b5cce1cad71c65fc8b4978c467e7a8d67ad1a42ad8accfb46e3bc654b0a1f64b9 config.seabios-128k