aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2019-02-22 12:53:47 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-06 07:51:40 +0000
commit4020a5c2fc3513f6500f049b2597d68cf4658171 (patch)
tree9710078ad4a0e20e90fdb134399639c79c21607b
parentc1a122e240abd3554576400736625527116859f8 (diff)
downloadaports-4020a5c2fc3513f6500f049b2597d68cf4658171.tar.gz
aports-4020a5c2fc3513f6500f049b2597d68cf4658171.tar.bz2
aports-4020a5c2fc3513f6500f049b2597d68cf4658171.tar.xz
community/ocamlbuild: upgrade to 0.13.1
Upgrade is needed to fix 0.12.0 check() failure with ocaml-4.07.1. While here, sync the arch= list with the ocaml aport.
-rw-r--r--community/ocamlbuild/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/community/ocamlbuild/APKBUILD b/community/ocamlbuild/APKBUILD
index a7ca751544..ae80c00d2a 100644
--- a/community/ocamlbuild/APKBUILD
+++ b/community/ocamlbuild/APKBUILD
@@ -2,11 +2,11 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
pkgname=ocamlbuild
-pkgver=0.12.0
-pkgrel=3
+pkgver=0.13.1
+pkgrel=0
pkgdesc="Generic build tool with built-in rules for building OCaml library and programs"
url="https://github.com/ocaml/ocamlbuild"
-arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml aport
+arch="aarch64 ppc64le x86_64" # limited by ocaml aport
license="LGPL-2.0-or-later-WITH-linking-exception"
checkdepends="ocaml-compiler-libs ocaml-findlib"
depends="ocaml-$pkgname=$pkgver-r$pkgrel cmd:tput"
@@ -68,4 +68,4 @@ _submv() {
rmdir -p "$pkgdir"/${path%/*} 2>/dev/null || true
}
-sha512sums="0755a8410a1e083d344e2389bbff06ae2ad5daaf9b186147fd0d2fa094bdc3a2e8e94e2a1e666a63276d10899274b905535300f47d50e747e86f17cf562abe08 ocamlbuild-0.12.0.tar.gz"
+sha512sums="ca22c4dfb9ddf20a5b0010a3df13495c8baf05fa6d660ea8ced2df86448bdc411d8231ffd05fb5fbfe96882e524a352cea555da3b97c16e9505b7520b96fa7b7 ocamlbuild-0.13.1.tar.gz"