aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-01 16:19:09 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-04 10:32:09 +0000
commit422d1fdc7f202d139b3fa14e0121806014d724cd (patch)
tree5a986775b48470ad37f13c5b91a135b448dde3d8
parentd9b794613be7af7c5c06c0012f230d9dc95afe05 (diff)
testing/nemo-qml-plugin-devicelock: new aport
-rw-r--r--testing/nemo-qml-plugin-devicelock/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/nemo-qml-plugin-devicelock/APKBUILD b/testing/nemo-qml-plugin-devicelock/APKBUILD
new file mode 100644
index 00000000000..6c16a03aaa9
--- /dev/null
+++ b/testing/nemo-qml-plugin-devicelock/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=nemo-qml-plugin-devicelock
+pkgver=0.2.26
+pkgrel=0
+pkgdesc="Nemo QML devicelock plugin"
+url="https://git.sailfishos.org/mer-core/nemo-qml-plugin-devicelock"
+arch="all"
+license="BSD-3-Clause"
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev nemo-qml-plugin-dbus-dev nemo-keepalive-dev elogind-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-static $pkgname-dev"
+source="https://git.sailfishos.org/mer-core/nemo-qml-plugin-devicelock/-/archive/$pkgver/nemo-qml-plugin-devicelock-$pkgver.tar.gz"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+
+sha512sums="c4363eec4f50056cb2f5d5a94aa6eb0a4b1b23c8f6132b2f812f21abb17bf3d8f6cd0d64ffe6e24548cb2a596516c4b1bed646aa8afdb4efd6a02efaedede3c4 nemo-qml-plugin-devicelock-0.2.26.tar.gz"