aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknuxify <knuxify@gmail.com>2021-09-24 18:33:58 +0200
committerAndy Postnikov <apostnikov@gmail.com>2021-09-25 13:48:53 +0000
commit42428ca2a389ae41386c02dce033deedceb395ac (patch)
tree9071fa5ce551cf04b73cb6cac96cdeedef815f5c
parentbfff933c168057efa9306f6cc7361a6a0735c445 (diff)
testing/xfce4-weather-plugin: new aport
https://docs.xfce.org/panel-plugins/xfce4-weather-plugin Weather plugin for the Xfce desktop environment
-rw-r--r--testing/xfce4-weather-plugin/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/xfce4-weather-plugin/APKBUILD b/testing/xfce4-weather-plugin/APKBUILD
new file mode 100644
index 00000000000..8627198a468
--- /dev/null
+++ b/testing/xfce4-weather-plugin/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: knuxify <knuxify@gmail.com>
+# Maintainer: knuxify <knuxify@gmail.com>
+pkgname=xfce4-weather-plugin
+pkgver=0.11.0
+pkgrel=0
+pkgdesc="Weather plugin for the Xfce desktop environment"
+url="https://docs.xfce.org/panel-plugins/xfce4-weather-plugin"
+arch="all !mips !mips64" # blocked by libxfce4ui-dev
+license="GPL-2.0-or-later"
+makedepends="xfce4-panel-dev libxfce4ui-dev libsoup-dev libxml2-dev"
+subpackages="$pkgname-lang"
+source="https://archive.xfce.org/src/panel-plugins/xfce4-weather-plugin/${pkgver%.*}/xfce4-weather-plugin-$pkgver.tar.bz2"
+
+build() {
+ export GEONAMES_USERNAME=rzjRsXj7it8epAV
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+f4534d47f825358752ec6252fd0fc49a44ac682e4cdce960d744cd343f5f670473fa4175c59849282352dc75ca9b22b83d7ace68cedfc7dc89bcb21be24ccf86 xfce4-weather-plugin-0.11.0.tar.bz2
+"