aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-03-23 18:39:58 +0100
committerTBK <tbk@jjtc.eu>2020-03-23 18:16:29 +0000
commit4266a308a2f322041dbca48e69b5d6ea90ba5e11 (patch)
tree51d203b003e09aba042fb9c985695b7c069ae706
parent165b47b9973a17d45aa87834e0514c01cc62e2d2 (diff)
community/libmicrohttpd: fix build
configure.ac:27: error: version mismatch. This is Automake 1.16.2, configure.ac:27: but the definition used by this AM_INIT_AUTOMAKE configure.ac:27: comes from Automake 1.16.1. You should recreate configure.ac:27: aclocal.m4 with aclocal and run automake again. WARNING: 'automake-1.16' is probably too old. You should only need it if you modified 'Makefile.am' or 'configure.ac' or m4 files included by 'configure.ac'. The 'automake' program is part of the GNU Automake package: <https://www.gnu.org/software/automake> It also requires GNU Autoconf, GNU m4 and Perl in order to run: <https://www.gnu.org/software/autoconf> <https://www.gnu.org/software/m4/> <https://www.perl.org/> make[3]: *** [Makefile:1128: Makefile.in] Error 63
-rw-r--r--community/libmicrohttpd/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/community/libmicrohttpd/APKBUILD b/community/libmicrohttpd/APKBUILD
index 0e944a29b72..df87cd354d0 100644
--- a/community/libmicrohttpd/APKBUILD
+++ b/community/libmicrohttpd/APKBUILD
@@ -9,10 +9,16 @@ pkgdesc="A small C library that is supposed to make it easy to run an HTTP serve
url="https://www.gnu.org/software/libmicrohttpd/"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="curl-dev libgcrypt-dev gnutls-dev automake autoconf libtool"
+makedepends="autoconf automake curl-dev gettext-dev gnutls-dev libgcrypt-dev libtool"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
source="https://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-$pkgver.tar.gz
- disable-test_options.patch"
+ disable-test_options.patch
+ "
+
+prepare() {
+ default_prepare
+ autoreconf -fi
+}
build() {
./configure \