aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2019-11-26 13:16:23 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-26 16:29:06 +0100
commit42ccc2c6bf2dfe475edeebb07558180a9d5ce6b5 (patch)
treece522e60eedf6fc08c43a16c6f3e3626f4a398fd
parent45f69fa2107bb3415c5321e1bbafb16783133a15 (diff)
testing/libmesode: new aport
https://github.com/profanity-im/libmesode Fork of libstrophe for use with Profanity XMPP Client testing/
-rw-r--r--testing/libmesode/10-patch-configure.patch32
-rw-r--r--testing/libmesode/APKBUILD50
2 files changed, 82 insertions, 0 deletions
diff --git a/testing/libmesode/10-patch-configure.patch b/testing/libmesode/10-patch-configure.patch
new file mode 100644
index 00000000000..38a82cd8874
--- /dev/null
+++ b/testing/libmesode/10-patch-configure.patch
@@ -0,0 +1,32 @@
+From 2cd7621d4ca4a3f78dbfb6b15779cbf57770670a Mon Sep 17 00:00:00 2001
+From: Stuart McLaren <stuart.mclaren@hp.com>
+Date: Sun, 12 Mar 2017 21:21:43 +0000
+Subject: [PATCH] Allow configure to run on netbsd
+
+NetBSD's shell (/bin/sh) doesn't support '+='. Removing '+=' allows
+configure to run and the library to compile.
+
+This matches configure.ac in boothj5/profanity which also doesn't
+use '+='.
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6d19f2e..34a5fe4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,11 +18,11 @@ AS_CASE([$host_os],
+ [PLATFORM="nix"])
+
+ PKG_CHECK_MODULES([expat], [expat >= 2.0.0],
+- [PC_REQUIRES+=(expat)],
++ [PC_REQUIRES="expat ${PC_REQUIRES}"],
+ [AC_CHECK_HEADER([expat.h],
+ [
+ expat_LIBS="-lexpat"
+- PC_LIBS+=($expat_LIBS)
++ PC_LIBS="${expat_LIBS} ${PC_LIBS}"
+ ],
+ [AC_MSG_ERROR([expat not found; expat required.])]
+ )
diff --git a/testing/libmesode/APKBUILD b/testing/libmesode/APKBUILD
new file mode 100644
index 00000000000..dc6705c41ff
--- /dev/null
+++ b/testing/libmesode/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname="libmesode"
+pkgver="0.9.3"
+pkgrel=0
+pkgdesc="Fork of libstrophe for use with Profanity XMPP Client"
+url="https://github.com/profanity-im/libmesode"
+arch="all"
+license="GPL-3.0-only MIT"
+makedepends="expat-dev doxygen openssl-dev
+ automake autoconf libtool"
+subpackages="$pkgname-dev $pkgname-doc"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/profanity-im/libmesode/archive/$pkgver.tar.gz
+ 10-patch-configure.patch
+"
+
+prepare() {
+ default_prepare
+ ./bootstrap.sh
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+ doxygen
+}
+
+doc() {
+ cd "$builddir"
+ mkdir -p "$subpkgdir"/usr/share/html/$pkgname
+ mv docs/html/* "$subpkgdir"/usr/share/html/$pkgname/
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/lib/*.a
+}
+sha512sums="572b51d762a9b7eabf8d49106219eb60613c054ac35915a54eb43ff153e434bc08c32003bc9d2277a679f246f90973bb0b47ac93af7cffcdbae07af4d2af3db8 libmesode-0.9.3.tar.gz
+65f7437d4ebd0e121d8b1f2c356c82a928a31df48cf68352fc9a9bce68a6ac5dda38780d9972fc10735f4b9583e67d58090eafd7bcb608d274886ca3f160ce05 10-patch-configure.patch"