aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-03-19 02:55:08 +0000
committerpsykose <alice@ayaya.dev>2023-03-19 03:55:08 +0100
commit439fc837589adb508d206e56105ea585a5528c25 (patch)
treef320588dc93f985e0dcb5b63f592fbbd59a199ec
parent4738627e9db85609cef679c1b9dfcc60a70157c6 (diff)
downloadaports-439fc837589adb508d206e56105ea585a5528c25.tar.gz
aports-439fc837589adb508d206e56105ea585a5528c25.tar.bz2
aports-439fc837589adb508d206e56105ea585a5528c25.tar.xz
community/sniproxy: upgrade to 0.6.1
-rw-r--r--community/sniproxy/APKBUILD22
-rw-r--r--community/sniproxy/gcc-10.patch23
2 files changed, 15 insertions, 30 deletions
diff --git a/community/sniproxy/APKBUILD b/community/sniproxy/APKBUILD
index 7400f6c5c14..aeaeac64ae0 100644
--- a/community/sniproxy/APKBUILD
+++ b/community/sniproxy/APKBUILD
@@ -1,13 +1,21 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=sniproxy
-pkgver=0.6.0
-pkgrel=2
+pkgver=0.6.1
+pkgrel=0
pkgdesc="Proxies incoming HTTP and TLS connections based on the hostname"
url="https://github.com/dlundquist/sniproxy"
arch="all"
license="BSD-2-Clause"
-makedepends="$depends_dev autoconf automake bsd-compat-headers gettext-dev
- libev-dev libtool pcre-dev udns-dev
+makedepends="
+ $depends_dev
+ autoconf
+ automake
+ bsd-compat-headers
+ gettext-dev
+ libev-dev
+ libtool
+ pcre-dev
+ udns-dev
"
install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-openrc"
@@ -18,7 +26,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/dlundquist/sniproxy/archive/
$pkgname.initd
$pkgname.conf
$pkgname.logrotate
- gcc-10.patch
"
prepare() {
@@ -53,8 +60,9 @@ package() {
done
}
-sha512sums="8a99573673bdd57e528c5781cb166d39c80daed699382b24c3fa18a6011d074a1d9e470fee404d24b4450cf067c9995125910b2941b5216d88d189a1d79ebf73 sniproxy-0.6.0.tar.gz
+sha512sums="
+4a20830ee6dfeb33a363c480c4698c263a8deccfcac2071198248147ef40d951a1b551c373b0e1e29f6b6bfcdac350390f8f4c3653ed9d1f1940ed50c96af785 sniproxy-0.6.1.tar.gz
57f4997f8a96516b4622105c024708bf39002a83d7f3eb76dd857ee0202598309b51d585f6b25b5e72e9710b79c36a3e4f21bc2effcead16dd2c032137c704f3 sniproxy.initd
f7423cfd48e9333d5db857b4eb61b747664221607e2d47a55167493159b7b838580f101427e98252468c0be9c42693f7f0689ac8bd1acdcd1dfb75638a8f49fb sniproxy.conf
8c026af5ed23620776ef5a9a08f09236d30fc5152c9f95de2b95eb7ac48ad001c21010922d74dc7c78071f9e6ef8f794c2a59c11677d8e12be8d57e94bac2b5e sniproxy.logrotate
-35d3e3e2702f859f7d03ee6c5ea72b49acbe276263bd3c92772e1745977dcf8b3d337d1ee9375855d658d8fc93b9d8d777be7c745a22e804e80e559c27a0402b gcc-10.patch"
+"
diff --git a/community/sniproxy/gcc-10.patch b/community/sniproxy/gcc-10.patch
deleted file mode 100644
index eae8d3d0398..00000000000
--- a/community/sniproxy/gcc-10.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Taken from: https://github.com/dlundquist/sniproxy/commit/822bb80df9b7b345cc9eba55df74a07b498819ba
-Author: Pierre-Olivier Mercier <nemunaire@nemunai.re>
-
---- a/src/http.h
-+++ b/src/http.h
-@@ -29,6 +29,6 @@
- #include <stdio.h>
- #include "protocol.h"
-
--const struct Protocol *const http_protocol;
-+extern const struct Protocol *const http_protocol;
-
- #endif
---- a/src/tls.h
-+++ b/src/tls.h
-@@ -28,6 +28,6 @@
-
- #include "protocol.h"
-
--const struct Protocol *const tls_protocol;
-+extern const struct Protocol *const tls_protocol;
-
- #endif