aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2022-08-27 14:57:19 +0200
committerMichał Polański <michal@polanski.me>2022-08-30 23:09:44 +0000
commit43b6926aa0a06be7822bbb49e551da1c93a9811f (patch)
treea7216892b1ffd3fa8c372fe7fe2d4dd2a89b3e6f
parenta0f5c1cddbeaa2e86a33edcdb7b8d731cd7b549a (diff)
community/py3-httpx: upgrade to 0.23.0
-rw-r--r--community/py3-httpx/APKBUILD7
-rw-r--r--community/py3-httpx/relax-dependencies.patch8
2 files changed, 7 insertions, 8 deletions
diff --git a/community/py3-httpx/APKBUILD b/community/py3-httpx/APKBUILD
index 340bf50a5f5..6c8854f5a5c 100644
--- a/community/py3-httpx/APKBUILD
+++ b/community/py3-httpx/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-httpx
-pkgver=0.22.0
+pkgver=0.23.0
pkgrel=0
pkgdesc="Next generation HTTP client for Python"
url="https://www.python-httpx.org/"
@@ -10,7 +10,6 @@ arch="noarch !armhf !ppc64le" # limited by py3-httpcore
depends="
python3
py3-certifi
- py3-charset-normalizer
py3-httpcore
py3-idna
py3-rfc3986
@@ -40,6 +39,6 @@ package() {
}
sha512sums="
-a7360f5355f75f07425b42d49697e480319f3fe606d4601bb6d64b870c8a8fce6fad8bd857ef422fc48e6141201307ee94876d5bc54a68557c7dc32ce8f1451b py3-httpx-0.22.0.tar.gz
-1d3f92df4886dfa970eb3b99d54ce1a646231419830fabb814cdde79844560123b9fe3f368283611b51e9656be267cda6a2b06c3ad79d0fb3d23b790086c7b94 relax-dependencies.patch
+3cfdf2b3b2f15967a1eec0be05ed947c5e18a46576b68a9cbfd5147dfd4736cb7c389f5431732b93f3a11f3ec6c6f25f7cbb3d96d845f00b58e2b8dae047c1d5 py3-httpx-0.23.0.tar.gz
+dc64c27e15116fdd061972747f96caedda4e4f73ca4545e77785d8c319763d55701f059339a502edc709441e21076e689caf113484986d0cb4a09b569b41603a relax-dependencies.patch
"
diff --git a/community/py3-httpx/relax-dependencies.patch b/community/py3-httpx/relax-dependencies.patch
index 816463ab316..3a4f5e2ca9c 100644
--- a/community/py3-httpx/relax-dependencies.patch
+++ b/community/py3-httpx/relax-dependencies.patch
@@ -2,12 +2,12 @@ Relax dependencies
--- a/setup.py
+++ b/setup.py
-@@ -59,7 +59,7 @@ setup(
+@@ -58,7 +58,7 @@ setup(
+ install_requires=[
"certifi",
- "charset_normalizer",
"sniffio",
- "rfc3986[idna2008]>=1.3,<2",
+ "rfc3986[idna2008]",
- "httpcore>=0.14.5,<0.15.0",
- "async_generator; python_version < '3.7'"
+ "httpcore>=0.15.0,<0.16.0",
],
+ extras_require={