aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSodface <sod@sodface.com>2022-06-20 18:01:49 -0400
committeralice <alice@ayaya.dev>2022-06-20 22:14:51 +0000
commit443cf8b108d5d8ac98ba4ec008c376b07f077e5d (patch)
tree620fb2ca7d3204f9f71bb4fc4dfbd2990b8dab2e
parente0e709a09017a293921e2fff4ea7e57e5ae41aab (diff)
community/nilfs-utils: remove max-input patch
-rw-r--r--community/nilfs-utils/APKBUILD6
-rw-r--r--community/nilfs-utils/max-input.patch12
2 files changed, 2 insertions, 16 deletions
diff --git a/community/nilfs-utils/APKBUILD b/community/nilfs-utils/APKBUILD
index c28a4a1207d..f1d66cf1926 100644
--- a/community/nilfs-utils/APKBUILD
+++ b/community/nilfs-utils/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Sodface <sod@sodface.com>
pkgname=nilfs-utils
pkgver=2.2.9
-pkgrel=0
+pkgrel=1
pkgdesc="Utilities for managing NILFS v2 filesystems"
url="http://nilfs.sourceforge.net"
arch="all"
@@ -11,8 +11,7 @@ license="GPL-2.0-or-later"
makedepends="autoconf automake libtool linux-headers util-linux-dev"
options="!check" # no test suite
subpackages="$pkgname-libs $pkgname-dev $pkgname-doc"
-source="http://nilfs.sourceforge.net/download/nilfs-utils-$pkgver.tar.bz2
- max-input.patch"
+source="http://nilfs.sourceforge.net/download/nilfs-utils-$pkgver.tar.bz2"
prepare() {
default_prepare
@@ -45,5 +44,4 @@ package() {
sha512sums="
dd8ab20ee0d6750a6d81f86fe4d1ad94a8a71aa53ee7cd38550ea32fffcc9527db1c75d34f732f0f8f6379a808249f8eec2619e54c595566a3fc434a87d9e66d nilfs-utils-2.2.9.tar.bz2
-9605c535bed809075df901f265d22b45b3b0c8915e69ea0dbb6ffef039f9e3a9c616f246fab927589a446035341eca2aadb807c0f74e0a9abd01977e09ebd39b max-input.patch
"
diff --git a/community/nilfs-utils/max-input.patch b/community/nilfs-utils/max-input.patch
deleted file mode 100644
index 21a769e4805..00000000000
--- a/community/nilfs-utils/max-input.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./bin/rmcp.c.orig
-+++ ./bin/rmcp.c
-@@ -56,6 +56,9 @@
- #include "nilfs.h"
- #include "parser.h"
-
-+#ifndef MAX_INPUT
-+#define MAX_INPUT _POSIX_MAX_INPUT
-+#endif
-
- #ifdef _GNU_SOURCE
- #include <getopt.h>