aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2018-01-21 12:02:44 +0000
committerSören Tempel <soeren+git@soeren-tempel.net>2018-01-21 13:57:43 +0100
commit44834f47fc4ca35c05b08b35491f06f291617b90 (patch)
tree12fbab3119a17626d8cf12f6bb80abaa791f13b0
parentec37c7f5e31a56396d96377ce354c8440d483432 (diff)
main/inotify-tools: remove inotify-tools-inc from depends
The inotify-tools-inc aport was deleted. While being here also add a check() function.
-rw-r--r--main/inotify-tools/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/inotify-tools/APKBUILD b/main/inotify-tools/APKBUILD
index dd055b5d695..7a781e5e0ea 100644
--- a/main/inotify-tools/APKBUILD
+++ b/main/inotify-tools/APKBUILD
@@ -2,12 +2,11 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname="inotify-tools"
pkgver=3.20.1
-pkgrel=0
+pkgrel=1
pkgdesc="C library and CLI tools providing a simple interface to inotify"
url="https://github.com/rvoicilas/inotify-tools"
arch="all"
license="GPL-2.0"
-depends="!inotify-tools-inc"
makedepends="automake autoconf libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/rvoicilas/$pkgname/archive/$pkgver.tar.gz"
@@ -27,6 +26,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install