aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-04-20 01:52:46 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-22 21:00:47 +0000
commit47b6cf726fbab12c8e797923853ba05b686d9433 (patch)
treeeae0a82f03c275eec3ff090e59970200cbf60eb7
parent4637142b32d8f147c359c7f29b09fae3a532277b (diff)
testing/perl-datetime-format-xsd: new aport
-rw-r--r--testing/perl-datetime-format-xsd/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/perl-datetime-format-xsd/APKBUILD b/testing/perl-datetime-format-xsd/APKBUILD
new file mode 100644
index 00000000000..1c97cf4d423
--- /dev/null
+++ b/testing/perl-datetime-format-xsd/APKBUILD
@@ -0,0 +1,36 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-datetime-format-xsd
+_pkgreal=DateTime-Format-XSD
+pkgver=0.2
+pkgrel=0
+pkgdesc="Format DateTime according to xsd:dateTime"
+url="https://metacpan.org/release/DateTime-Format-XSD/"
+arch="noarch"
+license="GPL-1.0-or-later Artistic-1.0-Perl"
+cpandepends="perl-datetime-format-iso8601"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DR/DRUOSO/DateTime-Format-XSD-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="2ee29b1a573a6d42b7e50515f441faf4cc91c696bc5f92cd428b70a061e572a2b32fa07ca3a90f1e269dedd750a2f31fb9ebae47389acb07611cd6b04c328faf DateTime-Format-XSD-0.2.tar.gz"