aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-03-18 11:49:19 +0000
committerpsykose <alice@ayaya.dev>2023-03-18 12:57:54 +0100
commit48c18b9b7f3601cf22ff5cec9f10ac65da4aed74 (patch)
tree3cac0ae3d5834157f566274605e23c0592eca647
parent86afc2354e476205f51e02adcd8b02b2137783fc (diff)
community/evolution-data-server: upgrade to 3.48.0
-rw-r--r--community/evolution-data-server/APKBUILD11
-rw-r--r--community/evolution-data-server/langver.patch14
2 files changed, 4 insertions, 21 deletions
diff --git a/community/evolution-data-server/APKBUILD b/community/evolution-data-server/APKBUILD
index 3785a40a9fe..01fbbe29393 100644
--- a/community/evolution-data-server/APKBUILD
+++ b/community/evolution-data-server/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=evolution-data-server
-pkgver=3.46.4
+pkgver=3.48.0
pkgrel=0
pkgdesc="data server for evolution"
options="!check" # Tests fail on the builders, passes CI
@@ -40,13 +40,11 @@ makedepends="$depends_dev
sqlite-dev
vala
webkit2gtk-4.1-dev
- webkit2gtk-5.0-dev
+ webkit2gtk-6.0-dev
"
checkdepends="db-utils"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.gnome.org/sources/evolution-data-server/${pkgver%.*}/evolution-data-server-$pkgver.tar.xz
- langver.patch
- "
+source="https://download.gnome.org/sources/evolution-data-server/${pkgver%.*}/evolution-data-server-$pkgver.tar.xz"
build() {
CFLAGS="$CFLAGS -I/usr/include/gnu-libiconv" \
@@ -80,6 +78,5 @@ package() {
}
sha512sums="
-7eca5e3c1562c196448f0d4e9c8cbdbedc79768edb6ddc1e92f70a3cd423407dc3c55f1d38c3c47a2e517a58c427a66ecbd3f4f35b0f9d892d1d029ba0a0e07b evolution-data-server-3.46.4.tar.xz
-c789c0f1033b46a3134f4ade98e756db8bbd9b76b0cb9f7e4151c751169757eaad4816988c566c11969a38b814a44c9a7f6b531718523250f25dce3f3f1960fd langver.patch
+15613fab61d2c6537906657f51803df92135e723edf94a03519b812326072e0fb168d3dbd791b9669ada3a8ba5dc05ee254f70233b015d7a6ee38fdc9beec324 evolution-data-server-3.48.0.tar.xz
"
diff --git a/community/evolution-data-server/langver.patch b/community/evolution-data-server/langver.patch
deleted file mode 100644
index 628deb4f459..00000000000
--- a/community/evolution-data-server/langver.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-new abseil requires minimum 17
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4532801..e4af6ec 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -6,7 +6,7 @@ cmake_policy(VERSION 3.1)
- project(evolution-data-server
- VERSION 3.46.4
- LANGUAGES C CXX)
--set(CMAKE_CXX_STANDARD 14)
-+set(CMAKE_CXX_STANDARD 17)
- set(PROJECT_BUGREPORT "https://gitlab.gnome.org/GNOME/evolution-data-server/issues/")
-
- # Base Version: This is for API/version tracking for things like