aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2022-09-10 05:00:45 +0200
committeralice <alice@ayaya.dev>2022-09-10 07:58:24 +0000
commit49ddac198ece68edf5d9a8830b799d4bd42b0d1d (patch)
tree34375a821df511fb5ebe5bb9f29741f4eaf2e11d
parentaf31700b99750a8a285e6f4918ef9476aad5cbfd (diff)
main/py3-six: run tests
-rw-r--r--main/py3-six/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/main/py3-six/APKBUILD b/main/py3-six/APKBUILD
index f97ecd6fab9..18d179f8ae9 100644
--- a/main/py3-six/APKBUILD
+++ b/main/py3-six/APKBUILD
@@ -2,22 +2,19 @@
pkgname=py3-six
_pkgname=six
pkgver=1.16.0
-pkgrel=2
+pkgrel=3
pkgdesc="Python 2 and 3 compatibility library"
url="https://pypi.python.org/pypi/six"
arch="noarch"
license="MIT"
depends="python3"
+checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://github.com/benjaminp/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-six" # Backwards compatibility
provides="py-six=$pkgver-r$pkgrel" # Backwards compatibility
-# circular dependency with pytest
-#checkdepends="pytest py3-pytest"
-options="!check"
-
build() {
python3 setup.py build
}