aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-06-14 11:57:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-14 12:00:37 +0000
commit4a6b944d7f41bda3c7ae8225472895eea4b26f3f (patch)
tree61f249c768aa2ddadcdbd1c4c51f071836db6d2b
parent03efe17c7cc87c36c387c49a4a7a9383f8c3a987 (diff)
downloadaports-4a6b944d7f41bda3c7ae8225472895eea4b26f3f.tar.gz
aports-4a6b944d7f41bda3c7ae8225472895eea4b26f3f.tar.bz2
aports-4a6b944d7f41bda3c7ae8225472895eea4b26f3f.tar.xz
community/php7-pecl-oauth: fix build
remove the configure test for pcre.h. php 7.3 uses pcre2.h and there is nothing in php oauth that uses pcre.h directly, it only relies on "ext/pcre/php_pcre.h" simply remove the check to fix build.
-rw-r--r--community/php7-pecl-oauth/APKBUILD6
-rw-r--r--community/php7-pecl-oauth/pcre.patch13
2 files changed, 17 insertions, 2 deletions
diff --git a/community/php7-pecl-oauth/APKBUILD b/community/php7-pecl-oauth/APKBUILD
index 97b1e66553..e4a958a756 100644
--- a/community/php7-pecl-oauth/APKBUILD
+++ b/community/php7-pecl-oauth/APKBUILD
@@ -10,7 +10,8 @@ arch="all"
license="PHP"
depends="php7-common"
makedepends="php7-dev autoconf re2c pcre2-dev curl-dev"
-source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz
+ pcre.patch"
builddir="$srcdir"/$_pkgreal-$pkgver
provides="php7-oauth=$pkgver-r$pkgrel" # for backward compatibility
replaces="php7-oauth" # for backward compatibility
@@ -34,4 +35,5 @@ package() {
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/60_$_pkgreal.ini
}
-sha512sums="3e0ce5ce01533bfd304c0c34465cc184fbd0af1a25f5192860e6394c86dc948688cc8d4b419b48676481cef3a685ba70ac612a8c516da26d0dfe9efdef7e98d9 oauth-2.0.3.tgz"
+sha512sums="3e0ce5ce01533bfd304c0c34465cc184fbd0af1a25f5192860e6394c86dc948688cc8d4b419b48676481cef3a685ba70ac612a8c516da26d0dfe9efdef7e98d9 oauth-2.0.3.tgz
+68d636032d2f3cb2822ea3121a80256b87a04cc5998c4775174366c6a3392dfe3abc00c84cc50aca5745a32ddd2246af129fe5aa17cc415652c52214a84feef9 pcre.patch"
diff --git a/community/php7-pecl-oauth/pcre.patch b/community/php7-pecl-oauth/pcre.patch
new file mode 100644
index 0000000000..7a47b989d3
--- /dev/null
+++ b/community/php7-pecl-oauth/pcre.patch
@@ -0,0 +1,13 @@
+diff --git a/config.m4 b/config.m4
+index e05ed68..48e2608 100644
+--- a/config.m4
++++ b/config.m4
+@@ -14,8 +14,6 @@ if test "$PHP_OAUTH" != "no"; then
+ PHP_NEW_EXTENSION(oauth, oauth.c provider.c, $ext_shared)
+ CFLAGS="$CFLAGS -Wall -g"
+
+- AC_CHECK_HEADER(pcre.h, , [AC_MSG_ERROR([Couldn't find pcre.h, try installing the libpcre development/headers package])])
+-
+ AS_IF([test "x$with_curl" != "xno"],
+ [
+ AC_MSG_CHECKING(for cURL in default path)