aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-05-01 15:05:12 -0400
committerLeo <thinkabit.ukim@gmail.com>2020-05-02 18:18:34 +0000
commit4b267901dd7abf29599aaf48b8916a35c004a57c (patch)
treee95068eaaecdcd6ade61ce8c4c594d273061a57f
parent29d0f28d1d5d181c6d16c275c75ab431f5616ad7 (diff)
testing/py3-requests-file: upgrade to 1.5.1
-rw-r--r--testing/py3-requests-file/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/py3-requests-file/APKBUILD b/testing/py3-requests-file/APKBUILD
index afe6c9d06f7..f863f500e18 100644
--- a/testing/py3-requests-file/APKBUILD
+++ b/testing/py3-requests-file/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Galen Abell <galen@galenabell.com>
pkgname=py3-requests-file
_pyname=requests-file
-pkgver=1.5.0
+pkgver=1.5.1
pkgrel=0
pkgdesc="Transport adapter for fetching file:// URLs with the requests python library"
url="https://github.com/dashea/requests-file"
@@ -10,6 +10,7 @@ arch="noarch"
license="Apache-2.0"
depends="python3"
makedepends="py3-setuptools"
+checkdepends="py3-mock py3-pytest py3-requests"
source="$_pyname-$pkgver.tar.gz::https://github.com/dashea/requests-file/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
@@ -18,10 +19,13 @@ build() {
}
check() {
+ # tests module needs an __init__ file
+ touch tests/__init__.py
+
python3 setup.py test
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="e4daceb2c9d8249b97b7a95d7fcae50c1659d14592835e8b296f9fe7c76fc4c740f6c4b19fc886c5d688b5c975f931ac5dbc8b5a50c7b6d1a898f90f7ed16c72 requests-file-1.5.0.tar.gz"
+sha512sums="821d2c8092b035308d2723b28d0780cb0ae52b1a2856c3399d57357fbc0da4dc3568af67a5910163e86e90bfd6dc8e7195dce3a2adee7a74b228d6dd4b10ae5a requests-file-1.5.1.tar.gz"