aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-08-03 03:39:55 +0000
committeralice <alice@ayaya.dev>2022-08-03 07:10:58 +0000
commit4b78dbe29d18151402052c56af43cc12d04b1a69 (patch)
tree0fdd85b1af4473a3cdb59667bd14cdc82f67dca7
parente00db2d9d99d5ec64306cc19538f0daf7a9204d8 (diff)
main/iproute2: upgrade to 5.19.0
add MIN macro remove unused seds
-rw-r--r--main/iproute2/APKBUILD20
-rw-r--r--main/iproute2/min.patch13
2 files changed, 20 insertions, 13 deletions
diff --git a/main/iproute2/APKBUILD b/main/iproute2/APKBUILD
index bfd242fa9ff..6151ce55538 100644
--- a/main/iproute2/APKBUILD
+++ b/main/iproute2/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iproute2
-pkgver=5.18.0
+pkgver=5.19.0
pkgrel=0
pkgdesc="IP Routing Utilities"
-url="https://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
+url="https://wiki.linuxfoundation.org/networking/iproute2"
arch="all"
license="GPL-2.0-or-later"
install="$pkgname.post-install"
@@ -31,22 +31,15 @@ subpackages="
$pkgname-ss
$pkgname-rdma
"
-source="https://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz"
+source="https://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
+ min.patch
+ "
options="!check" # requires namespaces support and root
# secfixes:
# 5.1.0-r0:
# - CVE-2019-20795
-prepare() {
- default_prepare
-
- sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
- sed -i 's:/usr/local:/usr:' tc/m_ipt.c include/iptables.h
- sed -i -e 's:=/share:=/usr/share:' \
- -e 's:-Werror::' Makefile
-}
-
build() {
make CCOPTS="-D_GNU_SOURCE $CFLAGS" V=1
}
@@ -96,5 +89,6 @@ rdma() {
}
sha512sums="
-7b43c89741a8ffe8fd529ac4ee19c8eab7dce2f064de494c160c75456ffb960fb5f1e78c868ab98360dafde28d5e2c4d58177135b6d380e80e06eba9e3eaf068 iproute2-5.18.0.tar.xz
+eb0fffb153f7cecc89b5573b7fc211d67fb1c06789fd3b0aec75ba5032521d53c51ccc52db7367e41397993df50244af84763b0b1d5a76d9dfccf013c010131b iproute2-5.19.0.tar.xz
+ec8614900396135fa6e76c5aa62d0f484102597866d4ff7795811c1668405d6cc91e1d2e22bfa048b969bb7bc584c23732279cf0763dd2ef3e8ee6f1ba0c1542 min.patch
"
diff --git a/main/iproute2/min.patch b/main/iproute2/min.patch
new file mode 100644
index 00000000000..878f376cd47
--- /dev/null
+++ b/main/iproute2/min.patch
@@ -0,0 +1,13 @@
+diff --git a/ip/ipstats.c b/ip/ipstats.c
+index 5cdd15a..7ccfae8 100644
+--- a/ip/ipstats.c
++++ b/ip/ipstats.c
+@@ -6,6 +6,8 @@
+ #include "utils.h"
+ #include "ip_common.h"
+
++#define MIN(a,b) (((a)<(b))?(a):(b))
++
+ struct ipstats_stat_dump_filters {
+ /* mask[0] filters outer attributes. Then individual nests have their
+ * filtering mask at the index of the nested attribute.