aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-04-06 22:23:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-04-06 22:23:32 -0300
commit4bc4ed8d1139760a007fbb6d920b363eecfc803a (patch)
treea072b8c467ae6556391e8aba876f98164c8374bf
parent1066b8129dfc909ab94618795eccfe88b39fd0c0 (diff)
testing/py3-manuel: fix source, make noarch=
-rw-r--r--testing/py3-manuel/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/py3-manuel/APKBUILD b/testing/py3-manuel/APKBUILD
index 5671532661b..8f650dc331b 100644
--- a/testing/py3-manuel/APKBUILD
+++ b/testing/py3-manuel/APKBUILD
@@ -5,11 +5,12 @@ pkgver=1.10.1
pkgrel=0
pkgdesc="mix and match traditional doctests with custom test syntax"
url="https://github.com/benji-york/manuel"
-arch="all"
+arch="noarch"
license="Apache-2.0"
+depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-zope-testing"
-source="https://files.pythonhosted.org/packages/source/m/manuel-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/benji-york/manuel/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/manuel-$pkgver"
build() {
@@ -24,4 +25,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="39376852e2ecb8a19b2f565464e53f475577edf68e89b3d267f94374a444714ed38ef63da638a02dcec2df851869d57c0d256dca4b436b37ff36b6b3a822710b manuel-1.10.1.tar.gz"
+sha512sums="7109852a80097a12237a363c91ac433dd2662e238ab4f20757b4d4b93019d0ada19069fd45a13a66128adf4dbc32f162d12a90879db2f2eb4748635118d75072 py3-manuel-1.10.1.tar.gz"