aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorodidev <odidev@puresoftware.com>2020-04-20 14:20:19 +0000
committerRasmus Thomsen <oss@cogitri.dev>2020-05-19 13:44:35 +0000
commit4c6a76a4b084c355d83ee28eaa062c657c8674a4 (patch)
tree8f8f014e4e4f17d24cde021f295c7de1e6481b5a
parentc71d18464347b3ed5fdc6e961bcd4f00b5f8e2e9 (diff)
downloadaports-4c6a76a4b084c355d83ee28eaa062c657c8674a4.tar.gz
aports-4c6a76a4b084c355d83ee28eaa062c657c8674a4.tar.bz2
aports-4c6a76a4b084c355d83ee28eaa062c657c8674a4.tar.xz
community/open-vm-tools: upgrade to 11.1.0
* Enable aarch64 Signed-off-by: odidev <odidev@puresoftware.com>
-rw-r--r--community/open-vm-tools/0009-gnu-ucontext.patch68
-rw-r--r--community/open-vm-tools/APKBUILD13
-rwxr-xr-x[-rw-r--r--]community/open-vm-tools/tools.conf.patch42
3 files changed, 33 insertions, 90 deletions
diff --git a/community/open-vm-tools/0009-gnu-ucontext.patch b/community/open-vm-tools/0009-gnu-ucontext.patch
deleted file mode 100644
index 77c4f8e158d..00000000000
--- a/community/open-vm-tools/0009-gnu-ucontext.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 33835208753a350a71a130837ad9e2289fd4cf2c Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 18 Nov 2015 10:27:51 +0000
-Subject: [PATCH 09/12] gnu-ucontext
-
----
- open-vm-tools/lib/include/sigPosixRegs.h | 24 ++++++++++++------------
- 1 file changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/open-vm-tools/lib/include/sigPosixRegs.h b/open-vm-tools/lib/include/sigPosixRegs.h
-index ee36da59..88d327a7 100644
---- a/open-vm-tools/lib/include/sigPosixRegs.h
-+++ b/open-vm-tools/lib/include/sigPosixRegs.h
-@@ -36,7 +36,7 @@
- extern "C" {
- #endif
-
--#if __linux__ // We need the REG_foo offsets in the gregset_t;
-+#if defined(__GLIBC__) // We need the REG_foo offsets in the gregset_t;
- # define _GNU_SOURCE // _GNU_SOURCE maps to __USE_GNU
-
- /* And, the REG_foo definitions conflict with our own in x86.h */
-@@ -74,7 +74,7 @@ extern "C" {
- #include <signal.h>
- #include <sys/ucontext.h>
-
--#if __linux__ && !defined __ANDROID__
-+#if defined(__GLIBC__)
- # if defined(__x86_64__)
- # undef REG_RAX
- # undef REG_RBX
-@@ -200,7 +200,7 @@ extern "C" {
- #define SC_ESP(uc) ((unsigned long) (uc)->uc_mcontext.mc_esp)
- #define SC_EIP(uc) ((unsigned long) (uc)->uc_mcontext.mc_eip)
- #endif
--#elif defined (sun)
-+#elif !defined (__GLIBC__)
- #ifdef __x86_64__
- #define SC_EAX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_RAX])
- #define SC_EBX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_RBX])
-@@ -220,15 +220,15 @@ extern "C" {
- #define SC_R14(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_R14])
- #define SC_R15(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_R15])
- #else
--#define SC_EAX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EAX])
--#define SC_EBX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EBX])
--#define SC_ECX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[ECX])
--#define SC_EDX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EDX])
--#define SC_EDI(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EDI])
--#define SC_ESI(uc) ((unsigned long) (uc)->uc_mcontext.gregs[ESI])
--#define SC_EBP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EBP])
--#define SC_ESP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[ESP])
--#define SC_EIP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EIP])
-+#define SC_EAX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EAX])
-+#define SC_EBX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EBX])
-+#define SC_ECX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_ECX])
-+#define SC_EDX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EDX])
-+#define SC_EDI(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EDI])
-+#define SC_ESI(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_ESI])
-+#define SC_EBP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EBP])
-+#define SC_ESP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_ESP])
-+#define SC_EIP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EIP])
- #endif
- #elif defined(ANDROID_X86)
- #define SC_EAX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EAX])
---
-2.19.1
-
diff --git a/community/open-vm-tools/APKBUILD b/community/open-vm-tools/APKBUILD
index a7ae66eff02..50069b36ab2 100644
--- a/community/open-vm-tools/APKBUILD
+++ b/community/open-vm-tools/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
pkgname=open-vm-tools
-pkgver=11.0.5
+pkgver=11.1.0
_pkgsubver=${pkgver#*_p}
_ver=${pkgver/_p/-}
pkgrel=3
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="https://github.com/vmware/open-vm-tools/"
-arch="x86 x86_64"
+arch="aarch64 x86 x86_64"
license="LGPL-2.1-or-later"
subpackages="
$pkgname-dbg
@@ -60,7 +60,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/vmware/open-vm-tools/archive
0006-Use-configure-to-test-for-feature-instead-of-platfor.patch
0007-Use-configure-test-for-sys-stat.h-include.patch
0008-Rename-poll.h-to-vm_poll.h.patch
- 0009-gnu-ucontext.patch
0010-use-posix-strerror_r-unless-gnu.patch
0011-use-off64_t-instead-of-loff_t.patch
strerror_r.patch
@@ -133,9 +132,6 @@ package() {
chmod -x "$confdir"/*.conf*
mv "$confdir"/tools.conf.example "$confdir"/tools.conf
- mkdir -p ./usr/sbin
- mv "$confdir"/vm-support ./usr/sbin/vm-support
-
# *-vm-default scripts are identical and they are not supposed to be
# modified by the user, so move the script to /usr/share and symlink back.
mkdir -p "$sharedir"
@@ -257,7 +253,7 @@ _all() {
mkdir -p "$subpkgdir"
}
-sha512sums="c09e5b66f318273c712880f8b8bfe9782f6302e798808eb588f643cfca763b6805d5672a95fc3c87bf18dd4549f7a0cdebf9b9ca313cf761a72864748895fab9 open-vm-tools-11.0.5.tar.gz
+sha512sums="6bde66b5ff854d9b07439f9641b1c62a17a0bb5b31123c7b317dcbcdbfa361e95deb3865b01c6ebceb4e2ffecae1d633058fff2b17f1aa5a5a28ea0945dc88bf open-vm-tools-11.1.0.tar.gz
fe56bb4a57f228081d28dede1f25d6de73fcdb9276a704354d24711aaf47fe2399f81202afd0a33f6eeda1117067fea0cfc9e3eb97e35a3a7fddfa54056c273f 0001-lib-misc-Recognize-Alpine-Linux.patch
9188161f9bbd6572ee20855e727257b2140b39f1ba19b96879eb9878fb08cbdb7c3a5c9f5f8a4f389090acea6f71ee88fb36c7d4a74c1b8b94c9124db696a7f2 0002-open-vm-tools-Add-disable-werror-configure-option.patch
1dd0cde6ee19aec77ddf803e95b0404e803569a38c7b3d001832b4bbeae95ea15ed32c59f27bffb315130bad0c7a788a7a522df13a5f265f66c4c7c302a1966d 0003-Do-not-assume-that-linux-and-gnu-libc-are-the-same-t.patch
@@ -266,7 +262,6 @@ c647561c72b3ad919502ec4dd0a1ab736e2d479d8437b882791adce5417d8c26163ecffe9e212dab
4d6ce73d7e3fa554e31d7956b26e1d0341b57ff477d3e1386f30d7e1acb38cf3f6d8a3f918a484f64acf3e5c0f2ef898027963b8b87949669d3308eb9c185d82 0006-Use-configure-to-test-for-feature-instead-of-platfor.patch
9d28eab3e1a40138efa05e78956a2615b171703f9689252d0960145e39b0ba5bbf0e2007479cbbca3dced89ccb45758908a57a2f5b361e4813ad67a0732e4539 0007-Use-configure-test-for-sys-stat.h-include.patch
03579b28ecc446c6a16256be8b53dcb9b5f90d05ea52aad77997f2a7957d63af546182872b2ad2ed2f99904a22be23fc64ced4ecac91a53646d9946bd6d13625 0008-Rename-poll.h-to-vm_poll.h.patch
-88a8dcb785723c6120aed19e46c7f9890858a4b60db4a86e97fe4babf7b0d8babb3b3294f9d6c0004c6ae0c75860c3a624e6446f6e0d1a23bb92578f92120352 0009-gnu-ucontext.patch
6c8b99f51bc0fd114ce66a3311f151efbe56ec308d079afec837b9d0b60eae3fb42e1b5219246c1015a23fb63616398b958e1388830b80d5efdb27cce7bd6552 0010-use-posix-strerror_r-unless-gnu.patch
a38bb2ac16657be9f7e9b2a5e32d23e66db1f283284c1cb8e7ffe853e047373397e60f01e735a28ecfaa60010f285b0b5a4066465a2afbe643a9b4b9b74ac1f4 0011-use-off64_t-instead-of-loff_t.patch
5507a58198179805e4c924b6bd6ac8b026bd602c9e5e4c52213dadf6c8880a23a16ee49a4dfe2db27515c2a36009e609dd81b7ee0d560bbea1ddf6a5324eb7ac strerror_r.patch
@@ -275,7 +270,7 @@ c18280eb3fdfe1e3ecc5aa116369908c71917bd4dd49743a9abf78e0096e8d6c7d4323057cf506ef
dbcec24beafbbe94c8ed12482f9d0c643a6bbec256198cdc898513410271a3e2c0b7e35b0997ee0e91b1567f4ed0ecf44740b8c972dd5b2fc4bf21643653153a fix-mount.vmhgfs-symlink.patch
87057ae614d34af2e5581f31b5e028363f316bce4e255b5199438bade96891e798160424aee5804314280773de98ed514fcac7a790bec1f1ae63f3daa1fbef9c change-default-log-dir.patch
6494fe94f332706a130dd12afa18b881f6b6c4e0523570ff866e1678e37af6bd6148c4cf7d957e12f8dc2a51b4f07aa849c4e947911bcbe20d0c81049a2b6974 change-statechange.subr-location.patch
-44d4f149bdb15b364c5a11657514f432dba7d3fd35907cb58b3c47d54165f439d7775db128f8b476e9f7002d9741cb11d4cba83ce8998db003bfad761c4db710 tools.conf.patch
+7413aa360c8b2d74ee92a95b4003f15da78a04fcefda59bc97c9200de5c008ad7fce71751f67d8e7d0301fbde5b262b99a7ea6d80b45623b646a522410207291 tools.conf.patch
0feef314fc178922f86fdb072fc46ae0932aa59085b8263beecc1ad53c9bec04967b0d7fa62ab1051e65685b03bba80ccb075fe01c0ac67591c81f38131176b2 use-libtirpc-nokrb.patch
1248234f19a29b28b6a75886b39d1579d0f94d43925db1f709b7a05907582f6650b78d39155e7da335f27b6da00586b9c3dc3ca7e4cab19dba5c84cfefd1e6cb open-vm-tools.initd
f996fc598d01ea778797674fca2a9f467d7ce7ced50e4e0343b3d53bea65770df488b1a286e42603d91e05ba85610161eb68e3fbaa5cbf1757a8aec81869a677 open-vm-tools.confd
diff --git a/community/open-vm-tools/tools.conf.patch b/community/open-vm-tools/tools.conf.patch
index c0a084e4527..0ffbc33a792 100644..100755
--- a/community/open-vm-tools/tools.conf.patch
+++ b/community/open-vm-tools/tools.conf.patch
@@ -1,8 +1,19 @@
-Remove Windows-only stuff and fix default paths.
+From d1bd7d0d8e9ae6ee96c10b34ef770848080b81dd Mon Sep 17 00:00:00 2001
+From: Linux User <odidev@puresoftware.com>
+Date: Mon, 13 Apr 2020 08:23:26 +0000
+Subject: [PATCH] tools.conf Update the tool.conf patch to support 11.1-x
+ release
+Signed-off-by: Linux User <odidev@puresoftware.com>
+---
+ open-vm-tools/tools.conf | 72 ++++++----------------------------------
+ 1 file changed, 11 insertions(+), 61 deletions(-)
+
+diff --git a/open-vm-tools/tools.conf b/open-vm-tools/tools.conf
+index a697e118..4588b0be 100644
--- a/open-vm-tools/tools.conf
+++ b/open-vm-tools/tools.conf
-@@ -65,10 +65,7 @@
+@@ -67,10 +67,7 @@
# Log destinations for various services
# By default, logs go to
@@ -14,7 +25,7 @@ Remove Windows-only stuff and fix default paths.
# Possible values for handler are:
# file: logs to a file. Set *.data to the file name
-@@ -80,7 +77,6 @@
+@@ -82,7 +79,6 @@
# std: Logs to stdout for level >= 'message',
# and to stderr for more severe than 'message'.
# syslog: logs to syslog
@@ -22,7 +33,7 @@ Remove Windows-only stuff and fix default paths.
# If handler is 'syslog' and the OS is Linux, the facility
# can be set with <domain>.facility. The facility value can be one of
-@@ -97,33 +93,33 @@
+@@ -99,33 +95,33 @@
# Enable tools service logging to a file.
#vmtoolsd.level = debug
#vmtoolsd.handler = file
@@ -62,7 +73,7 @@ Remove Windows-only stuff and fix default paths.
# Enable "hgfsServer" request handling logging to the appropriate service file.
#hgfsServer.level = debug
-@@ -158,18 +154,11 @@
+@@ -160,18 +156,11 @@
#poweroff-script=poweroff-vm-default
# Runs when the virtual machine is resumed after it was suspended.
@@ -83,7 +94,7 @@ Remove Windows-only stuff and fix default paths.
#suspend-script=suspend-vm-default
[guestinfo]
-@@ -203,8 +192,6 @@
+@@ -205,8 +194,6 @@
# Interface names can use wildcards like '*' and '?'.
# Default for Linux and all non-Windows:
#exclude-nics=veth*,docker*,virbr*
@@ -92,7 +103,7 @@ Remove Windows-only stuff and fix default paths.
# max umber of IPv4 routes to gather.
#max-ipv4-routes=100
-@@ -216,25 +203,10 @@
+@@ -218,25 +205,10 @@
#diskinfo-include-reserved=false
@@ -118,7 +129,7 @@ Remove Windows-only stuff and fix default paths.
#enable=true
[guestosinfo]
-@@ -247,12 +219,8 @@
+@@ -249,12 +221,8 @@
[vmbackup]
@@ -131,7 +142,7 @@ Remove Windows-only stuff and fix default paths.
# See https://kb.vmware.com/s/article/2146204
# can be used to fallback to FS quiescing forcely when there are app quiescing
# problems for specific Windows systems
-@@ -261,7 +229,6 @@
+@@ -263,7 +231,6 @@
#execScripts=true
#scriptArg=
@@ -139,7 +150,7 @@ Remove Windows-only stuff and fix default paths.
# The value of excludedFileSystems is a comma-separated list of glob-style
# patterns specifying the file systems to be excluded from quiesced snapshots.
# The patterns may use '*' (wildcard) to represent any string of characters
-@@ -271,12 +238,8 @@
+@@ -273,12 +240,8 @@
#excludedFileSystems=
# Whether to execute scripts on quiescing.
@@ -154,11 +165,10 @@ Remove Windows-only stuff and fix default paths.
# "/usr/sbin/pre-freeze-script"
# "/usr/sbin/post-thaw-script"
#
-@@ -295,17 +258,3 @@
-
+@@ -298,19 +261,6 @@
# Whether to use vgauth for guest op authentication
#useVGAuth=true
--
+
-[autoupgrade]
-
-# The autoupgrade plugin is only available for Windows.
@@ -172,3 +182,9 @@ Remove Windows-only stuff and fix default paths.
-#allow-add-feature=true
-#allow-remove-feature=true
-
+ [deployPkg]
+
+ # to disable guest customization
+--
+2.24.1
+