aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Berthault <justin.berthault@zaclys.net>2020-10-27 22:30:09 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-10-27 23:00:28 +0000
commit4d21d542c3c957cbd8a8e605570f599f4fdf0ba2 (patch)
tree99f209ae63720e6ab37eacc944b444b433022460
parent200099d0663c982a1dd9781bb6f478c5e0a670e8 (diff)
testing/wordgrinder: upgrade to 0.8
-rw-r--r--testing/wordgrinder/APKBUILD9
-rw-r--r--testing/wordgrinder/fixes-musl.patch28
2 files changed, 12 insertions, 25 deletions
diff --git a/testing/wordgrinder/APKBUILD b/testing/wordgrinder/APKBUILD
index 7c8e19ea996..bfb24d14da3 100644
--- a/testing/wordgrinder/APKBUILD
+++ b/testing/wordgrinder/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=wordgrinder
-pkgver=0.7.2
+pkgver=0.8
pkgrel=0
pkgdesc="A simple Unicode-aware word processor that runs on the console"
url="https://cowlark.com/wordgrinder/"
@@ -13,12 +13,9 @@ options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/davidgiven/wordgrinder/archive/$pkgver.tar.gz
fixes-musl.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-
package() {
- cd "$builddir"
make install PREFIX=/usr DESTDIR="$pkgdir"
}
-sha512sums="abf3fbeec25e557c780af9b633634d22214e20ae56aebe6574c97ba3d5e8d1adc985329ecf7930370f644d9762d064fb99ac8b64a5c95fa8e5ac6e14627f4d23 wordgrinder-0.7.2.tar.gz
-559eb2c04ba950fa72a0474e6bb74d2fbe64e8322af13d9b15622bde93013d0b8adba30fda2fa8e0f1e86ba1b7a28c238c5284c98685f118117314e2dea9b4ed fixes-musl.patch"
+sha512sums="192e21381dc7644ca1682fe2c5984f97675c7727b84971559625c4a30da28699164d62168022f9de76ec3250ecab32e65a720585c19c2105685d79c8c33a4d2b wordgrinder-0.8.tar.gz
+46a344f663c82bd538d48be05f4453eec2a1c0e6459c610560fb891eba6d24b2900d08761f10c3c396b0c38e5baba28ae8108b59c14def03f604d07bf7a3c593 fixes-musl.patch"
diff --git a/testing/wordgrinder/fixes-musl.patch b/testing/wordgrinder/fixes-musl.patch
index 491993181a2..37731c169d5 100644
--- a/testing/wordgrinder/fixes-musl.patch
+++ b/testing/wordgrinder/fixes-musl.patch
@@ -1,23 +1,13 @@
+diff --git a/src/c/arch/unix/cursesw/dpy.c b/src/c/arch/unix/cursesw/dpy.c
+index e9931bd..6345c89 100644
--- a/src/c/arch/unix/cursesw/dpy.c
+++ b/src/c/arch/unix/cursesw/dpy.c
-@@ -114,7 +114,7 @@
- {
- struct timeval then;
- gettimeofday(&then, NULL);
-- u_int64_t thenms = (then.tv_usec/1000) + ((u_int64_t) then.tv_sec*1000);
-+ uint64_t thenms = (then.tv_usec/1000) + ((uint64_t) then.tv_sec*1000);
+@@ -12,6 +12,8 @@
- for (;;)
- {
-@@ -123,9 +123,9 @@
- {
- struct timeval now;
- gettimeofday(&now, NULL);
-- u_int64_t nowms = (now.tv_usec/1000) + ((u_int64_t) now.tv_sec*1000);
-+ uint64_t nowms = (now.tv_usec/1000) + ((uint64_t) now.tv_sec*1000);
-
-- int delay = ((u_int64_t) timeout*1000) + nowms - thenms;
-+ int delay = ((uint64_t) timeout*1000) + nowms - thenms;
- if (delay <= 0)
- return -KEY_TIMEOUT;
+ #define KEY_TIMEOUT (KEY_MAX + 1)
++typedef uint64_t u_int64_t;
++
+ #if defined A_ITALIC
+ static bool has_italics = false;
+ #endif