aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2022-12-16 19:20:42 +0100
committerMichał Polański <michal@polanski.me>2022-12-16 19:20:42 +0100
commit4e440143f1b74ae9dea4b0b82246f533abf7f150 (patch)
tree4a4058828b6006d8467efecf1b436f51ababf1c7
parent252710a0673edfb063033bc6273f74fc9a983001 (diff)
community/basu: upgrade to 0.2.1
-rw-r--r--community/basu/APKBUILD15
-rw-r--r--community/basu/allow-both-shared-and-static-lib.patch13
-rw-r--r--community/basu/link-basuctl-with-libbasu-dynamically.patch30
3 files changed, 5 insertions, 53 deletions
diff --git a/community/basu/APKBUILD b/community/basu/APKBUILD
index 9850c9c0f25..5b54a9dbe6c 100644
--- a/community/basu/APKBUILD
+++ b/community/basu/APKBUILD
@@ -1,18 +1,15 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=basu
-pkgver=0.2.0
-pkgrel=3
+pkgver=0.2.1
+pkgrel=0
pkgdesc="The sd-bus library, extracted from systemd"
url="https://sr.ht/~emersion/basu/"
license="LGPL-2.1-or-later"
arch="all"
makedepends="audit-dev gperf libcap-dev meson"
subpackages="$pkgname-static $pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~emersion/basu/archive/v$pkgver.tar.gz
- allow-both-shared-and-static-lib.patch
- link-basuctl-with-libbasu-dynamically.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~emersion/basu/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
build() {
@@ -20,7 +17,7 @@ build() {
-Dsystem-bus-address="unix:path=/run/dbus/system_bus_socket" \
-Ddefault_library=both \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
@@ -32,7 +29,5 @@ package() {
}
sha512sums="
-c9ccb1aff4522752b06c14b49508513cf3d3295559160ac6278ca3140049ea9e4ba89394ef2837e5d8150f31431b50237480fbc71e0a70f1c0155d2419a2853b basu-0.2.0.tar.gz
-ce3edb36ec08012deeab1616a1df20f0bcbb7157a0b544b188ee1ccbe0f2cbcff8dd23b7f36bc1f75c993ff8409bd57d9bbe3bde1f4ba575b669bbe085f97cb3 allow-both-shared-and-static-lib.patch
-172c6e519fcee29edff010423487a93f4e7e144836bf0d1e92181b5518e6a1c4e477f5d971e7cf93314b69d33674a5ae69cd963f0dd876496c34dd1fb0047020 link-basuctl-with-libbasu-dynamically.patch
+b1f6a35e4d93d099c5c92a8ea68f8a93429a614f1a63de7346e256437525bee5b87c1a5ad2e0dad2ff0bdc88b525cf1931f048e032bd1f1ff007b4d5eee90c59 basu-0.2.1.tar.gz
"
diff --git a/community/basu/allow-both-shared-and-static-lib.patch b/community/basu/allow-both-shared-and-static-lib.patch
deleted file mode 100644
index 926d3075c31..00000000000
--- a/community/basu/allow-both-shared-and-static-lib.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-See https://mesonbuild.com/Build-targets.html
-
---- a/meson.build
-+++ b/meson.build
-@@ -304,7 +304,7 @@
- endforeach
-
- libsystemd_sym_path = '@0@/@1@'.format(meson.current_source_dir(), libsystemd_sym)
--libsystemd = shared_library(
-+libsystemd = library(
- 'basu',
- soversion : soversion,
- include_directories : includes,
diff --git a/community/basu/link-basuctl-with-libbasu-dynamically.patch b/community/basu/link-basuctl-with-libbasu-dynamically.patch
deleted file mode 100644
index 113b6bde983..00000000000
--- a/community/basu/link-basuctl-with-libbasu-dynamically.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 34471140993750d4af0da3f8feef77801276db36 Mon Sep 17 00:00:00 2001
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Fri, 17 Sep 2021 22:36:55 +0200
-Subject: [PATCH] meson: Link basuctl with libbasu dynamically
-
-This reduces the installed size significantly. I don't know about any
-reason for bundling libbasu in basuctl when they both come from the
-same package.
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Patch-Source: https://git.sr.ht/~emersion/basu/commit/34471140993750d4af0da3f8feef77801276db36
-
-diff --git a/meson.build b/meson.build
-index 121c0b9..056c7c4 100644
---- a/meson.build
-+++ b/meson.build
-@@ -330,7 +330,7 @@ exe = executable('basuctl',
- 'src/busctl/busctl-introspect.h',
- include_directories : includes,
- link_with : [libbasic,
-- libsystemd_static],
-+ libsystemd],
- install : true)
-
- meson.override_dependency('basu', declare_dependency(
---
-2.32.0
-