aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-02-22 20:38:00 +0000
committerpsykose <alice@ayaya.dev>2023-02-22 21:38:00 +0100
commit4f1e933eedd805fb9851238477eeb1febfdcc3ff (patch)
tree14d602a2bf0adde110853d282831f9aad385dbf8
parent192a854cffd61f2770b204aa860e2a8225f70047 (diff)
main/cups: use find -exec
-rw-r--r--main/cups/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/cups/APKBUILD b/main/cups/APKBUILD
index b7b46ded03d..b882fcf68e2 100644
--- a/main/cups/APKBUILD
+++ b/main/cups/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cups
pkgver=2.4.2
-pkgrel=3
+pkgrel=4
pkgdesc="The CUPS Printing System"
url="https://github.com/OpenPrinting/cups/"
arch="all"
@@ -89,7 +89,8 @@ package() {
sed -i 's|^Exec=htmlview http://localhost:631/|Exec=xdg-open http://localhost:631/|g' \
usr/share/applications/cups.desktop
fi
- find usr/share/cups/model -name "*.ppd" | xargs gzip -n9f
+ find usr/share/cups/model \( -name "*.ppd" -a ! -name "*.gz" \) \
+ -exec gzip -n9f {} \+
}
dev() {