aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Marz <main@lmarz.org>2023-01-14 14:16:48 +0100
committeralice <alice@ayaya.dev>2023-01-14 15:50:11 +0000
commit5061d123e9424e9c8e08db41eb8e30a5dff2adf2 (patch)
treeab20959f36987b09086f09bfe852b35f00ca671b
parent53cd27aec499478a2b4748611a4a987398e7d3aa (diff)
main/a*: update licenses
-rw-r--r--main/abi-compliance-checker/APKBUILD4
-rw-r--r--main/altermime/APKBUILD6
-rw-r--r--main/apache-mod-auth-radius/APKBUILD4
-rw-r--r--main/apcupsd/APKBUILD4
-rw-r--r--main/api-sanity-checker/APKBUILD4
-rw-r--r--main/apparmor/APKBUILD4
-rw-r--r--main/argon2/APKBUILD4
-rw-r--r--main/argp-standalone/APKBUILD4
-rw-r--r--main/arpwatch/APKBUILD4
-rw-r--r--main/asciidoc/APKBUILD4
-rw-r--r--main/aspell-de/APKBUILD4
-rw-r--r--main/aspell-fr/APKBUILD4
-rw-r--r--main/aspell-ru/APKBUILD4
-rw-r--r--main/aspell-uk/APKBUILD4
-rw-r--r--main/aspell/APKBUILD4
-rw-r--r--main/at-spi2-core/APKBUILD4
-rw-r--r--main/attr/APKBUILD4
-rw-r--r--main/audit/APKBUILD4
-rw-r--r--main/augeas/APKBUILD4
-rw-r--r--main/automake/APKBUILD4
-rw-r--r--main/avahi-ui/APKBUILD4
21 files changed, 42 insertions, 44 deletions
diff --git a/main/abi-compliance-checker/APKBUILD b/main/abi-compliance-checker/APKBUILD
index 6a5fa5b20fa..016bda307b0 100644
--- a/main/abi-compliance-checker/APKBUILD
+++ b/main/abi-compliance-checker/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=abi-compliance-checker
pkgver=2.3
-pkgrel=1
+pkgrel=2
pkgdesc="A tool for checking backward compatibility of a C/C++ library"
url="https://github.com/lvc/abi-compliance-checker"
arch="noarch"
-license="LGPL-2.0-or-later"
+license="LGPL-2.1-or-later"
depends="perl build-base"
makedepends="perl-dev"
options="!check"
diff --git a/main/altermime/APKBUILD b/main/altermime/APKBUILD
index b6249a10319..1c21c8eb13b 100644
--- a/main/altermime/APKBUILD
+++ b/main/altermime/APKBUILD
@@ -3,11 +3,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=altermime
pkgver=0.3.11
-pkgrel=2
+pkgrel=3
pkgdesc="alterMIME - MIME encoded email pack alteration tool"
url="https://pldaniels.com/altermime"
arch="all"
-license="custom:altermime"
+license="BSD-2-Clause"
# no check provided by upstream
options="!check"
subpackages="$pkgname-doc"
@@ -20,8 +20,6 @@ build() {
package() {
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
- install -Dm644 LICENCE \
- "$pkgdir"/usr/share/licenses/$pkgname/LICENCE
install -Dm644 README \
"$pkgdir"/usr/share/doc/$pkgname/README
}
diff --git a/main/apache-mod-auth-radius/APKBUILD b/main/apache-mod-auth-radius/APKBUILD
index 4cd0bafa390..afec6eadee0 100644
--- a/main/apache-mod-auth-radius/APKBUILD
+++ b/main/apache-mod-auth-radius/APKBUILD
@@ -3,11 +3,11 @@
pkgname=apache-mod-auth-radius
_pkgname=mod_auth_radius
pkgver=1.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Apache authentication module to become RADIUS client for AAA requests"
url="http://freeradius.org/mod_auth_radius/"
arch="all"
-license="BSD"
+license="Apache-1.0"
depends="apache2"
makedepends="apache2-dev freeradius-dev"
options="!check"
diff --git a/main/apcupsd/APKBUILD b/main/apcupsd/APKBUILD
index cdaf52a7ad0..4256ea236fb 100644
--- a/main/apcupsd/APKBUILD
+++ b/main/apcupsd/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apcupsd
pkgver=3.14.14
-pkgrel=3
+pkgrel=4
pkgdesc="A Daemon to control APC UPSes"
subpackages="$pkgname-doc $pkgname-webif $pkgname-openrc"
url="http://www.apcupsd.org"
arch="all"
-license="GPL-2.0-only"
+license="GPL-2.0-or-later"
depends="util-linux"
makedepends="net-snmp-dev linux-headers gd-dev libusb-compat-dev"
options="!check" # no test suite included
diff --git a/main/api-sanity-checker/APKBUILD b/main/api-sanity-checker/APKBUILD
index 3fae8b00a77..ba723a957e7 100644
--- a/main/api-sanity-checker/APKBUILD
+++ b/main/api-sanity-checker/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=api-sanity-checker
pkgver=1.98.7
-pkgrel=2
+pkgrel=3
pkgdesc="A tool for creating automated test suites from any set of C sources"
url="https://lvc.github.io/api-sanity-checker/"
arch="noarch"
-license="LGPL-2.0-or-later"
+license="LGPL-2.1-or-later"
depends="perl build-base"
makedepends="perl-dev abi-compliance-checker"
source="$pkgname-$pkgver.tar.gz::https://github.com/lvc/api-sanity-checker/archive/$pkgver.tar.gz"
diff --git a/main/apparmor/APKBUILD b/main/apparmor/APKBUILD
index fc06bea1965..8c906842c75 100644
--- a/main/apparmor/APKBUILD
+++ b/main/apparmor/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Allan Garret <allan.garret@gmail.com>
pkgname=apparmor
pkgver=3.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Linux application security framework - mandatory access control for programs"
url="https://gitlab.com/apparmor/apparmor/wikis/home"
arch="all"
-license="GPL-2.0-only"
+license="GPL-2.0-or-later"
depends="bash"
makedepends="
autoconf
diff --git a/main/argon2/APKBUILD b/main/argon2/APKBUILD
index 40d1211f549..f278aaa53bb 100644
--- a/main/argon2/APKBUILD
+++ b/main/argon2/APKBUILD
@@ -4,11 +4,11 @@
pkgname=argon2
_pkgname=phc-winner-argon2
pkgver=20190702
-pkgrel=2
+pkgrel=3
pkgdesc="The password hash Argon2, winner of PHC"
url="https://github.com/P-H-C/phc-winner-argon2"
arch="all"
-license="Apache-2.0 CC0-1.0"
+license="Apache-2.0 OR CC0-1.0"
subpackages="$pkgname-static $pkgname-dev $pkgname-libs"
source="$pkgname-$pkgver.tar.gz::https://github.com/P-H-C/$_pkgname/archive/$pkgver.tar.gz
"
diff --git a/main/argp-standalone/APKBUILD b/main/argp-standalone/APKBUILD
index e08b84006d0..4dc43fae938 100644
--- a/main/argp-standalone/APKBUILD
+++ b/main/argp-standalone/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=argp-standalone
pkgver=1.5.0
-pkgrel=0
+pkgrel=1
pkgdesc="Hierarchial argument parsing library broken out from glibc"
url="http://www.lysator.liu.se/~nisse/misc/"
arch="all"
-license="GPL-2.0-or-later"
+license="LGPL-2.1-or-later"
makedepends="libtool automake autoconf"
source="$pkgname-$pkgver.tar.gz::https://github.com/argp-standalone/argp-standalone/archive/refs/tags/$pkgver.tar.gz
gnu89-inline.patch"
diff --git a/main/arpwatch/APKBUILD b/main/arpwatch/APKBUILD
index 22860803d70..77ea4114c3d 100644
--- a/main/arpwatch/APKBUILD
+++ b/main/arpwatch/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=arpwatch
pkgver=3.3
-pkgrel=0
+pkgrel=1
pkgdesc="Ethernet monitoring program"
url="https://www-nrg.ee.lbl.gov/"
arch="all"
-license="BSD-4-Clause-Shortened"
+license="BSD-3-Clause"
pkgusers="arpwatch"
depends="python3"
makedepends="libpcap-dev"
diff --git a/main/asciidoc/APKBUILD b/main/asciidoc/APKBUILD
index 6b8c31bf97c..68c68ad6f1c 100644
--- a/main/asciidoc/APKBUILD
+++ b/main/asciidoc/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=asciidoc
pkgver=10.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Text based documentation"
url="https://asciidoc.org/"
arch="noarch"
-license="GPL-2.0-or-later AND GPL-1.0-or-later"
+license="GPL-2.0-or-later AND MIT"
depends="python3 libxml2-utils docbook-xsl"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-pytest-mock"
diff --git a/main/aspell-de/APKBUILD b/main/aspell-de/APKBUILD
index 7f94b3789d1..78d4665e09d 100644
--- a/main/aspell-de/APKBUILD
+++ b/main/aspell-de/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=aspell-de
pkgver=20161207
-pkgrel=0
+pkgrel=1
_lang=${pkgname##*-}
_name=${pkgname%%-*}6-$_lang-$pkgver-7-0
pkgdesc="German dictionary for aspell"
url="http://aspell.net/"
arch="noarch"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
options="!check" # No test suite
makedepends="aspell-dev"
source="https://ftp.gnu.org/gnu/aspell/dict/$_lang/$_name.tar.bz2"
diff --git a/main/aspell-fr/APKBUILD b/main/aspell-fr/APKBUILD
index 927ef05db09..4ef9b33884e 100644
--- a/main/aspell-fr/APKBUILD
+++ b/main/aspell-fr/APKBUILD
@@ -2,11 +2,11 @@
pkgname=aspell-fr
pkgver=0.50_p3
_ver=${pkgver/_p/-}
-pkgrel=2
+pkgrel=3
pkgdesc="French dictionary for aspell"
url="http://aspell.net/"
arch="noarch"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
makedepends="aspell-dev"
source="https://ftp.gnu.org/gnu/aspell/dict/fr/aspell-fr-$_ver.tar.bz2"
builddir="$srcdir"/aspell-fr-$_ver
diff --git a/main/aspell-ru/APKBUILD b/main/aspell-ru/APKBUILD
index 7e48a71991e..ab15085bef1 100644
--- a/main/aspell-ru/APKBUILD
+++ b/main/aspell-ru/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=aspell-ru
pkgver=0.99f7
-pkgrel=1
+pkgrel=2
_lang=${pkgname##*-}
_name=${pkgname%%-*}6-$_lang-$pkgver-1
pkgdesc="Russian dictionary for aspell"
url="http://aspell.net/"
arch="noarch"
-license="GPL-2.0"
+license="custom"
options="!check" # No test suite
makedepends="aspell-dev"
source="https://ftp.gnu.org/gnu/aspell/dict/$_lang/$_name.tar.bz2"
diff --git a/main/aspell-uk/APKBUILD b/main/aspell-uk/APKBUILD
index fc1d9984173..06c887039df 100644
--- a/main/aspell-uk/APKBUILD
+++ b/main/aspell-uk/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=aspell-uk
pkgver=1.4.0
-pkgrel=2
+pkgrel=3
_lang=${pkgname##*-}
_name=${pkgname%%-*}6-$_lang-$pkgver-0
pkgdesc="Ukrainian dictionary for aspell"
url="http://aspell.net/"
arch="noarch"
-license="GPL-2.0"
+license="LGPL-2.0-or-later"
options="!check" # No test suite
makedepends="aspell-dev"
source="https://ftp.gnu.org/gnu/aspell/dict/$_lang/$_name.tar.bz2"
diff --git a/main/aspell/APKBUILD b/main/aspell/APKBUILD
index cf7a667ed61..eb885f40294 100644
--- a/main/aspell/APKBUILD
+++ b/main/aspell/APKBUILD
@@ -2,11 +2,11 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=aspell
pkgver=0.60.8
-pkgrel=3
+pkgrel=4
pkgdesc="A spell checker designed to eventually replace Ispell"
url="http://aspell.net/"
arch="all"
-license="LGPL-2.0-or-later"
+license="LGPL-2.1-or-later"
subpackages="$pkgname-compat::noarch $pkgname-utils $pkgname-dev $pkgname-doc
$pkgname-lang $pkgname-libs"
depends_dev="$pkgname-utils"
diff --git a/main/at-spi2-core/APKBUILD b/main/at-spi2-core/APKBUILD
index 6ee2b291c63..03cf3b07768 100644
--- a/main/at-spi2-core/APKBUILD
+++ b/main/at-spi2-core/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=at-spi2-core
pkgver=2.46.0
-pkgrel=0
+pkgrel=1
pkgdesc="Protocol definitions and daemon for D-Bus at-spi"
url="https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
arch="all"
options="!check" # Requires running dbus daemon.
-license="LGPL-2.0-or-later"
+license="LGPL-2.1-or-later"
makedepends="
dbus-dev
glib-dev
diff --git a/main/attr/APKBUILD b/main/attr/APKBUILD
index cb6764dc5d9..b36dd775d90 100644
--- a/main/attr/APKBUILD
+++ b/main/attr/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=attr
pkgver=2.5.1
-pkgrel=2
+pkgrel=3
pkgdesc="utilities for managing filesystem extended attributes"
options="checkroot !check" # attr.test fails with no error message
url="https://savannah.nongnu.org/projects/attr"
arch="all"
-license="GPL-2.0-or-later"
+license="LGPL-2.1-or-later"
checkdepends="perl"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc lib$pkgname:libs"
source="https://download.savannah.nongnu.org/releases/attr/attr-$pkgver.tar.gz"
diff --git a/main/audit/APKBUILD b/main/audit/APKBUILD
index 68133d12000..e23a8a08bba 100644
--- a/main/audit/APKBUILD
+++ b/main/audit/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Tycho Andersen <tycho@docker.com>
pkgname=audit
pkgver=3.0.9
-pkgrel=0
+pkgrel=1
pkgdesc="User space tools for kernel auditing"
url="https://people.redhat.com/sgrubb/audit/"
arch="all"
-license="GPL-2.0-or-later"
+license="LGPL-2.1-or-later"
depends_dev="linux-headers"
makedepends="$depends_dev swig libcap-ng-dev python3"
install="$pkgname.pre-install"
diff --git a/main/augeas/APKBUILD b/main/augeas/APKBUILD
index b8cdd567ec8..01cd365fd2b 100644
--- a/main/augeas/APKBUILD
+++ b/main/augeas/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=augeas
pkgver=1.12.0
-pkgrel=1
+pkgrel=2
pkgdesc="A configuration editing tool"
url="http://augeas.net"
arch="all"
-license="LGPL-2.0-or-later"
+license="LGPL-2.1-or-later"
makedepends="autoconf automake libxml2-dev readline-dev libtool"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-tests::noarch $pkgname-libs"
source="http://download.augeas.net/augeas-$pkgver.tar.gz
diff --git a/main/automake/APKBUILD b/main/automake/APKBUILD
index 62f4606eb36..e12a3bccd4a 100644
--- a/main/automake/APKBUILD
+++ b/main/automake/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=automake
pkgver=1.16.5
-pkgrel=1
+pkgrel=2
pkgdesc="GNU tool for automatically creating Makefiles"
url="https://www.gnu.org/software/automake"
arch="noarch"
-license="GPL-2.0-or-later MIT Public-Domain"
+license="GPL-2.0-or-later"
depends="perl"
makedepends="autoconf"
subpackages="$pkgname-doc"
diff --git a/main/avahi-ui/APKBUILD b/main/avahi-ui/APKBUILD
index d5d9e3e3aa1..11ea4a7965f 100644
--- a/main/avahi-ui/APKBUILD
+++ b/main/avahi-ui/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=avahi-ui
pkgver=0.8
-pkgrel=3
+pkgrel=4
pkgdesc="Gtk user interface library for Avahi"
url="https://www.avahi.org/"
arch="all"
-license="LGPL-2.0-or-later"
+license="LGPL-2.1-or-later"
depends_dev="gdbm-dev"
makedepends="$depends_dev py3-gobject3-dev py3-dbus-dev intltool libevent-dev
gobject-introspection-dev expat-dev libdaemon-dev glib-dev dbus-dev