aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-10-18 05:28:31 -0600
committerAriadne Conill <ariadne@dereferenced.org>2020-10-18 05:29:43 -0600
commit5096451ea1b76ed4c239e68b967164e1b03a0e2b (patch)
tree978ab6a58fccc0db7ad90f87df0229d07cd20f5b
parent11f87b10431e708983f9404d89825c04b0edaa2e (diff)
downloadaports-5096451ea1b76ed4c239e68b967164e1b03a0e2b.tar.gz
aports-5096451ea1b76ed4c239e68b967164e1b03a0e2b.tar.bz2
aports-5096451ea1b76ed4c239e68b967164e1b03a0e2b.tar.xz
community: disable most kde stuff on mips64
-rw-r--r--community/baloo/APKBUILD2
-rw-r--r--community/frameworkintegration/APKBUILD2
-rw-r--r--community/kbookmarks/APKBUILD2
-rw-r--r--community/kcmutils/APKBUILD2
-rw-r--r--community/kdav/APKBUILD2
-rw-r--r--community/kdeclarative/APKBUILD2
-rw-r--r--community/kdelibs4support/APKBUILD2
-rw-r--r--community/kdesignerplugin/APKBUILD2
-rw-r--r--community/khtml/APKBUILD2
-rw-r--r--community/kinit/APKBUILD2
-rw-r--r--community/kio/APKBUILD2
-rw-r--r--community/kmediaplayer/APKBUILD2
-rw-r--r--community/knewstuff/APKBUILD2
-rw-r--r--community/knotifyconfig/APKBUILD2
-rw-r--r--community/kparts/APKBUILD2
-rw-r--r--community/kross/APKBUILD2
-rw-r--r--community/krunner/APKBUILD2
-rw-r--r--community/ktexteditor/APKBUILD2
-rw-r--r--community/kwallet/APKBUILD2
-rw-r--r--community/kxmlgui/APKBUILD2
-rw-r--r--community/kxmlrpcclient/APKBUILD2
-rw-r--r--community/plasma-framework/APKBUILD2
-rw-r--r--community/purpose/APKBUILD2
-rw-r--r--community/qqc2-desktop-style/APKBUILD2
-rw-r--r--community/solid/APKBUILD2
25 files changed, 25 insertions, 25 deletions
diff --git a/community/baloo/APKBUILD b/community/baloo/APKBUILD
index 41bc7c2ba6..7800a337e1 100644
--- a/community/baloo/APKBUILD
+++ b/community/baloo/APKBUILD
@@ -4,7 +4,7 @@ pkgname=baloo
pkgver=5.75.0
pkgrel=0
pkgdesc="A framework for searching and managing metadata"
-arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by qt5-qtdeclarative and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="qt5-qtdeclarative-dev lmdb-dev kcoreaddons-dev kconfig-dev kdbusaddons-dev ki18n-dev kidletime-dev solid-dev kfilemetadata-dev kcrash-dev kio-dev kservice-dev kbookmarks-dev kcompletion-dev kjobwidgets-dev"
diff --git a/community/frameworkintegration/APKBUILD b/community/frameworkintegration/APKBUILD
index 0fff2daee2..1fe69534a6 100644
--- a/community/frameworkintegration/APKBUILD
+++ b/community/frameworkintegration/APKBUILD
@@ -4,7 +4,7 @@ pkgname=frameworkintegration
pkgver=5.75.0
pkgrel=0
pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://www.kde.org"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kconfig-dev kconfigwidgets-dev kiconthemes-dev knotifications-dev knewstuff-dev kwidgetsaddons-dev kpackage-dev ki18n-dev appstream-dev"
diff --git a/community/kbookmarks/APKBUILD b/community/kbookmarks/APKBUILD
index 53928d3f60..6603f2b9b1 100644
--- a/community/kbookmarks/APKBUILD
+++ b/community/kbookmarks/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kbookmarks
pkgver=5.75.0
pkgrel=0
pkgdesc="Support for bookmarks and the XBEL format"
-arch="all !armhf !mips !mips64 !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kconfig-dev kcoreaddons-dev kcodecs-dev kconfigwidgets-dev kwidgetsaddons-dev kxmlgui-dev"
diff --git a/community/kcmutils/APKBUILD b/community/kcmutils/APKBUILD
index be597dae03..ae18d5f2cf 100644
--- a/community/kcmutils/APKBUILD
+++ b/community/kcmutils/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kcmutils
pkgver=5.75.0
pkgrel=0
pkgdesc="Utilities for interacting with KCModules"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="kitemviews-dev kconfigwidgets-dev kcoreaddons-dev ki18n-dev kiconthemes-dev kservice-dev kxmlgui-dev kdeclarative-dev"
diff --git a/community/kdav/APKBUILD b/community/kdav/APKBUILD
index 104d9f3b44..218e4278da 100644
--- a/community/kdav/APKBUILD
+++ b/community/kdav/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.75.0
pkgrel=0
pkgdesc="A DAV protocol implementation with KJobs"
url="https://community.kde.org/Frameworks"
-arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by qt5-qtdeclarative and mips64, s390x blocked by polkit
license="LGPL-2.0-or-later"
depends_dev="qt5-qtbase-dev qt5-qtxmlpatterns-dev kcoreaddons-dev kio-dev ki18n-dev"
makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
diff --git a/community/kdeclarative/APKBUILD b/community/kdeclarative/APKBUILD
index 9b8433a559..6c4a1c1c0d 100644
--- a/community/kdeclarative/APKBUILD
+++ b/community/kdeclarative/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kdeclarative
pkgver=5.75.0
pkgrel=0
pkgdesc="Provides integration of QML and KDE Frameworks"
-arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by qt5-qtdeclarative and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtdeclarative-dev kconfig-dev ki18n-dev kiconthemes-dev kio-dev kwidgetsaddons-dev kwindowsystem-dev kglobalaccel-dev kguiaddons-dev kpackage-dev libepoxy-dev"
diff --git a/community/kdelibs4support/APKBUILD b/community/kdelibs4support/APKBUILD
index a5bb6fbd4e..cf12e15616 100644
--- a/community/kdelibs4support/APKBUILD
+++ b/community/kdelibs4support/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kdelibs4support
pkgver=5.75.0
pkgrel=0
pkgdesc="Porting aid from KDELibs4"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND MIT AND LGPL-2.1-only AND LGPL-2.0-only AND (LGPL-2.1-only OR LGPL-3.0-only) AND (LGPL-2.0-only OR LGPL-3.0-only)"
depends_dev="qt5-qtbase-dev qt5-qttools-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kcrash-dev kdesignerplugin kdesignerplugin-dev kglobalaccel-dev kemoticons-dev kguiaddons-dev ki18n-dev kiconthemes-dev kio-dev knotifications-dev kparts-dev kservice-dev ktextwidgets-dev kunitconversion-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kdbusaddons-dev kded-dev kinit-dev perl-uri kdoctools-dev kitemmodels-dev"
diff --git a/community/kdesignerplugin/APKBUILD b/community/kdesignerplugin/APKBUILD
index d63bef76a2..d0c2539b11 100644
--- a/community/kdesignerplugin/APKBUILD
+++ b/community/kdesignerplugin/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kdesignerplugin
pkgver=5.75.0
pkgrel=0
pkgdesc="Integration of Frameworks widgets in Qt Designer/Creator"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only"
depends_dev="kcoreaddons-dev kconfig-dev kcompletion-dev kconfigwidgets-dev kiconthemes-dev kio-dev kitemviews-dev kplotting-dev ktextwidgets-dev kwidgetsaddons-dev kxmlgui-dev sonnet-dev"
diff --git a/community/khtml/APKBUILD b/community/khtml/APKBUILD
index 8b1dbdba99..b549535a8a 100644
--- a/community/khtml/APKBUILD
+++ b/community/khtml/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="The KDE HTML library, ancestor of WebKit"
# ppc64le: CMakeFiles/kmultipart.dir/kmultipart.cpp.o uses 64-bit long double,
# /usr/lib/gcc/powerpc64le-alpine-linux-musl/10.2.0/../../../../lib/libgcc_s.so.1 uses 128-bit long double
-arch="all !armhf !s390x !ppc64le" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !s390x !mips64 !ppc64le" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND LGPL-2.1-only"
depends_dev="qt5-qtbase-dev perl-dev giflib-dev libjpeg-turbo-dev karchive-dev
diff --git a/community/kinit/APKBUILD b/community/kinit/APKBUILD
index 51d68ba2df..555899dbdf 100644
--- a/community/kinit/APKBUILD
+++ b/community/kinit/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kinit
pkgver=5.75.0
pkgrel=0
pkgdesc="Process launcher to speed up launching KDE applications"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="qt5-qtbase-dev libcap-dev kservice-dev kio-dev ki18n-dev kwindowsystem-dev kcrash-dev kconfig-dev"
diff --git a/community/kio/APKBUILD b/community/kio/APKBUILD
index e86c4cfe34..dcb5c8458c 100644
--- a/community/kio/APKBUILD
+++ b/community/kio/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kio
pkgver=5.75.0
pkgrel=0
pkgdesc="Resource and network access abstraction"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="
diff --git a/community/kmediaplayer/APKBUILD b/community/kmediaplayer/APKBUILD
index 1b19251a81..d47fb6e4e1 100644
--- a/community/kmediaplayer/APKBUILD
+++ b/community/kmediaplayer/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kmediaplayer
pkgver=5.75.0
pkgrel=0
pkgdesc="Media player framework for KDE 5"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="X11 AND LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kparts-dev kxmlgui-dev"
diff --git a/community/knewstuff/APKBUILD b/community/knewstuff/APKBUILD
index 3939f4a188..54b670a878 100644
--- a/community/knewstuff/APKBUILD
+++ b/community/knewstuff/APKBUILD
@@ -4,7 +4,7 @@ pkgname=knewstuff
pkgver=5.75.0
pkgrel=0
pkgdesc="Framework for downloading and sharing additional application data"
-arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by qt5-qtdeclarative and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends="kirigami2"
diff --git a/community/knotifyconfig/APKBUILD b/community/knotifyconfig/APKBUILD
index d48a8a9730..4ffcbc7149 100644
--- a/community/knotifyconfig/APKBUILD
+++ b/community/knotifyconfig/APKBUILD
@@ -4,7 +4,7 @@ pkgname=knotifyconfig
pkgver=5.75.0
pkgrel=0
pkgdesc="Configuration system for KNotify"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-only"
depends_dev="kcompletion-dev kconfig-dev ki18n-dev kio-dev"
diff --git a/community/kparts/APKBUILD b/community/kparts/APKBUILD
index 9dd9f4a844..adde972e4a 100644
--- a/community/kparts/APKBUILD
+++ b/community/kparts/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kparts
pkgver=5.75.0
pkgrel=0
pkgdesc="Document centric plugin system"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="qt5-qtbase-dev kconfig-dev kcoreaddons-dev ki18n-dev kiconthemes-dev
diff --git a/community/kross/APKBUILD b/community/kross/APKBUILD
index ca52fa7778..a591286dcc 100644
--- a/community/kross/APKBUILD
+++ b/community/kross/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kross
pkgver=5.75.0
pkgrel=0
pkgdesc="Framework for scripting KDE applications"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev qt5-qttools-dev kcompletion-dev kcoreaddons-dev ki18n-dev kiconthemes-dev kio-dev kparts-dev kwidgetsaddons-dev kxmlgui-dev"
diff --git a/community/krunner/APKBUILD b/community/krunner/APKBUILD
index 07e00be920..ee615ab1f6 100644
--- a/community/krunner/APKBUILD
+++ b/community/krunner/APKBUILD
@@ -4,7 +4,7 @@ pkgname=krunner
pkgver=5.75.0
pkgrel=0
pkgdesc="Framework for providing different actions given a string query"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kconfig-dev kcoreaddons-dev ki18n-dev kio-dev
diff --git a/community/ktexteditor/APKBUILD b/community/ktexteditor/APKBUILD
index 71225e9349..90bbdb440a 100644
--- a/community/ktexteditor/APKBUILD
+++ b/community/ktexteditor/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ktexteditor
pkgver=5.75.0
pkgrel=0
pkgdesc="Advanced embeddable text editor"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND (LGPL-2.0-only OR LGPL-3.0-only)"
depends_dev="karchive-dev kconfig-dev kguiaddons-dev ki18n-dev kio-dev kparts-dev sonnet-dev kiconthemes-dev syntax-highlighting-dev kauth-dev"
diff --git a/community/kwallet/APKBUILD b/community/kwallet/APKBUILD
index 46bfa332d3..def26a5a4c 100644
--- a/community/kwallet/APKBUILD
+++ b/community/kwallet/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kwallet
pkgver=5.75.0
pkgrel=0
pkgdesc="Secure and unified container for user passwords"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="libgcrypt-dev kcoreaddons-dev kconfig-dev kwindowsystem-dev ki18n-dev kconfigwidgets-dev kdbusaddons-dev kiconthemes-dev knotifications-dev kservice-dev"
diff --git a/community/kxmlgui/APKBUILD b/community/kxmlgui/APKBUILD
index dc6678a887..92cc6e107e 100644
--- a/community/kxmlgui/APKBUILD
+++ b/community/kxmlgui/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kxmlgui
pkgver=5.75.0
pkgrel=0
pkgdesc="User configurable main windows"
-arch="all !armhf !mips !mips64 !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kcoreaddons-dev kitemviews-dev kconfig-dev kconfigwidgets-dev ki18n-dev kiconthemes-dev ktextwidgets-dev kwidgetsaddons-dev kwindowsystem-dev attica-dev kglobalaccel-dev"
diff --git a/community/kxmlrpcclient/APKBUILD b/community/kxmlrpcclient/APKBUILD
index c4307b7e60..0b05f598fd 100644
--- a/community/kxmlrpcclient/APKBUILD
+++ b/community/kxmlrpcclient/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kxmlrpcclient
pkgver=5.75.0
pkgrel=0
pkgdesc="XML-RPC client library for KDE"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://projects.kde.org/projects/kde/pim/kxmlrpcclient"
license="BSD-2-Clause"
depends_dev="ki18n-dev kio-dev"
diff --git a/community/plasma-framework/APKBUILD b/community/plasma-framework/APKBUILD
index f51cdedade..ceac6088e9 100644
--- a/community/plasma-framework/APKBUILD
+++ b/community/plasma-framework/APKBUILD
@@ -4,7 +4,7 @@ pkgname=plasma-framework
pkgver=5.75.0
pkgrel=0
pkgdesc="Plasma library and runtime components based upon KF5 and Qt5"
-arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by qt5-qtdeclarative and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND GPL-2.0-or-later"
depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev kactivities-dev karchive-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev kdeclarative-dev kglobalaccel-dev kguiaddons-dev ki18n-dev kiconthemes-dev kio-dev kservice-dev kwindowsystem-dev kxmlgui-dev knotifications-dev kpackage-dev kirigami2-dev kwayland-dev"
diff --git a/community/purpose/APKBUILD b/community/purpose/APKBUILD
index 2e1d860a38..344763fde0 100644
--- a/community/purpose/APKBUILD
+++ b/community/purpose/APKBUILD
@@ -4,7 +4,7 @@ pkgname=purpose
pkgver=5.75.0
pkgrel=0
pkgdesc="Framework for providing abstractions to get the developer's purposes fulfilled"
-arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by qt5-qtdeclarative and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
diff --git a/community/qqc2-desktop-style/APKBUILD b/community/qqc2-desktop-style/APKBUILD
index eadba56e37..1de09eccc3 100644
--- a/community/qqc2-desktop-style/APKBUILD
+++ b/community/qqc2-desktop-style/APKBUILD
@@ -4,7 +4,7 @@ pkgname=qqc2-desktop-style
pkgver=5.75.0
pkgrel=0
pkgdesc="A style for Qt Quick Controls 2 to make it follow your desktop theme"
-arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by qt5-qtdeclarative and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-3.0-only AND (GPL-2.0-only OR GPL-3.0-only)"
depends="qt5-qtgraphicaleffects qt5-qtquickcontrols2"
diff --git a/community/solid/APKBUILD b/community/solid/APKBUILD
index 5a030ed241..370d0ca819 100644
--- a/community/solid/APKBUILD
+++ b/community/solid/APKBUILD
@@ -4,7 +4,7 @@ pkgname=solid
pkgver=5.75.0
pkgrel=0
pkgdesc="Hardware integration and detection"
-arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
+arch="all !armhf !mips64 !s390x" # armhf blocked by qt5-qtdeclarative and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="qt5-qtdeclarative-dev"