aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-19 16:31:02 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-19 16:40:32 +0100
commit5257f7c249810eb910301dede62c601181afbce4 (patch)
tree11881cce93c28c9a3361b446f629b75a4690abd6
parent6c38e4fa4bc3c6cece3314ef9584dd0df95d1c27 (diff)
main/py3-idna: drop python2
-rw-r--r--main/py3-idna/APKBUILD39
1 files changed, 10 insertions, 29 deletions
diff --git a/main/py3-idna/APKBUILD b/main/py3-idna/APKBUILD
index 4c3057baf5f..61d2e90df14 100644
--- a/main/py3-idna/APKBUILD
+++ b/main/py3-idna/APKBUILD
@@ -1,46 +1,27 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-idna
+pkgname=py3-idna
_pkgname=idna
pkgver=2.8
-pkgrel=2
-pkgdesc="IDNA 2008 and UTS #46 for Python"
+pkgrel=3
+pkgdesc="IDNA 2008 and UTS #46 for Python3"
url="https://github.com/kjd/idna"
arch="noarch"
-license="BSD"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
source="idna-$pkgver.tar.gz::https://github.com/kjd/idna/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-idna" # Backwards compatibility
+provides="py-idna=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="848ca6a2630da1cfd9c4657854d71dc060f31fdd1f687ce35fd10467ca08ab29223bae521999aabde44ef777724bd5f5c2b5f362109c2c531c2ad6358ed1f3d6 idna-2.8.tar.gz"