aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-03-13 22:09:45 +0000
committerpsykose <alice@ayaya.dev>2023-03-13 23:12:44 +0100
commit52e4c50de6c949e250fc1d8a97ae6e84ea1e2203 (patch)
tree90e5de19d145ae3477194cf350415ee944a82603
parentdb0112dcf323537c0d96d325068a27aad3243d96 (diff)
main/git: upgrade to 2.40.0
-rw-r--r--main/git/APKBUILD10
-rw-r--r--main/git/segfault-bundle-fix.patch73
2 files changed, 4 insertions, 79 deletions
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index 651ef19e7ca..180d49a670d 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -43,7 +43,7 @@
# - CVE-2021-46101
pkgname=git
-pkgver=2.39.2
+pkgver=2.40.0
pkgrel=0
pkgdesc="Distributed version control system"
url="https://www.git-scm.com/"
@@ -64,12 +64,12 @@ makedepends="
subpackages="
$pkgname-dbg
$pkgname-bash-completion
- $pkgname-prompt
+ $pkgname-prompt::noarch
perl-$pkgname-svn:_perl_git_svn:noarch
perl-$pkgname:_perl_git:noarch
$pkgname-svn::noarch
$pkgname-email
- $pkgname-fast-import:_fast_import
+ $pkgname-fast-import:_fast_import:noarch
$pkgname-cvs::noarch
$pkgname-daemon
$pkgname-daemon-openrc:daemon_openrc
@@ -84,7 +84,6 @@ source="https://www.kernel.org/pub/software/scm/git/git-$pkgver.tar.xz
git-daemon.initd
git-daemon.confd
fix-t4219-with-sticky-bit.patch
- segfault-bundle-fix.patch
"
_gitcoredir=/usr/libexec/git-core
@@ -362,9 +361,8 @@ _perl_config() {
}
sha512sums="
-fdca70bee19401c5c7a6d2f3d70bd80b6ba99f6a9f97947de31d4366ee3a78a18d5298abb25727ec8ef67131bca673e48dff2a5a050b6e032884ab04066b20cb git-2.39.2.tar.xz
+a2720f8f9a0258c0bb5e23badcfd68a147682e45a5d039a42c47128296c508109d5039029db89311a35db97a9008585e84ed11b400846502c9be913d67f0fd90 git-2.40.0.tar.xz
89528cdd14c51fd568aa61cf6c5eae08ea0844e59f9af9292da5fc6c268261f4166017d002d494400945e248df6b844e2f9f9cd2d9345d516983f5a110e4c42a git-daemon.initd
fbf1f425206a76e2a8f82342537ed939ff7e623d644c086ca2ced5f69b36734695f9f80ebda1728f75a94d6cd2fcb71bf845b64239368caab418e4d368c141ec git-daemon.confd
be5d568fc5b8b84c9afb97b31e471e41f32ccfe188eba0588ea0ef98b2d96c2ce4b2c1a3d70e88205aa4f6667f850b3f32c13bbb149ecddbf670344c162a4e25 fix-t4219-with-sticky-bit.patch
-e036d717f49ebe192aafd73eef4c6b5bdc8a93e342b45478d630e4b5e1f04ac916cefe87b05f7783efc5ca9086895a5df4eefffd42be95683c86fbf58a08bb39 segfault-bundle-fix.patch
"
diff --git a/main/git/segfault-bundle-fix.patch b/main/git/segfault-bundle-fix.patch
deleted file mode 100644
index 64c95ddf160..00000000000
--- a/main/git/segfault-bundle-fix.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-Patch-Source: https://github.com/git/git/commit/891cb09db6c0e6bf11b8175bc5ea5f45493afb85
-From 891cb09db6c0e6bf11b8175bc5ea5f45493afb85 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?=C3=86var=20Arnfj=C3=B6r=C3=B0=20Bjarmason?=
- <avarab@gmail.com>
-Date: Tue, 20 Dec 2022 14:40:18 +0100
-Subject: [PATCH] bundle: don't segfault on "git bundle <subcmd>"
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Since aef7d75e580 (builtin/bundle.c: let parse-options parse
-subcommands, 2022-08-19) we've been segfaulting if no argument was
-provided.
-
-The fix is easy, as all of the "git bundle" subcommands require a
-non-option argument we can check that we have arguments left after
-calling parse-options().
-
-This makes use of code added in 73c3253d75e (bundle: framework for
-options before bundle file, 2019-11-10), before this change that code
-has always been unreachable. In 73c3253d75e we'd never reach it as we
-already checked "argc < 2" in cmd_bundle() itself.
-
-Then when aef7d75e580 (whose segfault we're fixing here) migrated this
-code to the subcommand API it removed that "argc < 2" check, but we
-were still checking the wrong "argc" in parse_options_cmd_bundle(), we
-need to check the "newargc". The "argc" will always be >= 1, as it
-will necessarily contain at least the subcommand name
-itself (e.g. "create").
-
-As an aside, this could be safely squashed into this, but let's not do
-that for this minimal segfault fix, as it's an unrelated refactoring:
-
-Reported-by: Hubert Jasudowicz <hubertj@stmcyber.pl>
-Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com>
-Tested-by: Hubert Jasudowicz <hubertj@stmcyber.pl>
-Signed-off-by: Junio C Hamano <gitster@pobox.com>
----
- builtin/bundle.c | 2 +-
- t/t6020-bundle-misc.sh | 7 +++++++
- 2 files changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/builtin/bundle.c b/builtin/bundle.c
-index c12c09f..61c7628 100644
---- a/builtin/bundle.c
-+++ b/builtin/bundle.c
-@@ -58,7 +58,7 @@ static int parse_options_cmd_bundle(int argc,
- int newargc;
- newargc = parse_options(argc, argv, NULL, options, usagestr,
- PARSE_OPT_STOP_AT_NON_OPTION);
-- if (argc < 1)
-+ if (!newargc)
- usage_with_options(usagestr, options);
- *bundle_file = prefix_filename(prefix, argv[0]);
- return newargc;
-diff --git a/t/t6020-bundle-misc.sh b/t/t6020-bundle-misc.sh
-index 8332051..3a1cf30 100755
---- a/t/t6020-bundle-misc.sh
-+++ b/t/t6020-bundle-misc.sh
-@@ -11,6 +11,13 @@ export GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME
- . ./test-lib.sh
- . "$TEST_DIRECTORY"/lib-bundle.sh
-
-+for cmd in create verify list-heads unbundle
-+do
-+ test_expect_success "usage: git bundle $cmd needs an argument" '
-+ test_expect_code 129 git bundle $cmd
-+ '
-+done
-+
- # Create a commit or tag and set the variable with the object ID.
- test_commit_setvar () {
- notick=