aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2023-05-01 16:28:27 +0000
committerpsykose <alice@ayaya.dev>2023-05-01 18:28:27 +0200
commit54ab01ff5526f44a8e886532066df8707b43f86f (patch)
tree780e206f9343dc94edaa43346074d739efa4fe63
parentb85a5a5012bded1f852c5d5deaa8f5c0efd260de (diff)
community/py3-paste: upgrade to 3.5.3
* https://github.com/cdent/paste/blob/3.5.3/docs/news.txt
-rw-r--r--community/py3-paste/APKBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/community/py3-paste/APKBUILD b/community/py3-paste/APKBUILD
index 675bb571d63..62fd791c373 100644
--- a/community/py3-paste/APKBUILD
+++ b/community/py3-paste/APKBUILD
@@ -1,30 +1,42 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-paste
-pkgver=3.5.2
-pkgrel=2
+pkgver=3.5.3
+pkgrel=0
pkgdesc="Tools for using a Web Server Gateway Interface stack"
url="https://pythonpaste.readthedocs.io/en/latest/"
arch="noarch"
license="MIT"
-depends="py3-setuptools py3-six"
+depends="
+ py3-setuptools
+ py3-six
+ "
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
checkdepends="py3-pytest"
subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/P/Paste/Paste-$pkgver.tar.gz"
builddir="$srcdir/Paste-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONWARNINGS="ignore::DeprecationWarning" pytest
+ python3 -m venv --clear --without-pip --system-site-packages testenv
+ testenv/bin/python3 -m installer dist/*.whl
+ testenv/bin/python3 -m pytest -p no:warnings
}
package() {
- python3 setup.py install --skip-build --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ dist/*.whl
}
sha512sums="
-a1920dbd7ebea137ca33f8f8c33aad563329d1eea193d84e6aa7fc57690f706c1969e3ba76bbf21a73c59a0fe0f732daa4db15705914ac359814b4332a01bc75 py3-paste-3.5.2.tar.gz
+3087ea7b6cc45a90b85c473cbff7f018ca961536ff70fbed4610f86dedc82cef0274ccddb767de411ec2955d0c265cb4e797a14a25697870c38667ccd7c4a2d8 py3-paste-3.5.3.tar.gz
"