aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-11 06:35:52 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-11 06:35:52 -0300
commit580842dac7baabca3d2698112e3f3be766af8abe (patch)
treec1ec9ce6f125bb8aec18a30d3496ae61fce116f3
parent25dc12c69371e662cd89ee5b667fc7f92ea84543 (diff)
testing/zchunk: remove
-rw-r--r--testing/zchunk/APKBUILD47
-rw-r--r--testing/zchunk/fix-musl.patch18
2 files changed, 0 insertions, 65 deletions
diff --git a/testing/zchunk/APKBUILD b/testing/zchunk/APKBUILD
deleted file mode 100644
index c290b6f90f6..00000000000
--- a/testing/zchunk/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
-pkgname=zchunk
-pkgver=1.1.3
-pkgrel=0
-pkgdesc="File format for highly efficient deltas"
-url="https://github.com/zchunk/zchunk"
-arch="all"
-license="BSD-2-Clause"
-makedepends="
- meson
- zstd-dev
- curl-dev
- openssl-dev
- argp-standalone
- "
-subpackages="$pkgname-dev lib$pkgname:libs"
-source="
- $pkgname-$pkgver.tar.gz::https://github.com/zchunk/zchunk/archive/$pkgver.tar.gz
- fix-musl.patch
- "
-
-build() {
- LDFLAGS="$LDFLAGS -largp" \
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=release \
- -Dwith-zstd=enabled \
- -Dwith-openssl=enabled \
- -Dcoverity=false \
- . output
- ninja -C output
-}
-
-check() {
- ninja -C output test
-}
-
-package() {
- DESTDIR="$pkgdir" ninja -C output install
-}
-
-sha512sums="564c2e2718ae2e50d1fa32a99ddfb126685abb1050b3884803c89e78a94d5b265cec1cd0ddbff927cdc2bab1d7c15971244f525081ca4d8d9581675e3e16fd5b zchunk-1.1.3.tar.gz
-d35f72d42d5d00189ad732f232b8eee5a347832517229bc9272acf98edb0886a6b581c801005f61a054d70b35c457e9ca0fd3dee524958c92eaf5ea80f40d68a fix-musl.patch"
diff --git a/testing/zchunk/fix-musl.patch b/testing/zchunk/fix-musl.patch
deleted file mode 100644
index 766745bb5bd..00000000000
--- a/testing/zchunk/fix-musl.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/include/zck.h.in.orig 2018-08-03 07:08:45.140103751 +0200
-+++ b/include/zck.h.in 2018-08-03 07:09:18.613105487 +0200
-@@ -1,3 +1,4 @@
-+#include <sys/types.h>
- #ifndef ZCK_H
- #define ZCK_H
-
---- a/src/unzck.c 2018-08-02 15:42:19.000000000 +0200
-+++ b/src/unzck.c 2018-08-04 20:20:53.438164577 +0200
-@@ -39,7 +39,7 @@
- #include <zck.h>
-
- #include "util_common.h"
--
-+#undef stdout
- static char doc[] = "unzck - Decompress a zchunk file";
-
- static char args_doc[] = "<file>";