aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-10-23 12:48:22 +0200
committerBart Ribbers <bribbers@disroot.org>2021-10-23 21:22:31 +0200
commit582df05a8fd3c058fc9cf9e9dd5e30473812e36a (patch)
treedb971477a0b55eee6c0e236e14440970d1bfcd37
parentcaf16fb5ca147aa09e7f39ef1bdc4e152d9681c1 (diff)
main/py3-requests: switch py3-chardet dep for py3-charset-normalizer
Upstream changed to a maintained alternative to py3-chardet but this seems to have been forgotten or ignored while upgrading py3-requests
-rw-r--r--main/py3-requests/0002-allow-idna-3.patch15
-rw-r--r--main/py3-requests/APKBUILD21
2 files changed, 10 insertions, 26 deletions
diff --git a/main/py3-requests/0002-allow-idna-3.patch b/main/py3-requests/0002-allow-idna-3.patch
deleted file mode 100644
index b7fc7ba1b17..00000000000
--- a/main/py3-requests/0002-allow-idna-3.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-According to https://github.com/psf/requests/pull/5711
-
-diff --git a/setup.py b/setup.py
-index 065eb22..3b7b229 100755
---- a/setup.py
-+++ b/setup.py
-@@ -43,7 +43,7 @@ packages = ['requests']
-
- requires = [
- 'chardet>=3.0.2,<5',
-- 'idna>=2.5,<3',
-+ 'idna>=2.5,<3.3',
- 'urllib3>=1.21.1,<1.27',
-
- ]
diff --git a/main/py3-requests/APKBUILD b/main/py3-requests/APKBUILD
index 39aff2daf25..bb022ea8ca6 100644
--- a/main/py3-requests/APKBUILD
+++ b/main/py3-requests/APKBUILD
@@ -1,21 +1,24 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-requests
-_pkgname=requests
pkgver=2.26.0
-pkgrel=0
+pkgrel=1
pkgdesc="HTTP request library for Python3"
url="http://www.python-requests.org/"
arch="noarch"
license="Apache-2.0"
# Requirements for tests are not available in main
options="!check"
-depends="python3 py3-chardet py3-idna py3-urllib3 py3-certifi"
+depends="
+ py3-certifi
+ py3-charset-normalizer
+ py3-idna
+ py3-urllib3
+ python3
+ "
makedepends="py3-setuptools"
-source="
- https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
-"
-builddir="$srcdir/$_pkgname-$pkgver"
+source="https://files.pythonhosted.org/packages/source/r/requests/requests-$pkgver.tar.gz"
+builddir="$srcdir/requests-$pkgver"
replaces="py-requests" # Backwards compatibility
provides="py-requests=$pkgver-r$pkgrel" # Backwards compatibility
@@ -28,8 +31,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="
-ca6b0a257b448a999cade0ae173c29cddc9cfffb319d16fc3d051d3e1cd77161536e3cab279b3cba59c60d29d7864a9281c1fa1f689ce48d3bce2ca9f1cd8d45 requests-2.25.1.tar.gz
-28ea1bdfd897833d2563474979c0b6f2965d61c5cc29768e60592f4d36c7df6d7fa8408a424f99db332f898fb487c4b7b110884a04f6180d4b73646299d9c019 0002-allow-idna-3.patch
-"
sha512sums="c3397d77f0d2f1afb05661c4b98adad6c1ddaf360906254150b33ab0d9479fd306905bd6d61b8cf8becd9a40bdcf9b03542e8267c644ef19f03f44bfca0bc461 requests-2.26.0.tar.gz"