aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-05-12 08:40:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-06-18 11:57:36 +0200
commit5870790b9914ba17ed6160f674bd6ac52a78d037 (patch)
tree9cfa73585851db0d1b1860c99efe8f176e840f08
parent4a8b4cfd7e23fe2ce2a499a505ab0b6dc300e944 (diff)
main/sprunge: use https for tpaste.us
fixes tpaste which no longer work without https
-rw-r--r--main/sprunge/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/sprunge/APKBUILD b/main/sprunge/APKBUILD
index f663d800b9b..4d1f651abd2 100644
--- a/main/sprunge/APKBUILD
+++ b/main/sprunge/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sprunge
pkgver=0.6
-pkgrel=0
+pkgrel=1
pkgdesc="Helper script to paste things to http://sprunge.us"
url="http://sprunge.us"
arch="noarch"
@@ -33,10 +33,10 @@ package() {
tpaste() {
cd "$_builddir"
- url="http://tpaste.us"
+ url="https://tpaste.us"
pkgdesc="Helper script to paste things to $url"
mkdir -p "$subpkgdir"/usr/bin
- printf "#!/bin/sh\n\nexec curl -F 'tpaste=<-' http://tpaste.us" > \
+ printf "#!/bin/sh\n\nexec curl -F 'tpaste=<-' https://tpaste.us" > \
"$subpkgdir"/usr/bin/tpaste || return 1
chmod 755 "$subpkgdir"/usr/bin/tpaste || return 1
}