aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-12-04 13:57:15 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-12-06 00:42:28 -0300
commit58a0ffed5c52364cae0d984305b97aa3b2ad3a72 (patch)
tree62a4267cdb3e6429e201a20b02c2da75a95532d9
parent81ac161a23c473a374a5af7dd67b2efffa8e106e (diff)
testing/py3-autobahn: new aport
-rw-r--r--testing/py3-autobahn/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/py3-autobahn/APKBUILD b/testing/py3-autobahn/APKBUILD
new file mode 100644
index 00000000000..b04c8d7ca76
--- /dev/null
+++ b/testing/py3-autobahn/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-autobahn
+pkgver=20.7.1
+pkgrel=0
+pkgdesc="WebSocket client & server library, WAMP real-time framework"
+url="https://crossbar.io/autobahn/"
+arch="noarch"
+license="MIT"
+depends="
+ py3-txaio
+ py3-twisted
+ py3-sphinxcontrib-images
+ py3-pynacl
+ python3
+ "
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="https://pypi.python.org/packages/source/a/autobahn/autobahn-$pkgver.tar.gz"
+options="!check" # Fail to run https://github.com/crossbario/autobahn-python/issues/1117
+builddir="$srcdir/autobahn-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ find "$pkgdir" -name "test" -type d -exec rm -r {} +
+}
+
+sha512sums="e2c241194da90ada86a2804683cb063320f75a69b76ddc016349c11614e7f298619c2eeba4fcccb8f8d65d84375681fb339d9f92f94f45f1015f4f12fa0c39b0 autobahn-20.7.1.tar.gz"