aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2020-03-25 20:08:06 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-03-25 22:29:51 +0000
commit59a9f60bdf0f7294f9115255569c32b96b71b036 (patch)
tree233ecd2e298a873c06bb9ac8950da06d2ffa39f8
parentada1f76f5db57ee51ab1cd0ed6a6854a7102cd13 (diff)
main/speedtest-cli: fix build by adding py3-setuptools makedepends
and modify APKBUILD
-rw-r--r--main/speedtest-cli/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/main/speedtest-cli/APKBUILD b/main/speedtest-cli/APKBUILD
index f70021070bc..31fa952742e 100644
--- a/main/speedtest-cli/APKBUILD
+++ b/main/speedtest-cli/APKBUILD
@@ -8,22 +8,18 @@ url="https://github.com/sivel/speedtest-cli"
arch="noarch"
license="Apache-2.0"
depends="python3"
-makedepends="python3-dev"
+makedepends="py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/sivel/speedtest-cli/archive/v$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
-check() {
- cd "$builddir"
- python3 setup.py check
-}
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ python3 setup.py check
+}
+
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
install -Dm755 speedtest.py "$pkgdir"/usr/bin/speedtest-cli
}