aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2022-01-19 19:56:01 +0100
committerJakub Jirutka <jakub@jirutka.cz>2022-01-19 19:53:01 +0000
commit5a702cd7677907c3d080f9e4aa6d5b48a825013a (patch)
treedd7faae65aa6d8227e8d03ad689711ea6f1a28d8
parent6641c26e07c950e151a5ee8c5163f70b71a2b7a2 (diff)
community/flatpak: add post-install message about XDG directories
I took me a long time to figure out what is wrong, why I don't have access to ~/Downloads directory from Flatpacked Firefox on Sway desktop. xdg-user-dirs-update just creates config file `$XDG_CONFIG_HOME/user-dirs.dirs` that defines location of each well-known XDG directory and also creates these directories. It's a one-time thing, this config could be just copied from a template... That's why I'm not proposing to add it as a dependency of flatpak.
-rw-r--r--community/flatpak/APKBUILD2
-rw-r--r--community/flatpak/flatpak.post-install8
2 files changed, 9 insertions, 1 deletions
diff --git a/community/flatpak/APKBUILD b/community/flatpak/APKBUILD
index bc7f6473d48..acf187870f9 100644
--- a/community/flatpak/APKBUILD
+++ b/community/flatpak/APKBUILD
@@ -4,7 +4,7 @@
pkgname=flatpak
# Follows GNOME versioning, MINOR (the 2nd number) must be even.
pkgver=1.12.3
-pkgrel=0
+pkgrel=1
pkgdesc="Application deployment framework for desktop apps"
url="https://flatpak.org"
# s390x and riscv64 blocked by polkit
diff --git a/community/flatpak/flatpak.post-install b/community/flatpak/flatpak.post-install
index 62c42f3a992..492200d8332 100644
--- a/community/flatpak/flatpak.post-install
+++ b/community/flatpak/flatpak.post-install
@@ -2,4 +2,12 @@
modprobe fuse
+cat >&2 <<EOF
+*
+* To enable access to XDG directories (e.g. ~/Desktop, ~/Downloads, ...) in
+* Flatpak apps, run xdg-user-dirs-update (from xdg-user-dirs package) as a
+* regular user that will use Flatpak.
+*
+EOF
+
exit 0