aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2022-04-09 22:34:50 +0000
committeralice <alice@ayaya.dev>2022-04-10 01:51:40 +0000
commit5b1b8bc9d3d1e2418d9005b392f28d3f45eac880 (patch)
tree0699bfc1f2b9459e33b558e26645b42f7db2e147
parentb055ebab029cf5af4dddd7eb39328ca0965570e5 (diff)
community/plasma*: build with samurai and RelWithDebInfo
-rw-r--r--community/plasma-applet-weather-widget/APKBUILD7
-rw-r--r--community/plasma-bigscreen/APKBUILD7
-rw-r--r--community/plasma-browser-integration/APKBUILD7
-rw-r--r--community/plasma-camera/APKBUILD7
-rw-r--r--community/plasma-desktop/APKBUILD15
-rw-r--r--community/plasma-dialer/APKBUILD8
-rw-r--r--community/plasma-disks/APKBUILD8
-rw-r--r--community/plasma-firewall/APKBUILD8
-rw-r--r--community/plasma-framework/APKBUILD8
-rw-r--r--community/plasma-integration/APKBUILD7
-rw-r--r--community/plasma-mobile-sounds/APKBUILD6
-rw-r--r--community/plasma-mobile/APKBUILD7
-rw-r--r--community/plasma-nano/APKBUILD8
-rw-r--r--community/plasma-nm/APKBUILD8
-rw-r--r--community/plasma-pa/APKBUILD8
-rw-r--r--community/plasma-pass/APKBUILD12
-rw-r--r--community/plasma-phonebook/APKBUILD8
-rw-r--r--community/plasma-remotecontrollers/APKBUILD5
-rw-r--r--community/plasma-sdk/APKBUILD7
-rw-r--r--community/plasma-settings/APKBUILD8
-rw-r--r--community/plasma-systemmonitor/APKBUILD8
-rw-r--r--community/plasma-thunderbolt/APKBUILD7
-rw-r--r--community/plasma-vault/APKBUILD7
-rw-r--r--community/plasma-videoplayer/APKBUILD12
-rw-r--r--community/plasma-wayland-protocols/APKBUILD9
-rw-r--r--community/plasma-workspace-wallpapers/APKBUILD8
-rw-r--r--community/plasma-workspace/APKBUILD8
-rw-r--r--community/plasmatube/APKBUILD7
28 files changed, 133 insertions, 92 deletions
diff --git a/community/plasma-applet-weather-widget/APKBUILD b/community/plasma-applet-weather-widget/APKBUILD
index 232d67aa849..19d7dc93c78 100644
--- a/community/plasma-applet-weather-widget/APKBUILD
+++ b/community/plasma-applet-weather-widget/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-applet-weather-widget
pkgver=1.6.10
-pkgrel=4
+pkgrel=5
pkgdesc="Plasmoid for showing weather information from yr.no and Open Weather Map servers"
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by polkit -> plasma-framework
@@ -16,14 +16,15 @@ makedepends="
extra-cmake-modules
plasma-framework-dev
qt5-qtbase-dev
+ samurai
"
source="https://github.com/kotelnik/plasma-applet-weather-widget/archive/v$pkgver/plasma-applet-weather-widget-v$pkgver.tar.gz"
subpackages="$pkgname-lang"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
diff --git a/community/plasma-bigscreen/APKBUILD b/community/plasma-bigscreen/APKBUILD
index a83d9060bc0..d5cc2c452ca 100644
--- a/community/plasma-bigscreen/APKBUILD
+++ b/community/plasma-bigscreen/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-bigscreen
pkgver=0_git20220221
-pkgrel=0
+pkgrel=1
_commit="14769c61a9492e7007ddd123d0171da71107d232"
pkgdesc="A 10-feet interface made for TVs"
url="https://invent.kde.org/plasma/plasma-bigscreen/"
@@ -37,13 +37,14 @@ makedepends="
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtmultimedia-dev
+ samurai
"
source="https://invent.kde.org/plasma/plasma-bigscreen/-/archive/$_commit/plasma-bigscreen-$_commit.tar.gz"
builddir="$srcdir/plasma-bigscreen-$_commit"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
diff --git a/community/plasma-browser-integration/APKBUILD b/community/plasma-browser-integration/APKBUILD
index 9b27631fa09..693bbc4d9ad 100644
--- a/community/plasma-browser-integration/APKBUILD
+++ b/community/plasma-browser-integration/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-browser-integration
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="Components necessary to integrate browsers into the Plasma Desktop"
# armhf blocked by extra-cmake-modules
# s390x and riscv64 blocked by polkit -> kio
@@ -23,6 +23,7 @@ makedepends="
plasma-workspace-dev
purpose-dev
qt5-qtbase-dev
+ samurai
"
case "$pkgver" in
@@ -33,8 +34,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-browser-integration
subpackages="$pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
diff --git a/community/plasma-camera/APKBUILD b/community/plasma-camera/APKBUILD
index 4cf337e6a7c..93f0ce67abc 100644
--- a/community/plasma-camera/APKBUILD
+++ b/community/plasma-camera/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-camera
pkgver=1.0_git20210328
-pkgrel=0
+pkgrel=1
_commit="78c2e161c31b07be15f67c53bb556c3100a956b6"
pkgdesc="Camera application for Plasma Mobile"
# armhf blocked by qt5-qtdeclarative
@@ -24,14 +24,15 @@ makedepends="
qt5-qtdeclarative-dev
qt5-qtquickcontrols2-dev
qt5-qtsvg-dev
+ samurai
"
checkdepends="appstream"
source="https://invent.kde.org/plasma-mobile/plasma-camera/-/archive/$_commit/plasma-camera-$_commit.tar.gz"
builddir="$srcdir/$pkgname-$_commit"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
diff --git a/community/plasma-desktop/APKBUILD b/community/plasma-desktop/APKBUILD
index 72097de5e8b..f3445386c19 100644
--- a/community/plasma-desktop/APKBUILD
+++ b/community/plasma-desktop/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-desktop
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="KDE Plasma Desktop"
# armhf blocked by qt5-qtdeclarative
# s390x blocked by ibus
@@ -58,6 +58,7 @@ makedepends="
qt5-qtdeclarative-dev
qt5-qtsvg-dev
qt5-qtx11extras-dev
+ samurai
xf86-input-evdev-dev
xf86-input-libinput-dev
xf86-input-synaptics-dev
@@ -73,8 +74,8 @@ subpackages="$pkgname-dbg $pkgname-doc $pkgname-lang knetattach"
options="!check" # Requires running dbus
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -87,18 +88,16 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
-
- rm "$pkgdir"/usr/bin/knetattach
- rm "$pkgdir"/usr/share/applications/org.kde.knetattach.desktop
}
knetattach() {
pkgdesc="Wizard which makes it easier to integrate network resources with the Plasma Desktop"
depends="kdelibs4support"
- cd "$builddir"/build/knetattach
- DESTDIR="$subpkgdir" make install
+ amove usr/bin/knetattach
+ amove usr/share/applications/org.kde.knetattach.desktop
}
+
sha512sums="
9d6a8c50a85d7f59b89a13753d9a7072df5e8bd1e726bf1037c4cf8d4d43046c2076c8993dffc1f5cec7f7a113832dd14f836e9b47b879f6352f3c30f4b5c408 plasma-desktop-5.24.4.tar.xz
"
diff --git a/community/plasma-dialer/APKBUILD b/community/plasma-dialer/APKBUILD
index de093e117f9..5c366b55092 100644
--- a/community/plasma-dialer/APKBUILD
+++ b/community/plasma-dialer/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-dialer
pkgver=22.02
-pkgrel=0
+pkgrel=1
pkgdesc="A dialer for Plasma Mobile"
# armhf blocked by extra-cmake-modules
# s390x blocked by oxygen-sounds
@@ -30,14 +30,15 @@ makedepends="
qt5-qtfeedback-dev
qt5-qtquickcontrols2-dev
qtmpris-dev
+ samurai
"
subpackages="$pkgname-lang"
source="https://download.kde.org/stable/plasma-mobile/$pkgver/plasma-dialer-$pkgver.tar.xz"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -51,6 +52,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
aca00a36303045ceb82b7972436c99a080cbd014481bd28f1646158f24f49d16b6fbeb14734ca6270d145e102dcb93422fae384b319182d98c5555326f572a76 plasma-dialer-22.02.tar.xz
"
diff --git a/community/plasma-disks/APKBUILD b/community/plasma-disks/APKBUILD
index 0a1757dad0f..f7e354e19f7 100644
--- a/community/plasma-disks/APKBUILD
+++ b/community/plasma-disks/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-disks
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="Monitors S.M.A.R.T. capable devices for imminent failure"
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by polkit -> kio
@@ -25,6 +25,7 @@ makedepends="
kio-dev
kauth-dev
kdeclarative-dev
+ samurai
"
checkdepends="xvfb-run"
@@ -36,8 +37,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-disks-$pkgver.tar.x
subpackages="$pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -51,6 +52,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
735d28c6c50515ae7af7a3df4f2ba586d7273d11e8ba96e6546685f6dbf29917001854ba9fa8f298b15f50ec8b26d51d04771874074eeb808f29f5112d07758f plasma-disks-5.24.4.tar.xz
"
diff --git a/community/plasma-firewall/APKBUILD b/community/plasma-firewall/APKBUILD
index 0ad6b93e40b..480597f19bf 100644
--- a/community/plasma-firewall/APKBUILD
+++ b/community/plasma-firewall/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-firewall
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="Control Panel for your system firewall"
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by polkit -> kcmutils
@@ -23,6 +23,7 @@ makedepends="
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtx11extras-dev
+ samurai
"
case "$pkgver" in
@@ -33,8 +34,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-firewall-$pkgver.ta
subpackages="$pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -48,6 +49,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
320066a2339eae7113a3a8b50a01d8ef11c4ba2e9bed48a4f919cae0d1964246ad0beef02f3bc26c8e7ea63214037683552c1004d8b98cfcece52e2ee131b3cc plasma-firewall-5.24.4.tar.xz
"
diff --git a/community/plasma-framework/APKBUILD b/community/plasma-framework/APKBUILD
index 762d1981aef..d0220fec46f 100644
--- a/community/plasma-framework/APKBUILD
+++ b/community/plasma-framework/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-framework
pkgver=5.92.0
-pkgrel=0
+pkgrel=1
pkgdesc="Plasma library and runtime components based upon KF5 and Qt5"
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by polkit
@@ -33,6 +33,7 @@ depends_dev="
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtquickcontrols2-dev
+ samurai
"
makedepends="$depends_dev
doxygen
@@ -50,8 +51,8 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check" # 8 out of 13 tests fail
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -66,6 +67,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
6efbb9f03ec11804b12cda209dc665468cf6f56ecf712a136a5cf1ea2cb1deb1d427896770b12c18094a2d7f0ef69da9dcbe52b16ae2126e8382ade74d8ce54c plasma-framework-5.92.0.tar.xz
"
diff --git a/community/plasma-integration/APKBUILD b/community/plasma-integration/APKBUILD
index 16883639b83..97de9fc475d 100644
--- a/community/plasma-integration/APKBUILD
+++ b/community/plasma-integration/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-integration
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="Qt Platform Theme integration plugins for the Plasma workspaces"
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by polkit -> kio
@@ -30,6 +30,7 @@ makedepends="
qt5-qtbase-dev
qt5-qtquickcontrols2-dev
qt5-qtx11extras-dev
+ samurai
"
checkdepends="xvfb-run"
@@ -42,8 +43,8 @@ subpackages="$pkgname-lang"
options="!check" # Broken
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_DISABLE_FIND_PACKAGE_FontNotoSans=true \
diff --git a/community/plasma-mobile-sounds/APKBUILD b/community/plasma-mobile-sounds/APKBUILD
index 3ea1702fdeb..09fab05dffe 100644
--- a/community/plasma-mobile-sounds/APKBUILD
+++ b/community/plasma-mobile-sounds/APKBUILD
@@ -2,18 +2,18 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-mobile-sounds
pkgver=0.1
-pkgrel=0
+pkgrel=1
pkgdesc="Sounds for Plasma Mobile devices"
url="https://invent.kde.org/plasma-mobile/plasma-mobile-sounds"
# armhf blocked by extra-cmake-modules
arch="noarch !armhf"
license="CC-BY-4.0 AND CC-BY-SA-4.0 AND CC0-1.0"
-makedepends="extra-cmake-modules"
+makedepends="extra-cmake-modules samurai"
source="https://download.kde.org/stable/plasma-mobile-sounds/$pkgver/plasma-mobile-sounds-$pkgver.tar.xz"
options="!check" # No code to test
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
diff --git a/community/plasma-mobile/APKBUILD b/community/plasma-mobile/APKBUILD
index 59614e982db..464d80aa491 100644
--- a/community/plasma-mobile/APKBUILD
+++ b/community/plasma-mobile/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-mobile
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="Modules providing phone functionality for Plasma"
# armhf blocked by extra-cmake-modules
# s390x and riscv64 blocked by polkit -> kio
@@ -52,6 +52,7 @@ makedepends="
networkmanager-qt-dev
plasma-framework-dev
qt5-qtdeclarative-dev
+ samurai
solid-dev
telepathy-qt-dev
"
@@ -69,8 +70,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-mobile-$pkgver.tar.
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
diff --git a/community/plasma-nano/APKBUILD b/community/plasma-nano/APKBUILD
index f4b813b87bc..b8694080003 100644
--- a/community/plasma-nano/APKBUILD
+++ b/community/plasma-nano/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-nano
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="A minimal Plasma shell package intended for embedded devices"
# armhf blocked by extra-cmake-modules
# s390x and riscv64 blocked by polkit -> plasma-framework
@@ -17,6 +17,7 @@ makedepends="
plasma-framework-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
"
case "$pkgver" in
@@ -27,8 +28,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-nano-$pkgver.tar.xz
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -42,6 +43,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
d954a120039eb509f1728c7e06db3944ac9303c48a814d9d3c1d222fa005d6eb1aa0c087aac19a018a96a7b3ab40cafa7ef1a6ac163983fcf52371b29bf3bc66 plasma-nano-5.24.4.tar.xz
"
diff --git a/community/plasma-nm/APKBUILD b/community/plasma-nm/APKBUILD
index 7f60f1acef8..113498c3f4f 100644
--- a/community/plasma-nm/APKBUILD
+++ b/community/plasma-nm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-nm
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="Plasma applet written in QML for managing network connections"
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by polkit -> plasma-framework
@@ -36,6 +36,7 @@ makedepends="
qca-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
solid-dev
"
@@ -47,8 +48,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-nm-$pkgver.tar.xz"
subpackages="$pkgname-lang $pkgname-mobile"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_MOBILE=ON
@@ -72,6 +73,7 @@ mobile() {
amove usr/lib/qt5/plugins/kcms
amove usr/share/kservices5/wifisettings.desktop
}
+
sha512sums="
2a28f7879a3e90111ab43d6c30d7f191dfbd58dbcac1e2415387f054674cebc28e2aaeb5beffe448c1bc4f698bb1212b757746dc1e4f5d78a1c2e094895eae85 plasma-nm-5.24.4.tar.xz
"
diff --git a/community/plasma-pa/APKBUILD b/community/plasma-pa/APKBUILD
index 43dc4dd14c1..a0b7e5b3d7d 100644
--- a/community/plasma-pa/APKBUILD
+++ b/community/plasma-pa/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-pa
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="Plasma applet for audio volume management using PulseAudio"
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by polkit -> plasma-workspace
@@ -23,6 +23,7 @@ makedepends="
plasma-workspace-dev
pulseaudio-dev
libcanberra-dev
+ samurai
"
case "$pkgver" in
@@ -33,8 +34,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-pa-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DUSE_GCONF=OFF
@@ -49,6 +50,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
37662d46928e5e086ea6e9d681903d70a2c673207c0c5b692dac01d583d38e14a79f185088a8f7db88e655ef16d62432771acc1cec9c923d22299f7b1da0749d plasma-pa-5.24.4.tar.xz
"
diff --git a/community/plasma-pass/APKBUILD b/community/plasma-pass/APKBUILD
index 6eb55729786..97e16c9c390 100644
--- a/community/plasma-pass/APKBUILD
+++ b/community/plasma-pass/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-pass
pkgver=1.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Plasma applet for the Pass password manager"
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by polkit -> plasma-framework
@@ -18,14 +18,15 @@ makedepends="
plasma-framework-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
"
source="https://download.kde.org/stable/plasma-pass/plasma-pass-$pkgver.tar.xz"
subpackages="$pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -39,4 +40,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="4ac72af97a8026022459c46eb3d8dec1489dedf0ea47ab8c71a5ab92a9c5e2faca92ef2ed512e5cd0cc181a6aa7b6ab802ae98ce525e97818704e0bf58e4603a plasma-pass-1.2.0.tar.xz"
+
+sha512sums="
+4ac72af97a8026022459c46eb3d8dec1489dedf0ea47ab8c71a5ab92a9c5e2faca92ef2ed512e5cd0cc181a6aa7b6ab802ae98ce525e97818704e0bf58e4603a plasma-pass-1.2.0.tar.xz
+"
diff --git a/community/plasma-phonebook/APKBUILD b/community/plasma-phonebook/APKBUILD
index 9afbc124822..ce35e507b9e 100644
--- a/community/plasma-phonebook/APKBUILD
+++ b/community/plasma-phonebook/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-phonebook
pkgver=22.02
-pkgrel=0
+pkgrel=1
pkgdesc="Contacts application which allows adding, modifying and removing contacts"
# armhf blocked by extra-cmake-modules
arch="all !armhf"
@@ -23,14 +23,15 @@ makedepends="
qt5-qtdeclarative-dev
qt5-qtquickcontrols2-dev
qt5-qtsvg-dev
+ samurai
"
source="https://download.kde.org/stable/plasma-mobile/$pkgver/plasma-phonebook-$pkgver.tar.xz"
subpackages="$pkgname-lang"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -44,6 +45,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
ae8ee7aaf64c0228064dd6829e6b8f90bb3407888e4b5ce5b943ae55e1c1c5cb3bd3265089a613ddace885268cb045b269cbceec576cf7ca63d3d117e1a0dcf9 plasma-phonebook-22.02.tar.xz
"
diff --git a/community/plasma-remotecontrollers/APKBUILD b/community/plasma-remotecontrollers/APKBUILD
index 7edef82e3dd..13dea21974a 100644
--- a/community/plasma-remotecontrollers/APKBUILD
+++ b/community/plasma-remotecontrollers/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-remotecontrollers
pkgver=0_git20220306
-pkgrel=0
+pkgrel=1
_commit="da4623eed36d47193bab1a7e388ce410333c27b7"
pkgdesc="Translate various input device events into keyboard and pointer events"
url="https://invent.kde.org/plasma-bigscreen/plasma-remotecontrollers"
@@ -19,6 +19,7 @@ makedepends="
libcec-dev
libevdev-dev
qt5-qtbase-dev
+ samurai
solid-dev
"
case "$CARCH" in
@@ -32,7 +33,7 @@ options="!check" # No tests
builddir="$srcdir/$pkgname-$_commit"
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
diff --git a/community/plasma-sdk/APKBUILD b/community/plasma-sdk/APKBUILD
index 309497d3794..626647934a9 100644
--- a/community/plasma-sdk/APKBUILD
+++ b/community/plasma-sdk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-sdk
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="Applications useful for Plasma Development"
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by polkit -> kio
@@ -34,6 +34,7 @@ makedepends="
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtsvg-dev
+ samurai
"
checkdepends="xvfb-run"
@@ -45,8 +46,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-sdk-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
diff --git a/community/plasma-settings/APKBUILD b/community/plasma-settings/APKBUILD
index a5eb98154fa..a2f132632aa 100644
--- a/community/plasma-settings/APKBUILD
+++ b/community/plasma-settings/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-settings
pkgver=22.02
-pkgrel=0
+pkgrel=1
pkgdesc="Settings application for Plasma Mobile"
# armhf blocked by extra-cmake-modules
# s390x and riscv64 blocked by polkit -> kio
@@ -31,6 +31,7 @@ makedepends="
plasma-framework-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
solid-dev
"
subpackages="$pkgname-lang"
@@ -38,8 +39,8 @@ source="https://download.kde.org/stable/plasma-mobile/$pkgver/plasma-settings-$p
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -48,6 +49,7 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
ee52795f05b9dbb6d43c0cddb8127684c38f2a49613840c34ed912eb64e8fb37467d6819eb75bf83981452a0f77f0fd721c29d572552b6f6e19d3ac3cc4ff3a4 plasma-settings-22.02.tar.xz
"
diff --git a/community/plasma-systemmonitor/APKBUILD b/community/plasma-systemmonitor/APKBUILD
index 0f3e0b5c479..f2cc15f9000 100644
--- a/community/plasma-systemmonitor/APKBUILD
+++ b/community/plasma-systemmonitor/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-systemmonitor
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="An application for monitoring system resources"
# armhf blocked by extra-cmake-modules
# s390x and riscv64 blocked by polkit -> kio
@@ -24,6 +24,7 @@ makedepends="
libksysguard-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
"
case "$pkgver" in
@@ -34,8 +35,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-systemmonitor-$pkgv
subpackages="$pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -50,6 +51,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
13d489865df36bbe9a1465d7efd5603442144492781d0a5102e395f80f50b31d0519953962a0c3b2b9ff199c05daf20e9d7828ae42ce2335714c31bb6ff9f2c1 plasma-systemmonitor-5.24.4.tar.xz
"
diff --git a/community/plasma-thunderbolt/APKBUILD b/community/plasma-thunderbolt/APKBUILD
index c415bd0ee95..3910b3beb4d 100644
--- a/community/plasma-thunderbolt/APKBUILD
+++ b/community/plasma-thunderbolt/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-thunderbolt
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
# armhf blocked by qt5-qtdeclarative
# s390x and riscv64 blocked by bolt -> polkit
arch="all !armhf !s390x !riscv64"
@@ -20,6 +20,7 @@ makedepends="
knotifications-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
"
checkdepends="xvfb-run"
@@ -32,8 +33,8 @@ subpackages="$pkgname-lang"
options="!check" # Requires running dbus server
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
diff --git a/community/plasma-vault/APKBUILD b/community/plasma-vault/APKBUILD
index 71262d24dc0..7ab878ac0e0 100644
--- a/community/plasma-vault/APKBUILD
+++ b/community/plasma-vault/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-vault
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="Plasma applet and services for creating encrypted vaults"
# armhf blocked by extra-cmake-modules
# s390x and riscv64 blocked by polkit -> kio
@@ -23,6 +23,7 @@ makedepends="
networkmanager-qt-dev
plasma-framework-dev
qt5-qtbase-dev
+ samurai
"
case "$pkgver" in
@@ -34,8 +35,8 @@ subpackages="$pkgname-lang"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
diff --git a/community/plasma-videoplayer/APKBUILD b/community/plasma-videoplayer/APKBUILD
index 3208cd2127f..2dfd6a8a61b 100644
--- a/community/plasma-videoplayer/APKBUILD
+++ b/community/plasma-videoplayer/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-videoplayer
pkgver=0.3_git20200223
-pkgrel=1
+pkgrel=2
_commit="5418bde23b89960ebdaa7f86e0830960a1efe1e4"
pkgdesc="Video Player for Plasma Mobile"
url="https://invent.kde.org/jbbgameich/videoplayer"
@@ -24,14 +24,15 @@ makedepends="
plasma-framework-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
"
source="https://invent.kde.org/jbbgameich/videoplayer/-/archive/$_commit/videoplayer-$_commit.tar.gz"
options="!check" # No tests
builddir="$srcdir/videoplayer-$_commit"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -40,4 +41,7 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="2f424ec10a0c9ed087cc140b2212bde7b8f906f0e2850ee0afe52f846ce9e05ce441e2406f44dc44008377969d003dde4f2329f9f56a68e0f4b637d670e8c398 videoplayer-5418bde23b89960ebdaa7f86e0830960a1efe1e4.tar.gz"
+
+sha512sums="
+2f424ec10a0c9ed087cc140b2212bde7b8f906f0e2850ee0afe52f846ce9e05ce441e2406f44dc44008377969d003dde4f2329f9f56a68e0f4b637d670e8c398 videoplayer-5418bde23b89960ebdaa7f86e0830960a1efe1e4.tar.gz
+"
diff --git a/community/plasma-wayland-protocols/APKBUILD b/community/plasma-wayland-protocols/APKBUILD
index 812660bc403..55c998ff800 100644
--- a/community/plasma-wayland-protocols/APKBUILD
+++ b/community/plasma-wayland-protocols/APKBUILD
@@ -2,18 +2,18 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-wayland-protocols
pkgver=1.6.0
-pkgrel=0
+pkgrel=1
pkgdesc="Plasma Specific Protocols for Wayland"
arch="noarch !armhf" # armhf blocked by extra-cmake-modules
url="https://www.kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-only"
-makedepends="extra-cmake-modules"
+makedepends="extra-cmake-modules samurai"
source="https://download.kde.org/stable/plasma-wayland-protocols/plasma-wayland-protocols-$pkgver.tar.xz"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -22,6 +22,7 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
a9306d30032c46e8046ffbc8713e1afab732ee48a43922d0091cff25f0aaf407bee6fd08c333d9a83d064b903ebd1699d7d0ceadfe8b939ffd4d5e2129c22cf8 plasma-wayland-protocols-1.6.0.tar.xz
"
diff --git a/community/plasma-workspace-wallpapers/APKBUILD b/community/plasma-workspace-wallpapers/APKBUILD
index a78f1d61484..93c21f843a0 100644
--- a/community/plasma-workspace-wallpapers/APKBUILD
+++ b/community/plasma-workspace-wallpapers/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-workspace-wallpapers
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="Wallpapers for the Plasma Workspace"
arch="noarch !armhf" # armhf blocked by extra-cmake-modules
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
-makedepends="extra-cmake-modules"
+makedepends="extra-cmake-modules samurai"
case "$pkgver" in
*.90*) _rel=unstable;;
@@ -17,8 +17,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-workspace-wallpaper
options="!check" # No tests available
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
diff --git a/community/plasma-workspace/APKBUILD b/community/plasma-workspace/APKBUILD
index 7775aaaf0d8..f6332c904ea 100644
--- a/community/plasma-workspace/APKBUILD
+++ b/community/plasma-workspace/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-workspace
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="KDE Plasma Workspace"
# armhf blocked by kirigami2
# s390x and riscv64 blocked by polkit -> kio-extras
@@ -65,6 +65,7 @@ depends_dev="
phonon-dev
plasma-framework-dev
prison-dev
+ samurai
zlib-dev
"
makedepends="$depends_dev
@@ -83,8 +84,8 @@ subpackages="$pkgname-dev $pkgname-libs $pkgname-doc $pkgname-lang"
replaces="plasma-desktop<5.24 breeze<5.22.90"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DPLASMA_WAYLAND_DEFAULT_SESSION=TRUE
@@ -124,6 +125,7 @@ package() {
# We don't ship systemd
rm -r "$pkgdir"/usr/lib/systemd
}
+
sha512sums="
6c917d3ea307bca85e6ca12294357410c3442a9115a4864311df87af29919c20d8dab768f470379bbc4e0510367319a6cf8ce045ab7254db06e8c29477370d89 plasma-workspace-5.24.4.tar.xz
"
diff --git a/community/plasmatube/APKBUILD b/community/plasmatube/APKBUILD
index fa629f212e2..a948c2566be 100644
--- a/community/plasmatube/APKBUILD
+++ b/community/plasmatube/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasmatube
pkgver=22.02
-pkgrel=0
+pkgrel=1
pkgdesc="Kirigami YouTube video player based on Invidious"
# armhf blocked by extra-cmake-modules
# s390x and riscv64 blocked by polkit
@@ -25,14 +25,15 @@ makedepends="
kirigami2-dev
qt5-qtbase-dev
qt5-qtquickcontrols2-dev
+ samurai
"
subpackages="$pkgname-lang"
source="https://download.kde.org/stable/plasma-mobile/$pkgver/plasmatube-$pkgver.tar.xz"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build