aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-09-23 04:17:41 +0000
committerpsykose <alice@ayaya.dev>2022-09-23 06:17:41 +0200
commit5bbb3e9232e1cbb1210b7be361101fcfb5f92f1f (patch)
treec89545b176425381a1b9f9a711166f6af96494aa
parente45fb075bbe468b9f1e714dedaeceb4c8191cb41 (diff)
main/boost1.80: fix aligned_alloc detection
-rw-r--r--main/boost1.80/APKBUILD4
-rw-r--r--main/boost1.80/aligned-alloc.patch28
2 files changed, 31 insertions, 1 deletions
diff --git a/main/boost1.80/APKBUILD b/main/boost1.80/APKBUILD
index c2494841032..6e1e43aec39 100644
--- a/main/boost1.80/APKBUILD
+++ b/main/boost1.80/APKBUILD
@@ -2,7 +2,7 @@
pkgname=boost1.80
pkgver=1.80.0
_pkgver="${pkgver//./_}"
-pkgrel=1
+pkgrel=2
pkgdesc="Free peer-reviewed portable C++ source libraries"
url="https://www.boost.org/"
arch="all"
@@ -17,6 +17,7 @@ subpackages="
boost-dev:_dev
"
source="https://boostorg.jfrog.io/artifactory/main/release/$pkgver/source/boost_$_pkgver.tar.bz2
+ aligned-alloc.patch
boost-1.57.0-python-abi_letters.patch
boost-1.57.0-python-libpython_dep.patch
0001-revert-cease-dependence-on-range.patch
@@ -225,6 +226,7 @@ _pyversion() {
sha512sums="
829a95b463473d69ff79ea41799c68429bb79d3b2321fbdb71df079af237ab01de9ad7e9612d8783d925730acada010068d2d1aa856c34244ee5c0ece16f208f boost_1_80_0.tar.bz2
+6254b4cc92d091aef9e8fdea375c0779f47bc3ea7965f6d93cab8bf76d2a502d9593d860228d2313ea133ee4f7935c4813d39df4bcb29bdf380628474ce4dcd6 aligned-alloc.patch
d96d4d37394a31764ed817d0bc4a99cffa68a75ff1ecfd4417b9e1e5ae2c31a96ed24f948c6f2758ffdac01328d2402c4cf0d33a37107e4f5f721e636daebd66 boost-1.57.0-python-abi_letters.patch
132c4b62815d605c2d3c9038427fa4f422612a33711d47b2862f2311516af8a371d6b75bf078a7bffe20be863f8d21fb9fe74dc1a1bac3a10d061e9768ec3e02 boost-1.57.0-python-libpython_dep.patch
9b53d2fe2dddd592e43db03c26fadd6c07d4c45a980ae4c775b7a914346a3914f6e0c3ef42dad5e2ea4568afb86c9967e09444ff609cfba1e1d39f4980b22ad6 0001-revert-cease-dependence-on-range.patch
diff --git a/main/boost1.80/aligned-alloc.patch b/main/boost1.80/aligned-alloc.patch
new file mode 100644
index 00000000000..8d168ee6bd1
--- /dev/null
+++ b/main/boost1.80/aligned-alloc.patch
@@ -0,0 +1,28 @@
+Patch-Source: https://github.com/chimera-linux/cports/blob/1dd1fed225a0b65b5164bc5168194f85deea3b19/main/boost1.80/patches/aligned_alloc.patch
+commit 98ca73bfe3f574ba72232013919885bdae679e09
+Author: Daniel Kolesa <daniel@octaforge.org>
+Date: Fri Sep 23 03:55:45 2022 +0200
+
+ use posix as a fallback for aligned_alloc
+
+ Testing for feature test macros is a broken antipattern, and
+ fucks up in ugly ways under musl. Since we don't really care
+ for having a non-POSIX fallback, always use the POSIX code
+ unless forced.
+
+diff --git a/boost/align/aligned_alloc.hpp b/boost/align/aligned_alloc.hpp
+index 1d81a13..f2b5137 100644
+--- a/boost/align/aligned_alloc.hpp
++++ b/boost/align/aligned_alloc.hpp
+@@ -38,10 +38,8 @@ Distributed under the Boost Software License, Version 1.0.
+ #include <boost/align/detail/aligned_alloc_posix.hpp>
+ #elif defined(sun) || defined(__sun)
+ #include <boost/align/detail/aligned_alloc_sunos.hpp>
+-#elif (_POSIX_C_SOURCE >= 200112L) || (_XOPEN_SOURCE >= 600)
+-#include <boost/align/detail/aligned_alloc_posix.hpp>
+ #else
+-#include <boost/align/detail/aligned_alloc.hpp>
++#include <boost/align/detail/aligned_alloc_posix.hpp>
+ #endif
+
+ #endif