aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2021-01-05 00:25:13 +0100
committerJakub Jirutka <jakub@jirutka.cz>2021-01-05 00:49:39 +0100
commit5e4a02a38d1b548d85172acc2fd34a8a5047806e (patch)
treea51062bc03df5a2c45c45e7b4efee2bf7221abe8
parentffc653584af6b0d96f03c56d507c3093f627c7d0 (diff)
main/icu: add subpackage -data with .dat file and TODO note
-rw-r--r--main/icu/APKBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/main/icu/APKBUILD b/main/icu/APKBUILD
index 6c955cc303e..af61c144ba1 100644
--- a/main/icu/APKBUILD
+++ b/main/icu/APKBUILD
@@ -1,13 +1,16 @@
# Contributor: Sergey Lukin <sergej.lukin@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+#
+# TODO: After 3.13 is released, change data-packaging to "archive" and split
+# data into multiple variants (English-only, all, ...).
pkgname=icu
pkgver=67.1
-pkgrel=1
+pkgrel=2
pkgdesc="International Components for Unicode library"
url="http://site.icu-project.org/"
arch="all"
license="MIT ICU Unicode-TOU"
-subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-libs"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-libs $pkgname-data::noarch"
depends_dev="$pkgname=$pkgver-r$pkgrel"
checkdepends="diffutils python3"
source="https://github.com/unicode-org/icu/releases/download/release-${pkgver//./-}/icu4c-${pkgver//./_}-src.tgz"
@@ -65,4 +68,12 @@ libs() {
replaces="icu"
}
+data() {
+ pkgdesc="ICU data in a .dat package file"
+ local majorver=${pkgver%%.*}
+
+ install -Dm644 "$builddir"/data/in/icudt${majorver}l.dat \
+ "$subpkgdir"/usr/share/icu/$pkgver/icudt${majorver}l.dat
+}
+
sha512sums="4779f1ce1ca7976f6fad6768853ea8c540da54d11509e3b6cfd864a04b5f2db1c3d4b546387f91ad02fb90804525bc37d2543173f0d705d6ca11dc6f2b7640a8 icu4c-67_1-src.tgz"