aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2023-06-22 20:21:58 +0200
committerBart Ribbers <bribbers@disroot.org>2023-06-22 19:15:54 +0000
commit5fef1222705c899992ee4edbacce8956f612eaf3 (patch)
tree48811f50f337d926a75c239eac28b9f7025f5216
parentadcf8b2c5d8b76d312c7d73100ec06ed60c2c3b0 (diff)
community/py3-requests-cache: upgrade to 1.0.1
-rw-r--r--community/py3-requests-cache/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/community/py3-requests-cache/APKBUILD b/community/py3-requests-cache/APKBUILD
index 4efd0fa9f3b..ac21aafd658 100644
--- a/community/py3-requests-cache/APKBUILD
+++ b/community/py3-requests-cache/APKBUILD
@@ -1,41 +1,42 @@
# Contributor: Philipp Glaum <p@pglaum.de>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-requests-cache
-pkgver=0.9.1
-pkgrel=4
+pkgver=1.0.1
+pkgrel=0
pkgdesc="Persistent cache for requests library"
url="https://github.com/requests-cache/requests-cache"
arch="noarch"
license="BSD-3-Clause"
depends="
- py3-appdirs
py3-attrs
py3-cattrs
+ py3-platformdirs
py3-requests
- py3-responses
py3-url-normalize
py3-urllib3
- python3
"
makedepends="
py3-gpep517
py3-poetry-core
+ py3-wheel
"
checkdepends="
py3-itsdangerous
py3-mock
py3-mongo
- py3-orjson
py3-msgpack
+ py3-orjson
py3-pytest
py3-pytest-xdist
py3-requests-mock
+ py3-responses
+ py3-rich
py3-timeout-decorator
py3-ujson
py3-yaml
"
subpackages="$pkgname-pyc"
-source="https://pypi.python.org/packages/source/r/requests-cache/requests-cache-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/requests-cache/requests-cache/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/requests-cache-$pkgver"
build() {
@@ -56,5 +57,5 @@ package() {
}
sha512sums="
-1fc33a26b109b43a4f9d273e66b591ff7c40cc7564a6cb664d446c6717d04ef9004d5dc7ec6800d77dec243c1fb6004b4d3b3bca3f031a0b7fa28a0bc6d6bacd requests-cache-0.9.1.tar.gz
+ec5788e31f60fd95e575d01af1163f981757972db6557d7a62da2ca0719e84262cf66cdd9b40c73cca540b92d6b7f6beba1aa42bedba528734c61edf5013ec3d py3-requests-cache-1.0.1.tar.gz
"