aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-11-17 11:08:56 +0100
committerBart Ribbers <bribbers@disroot.org>2021-11-17 11:08:58 +0100
commit61dac54a74d75c91dd0b448370a21776e9f2cde8 (patch)
treeed0d411ab633a1dc49d11372ec2bdee07b6e198d
parent10afb9e880cf79994d6c51131abfd07e7ff2dbde (diff)
downloadaports-61dac54a74d75c91dd0b448370a21776e9f2cde8.tar.gz
aports-61dac54a74d75c91dd0b448370a21776e9f2cde8.tar.bz2
aports-61dac54a74d75c91dd0b448370a21776e9f2cde8.tar.xz
community/ansible-core: replace ansible-base files
Otherwise: ERROR: ansible-core-2.11.6-r0: trying to overwrite usr/lib/python3.9/site-packages/ansible_test/config/cloud-config-hcloud.ini.template owned by ansible-base-2.10.5-r1.
-rw-r--r--community/ansible-core/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/ansible-core/APKBUILD b/community/ansible-core/APKBUILD
index 1bda8558382..3f73b9b044f 100644
--- a/community/ansible-core/APKBUILD
+++ b/community/ansible-core/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sean McAvoy <seanmcavoy@gmail.com>
pkgname=ansible-core
pkgver=2.11.6
-pkgrel=0
+pkgrel=1
pkgdesc="core components of ansible: A configuration-management, deployment, task-execution, and multinode orchestration framework"
url="https://ansible.com"
options="!check" # for now
@@ -13,6 +13,8 @@ makedepends="py3-setuptools"
subpackages="$pkgname-doc"
source="https://pypi.python.org/packages/source/a/ansible-core/ansible-core-$pkgver.tar.gz"
+replaces="ansible-base"
+
build() {
python3 setup.py build
}