aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-24 06:37:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-24 07:38:54 -0300
commit6231ded90615e1e5f6954a9e43916eb53b3bd136 (patch)
treedf2199004c01580a3da04807ba34d2d88c2462bb
parentaf2f29b5842778a74f528697b1c59cede11c889b (diff)
testing/opencolorio: upgrade to 1.1.1
-rw-r--r--testing/opencolorio/APKBUILD12
-rw-r--r--testing/opencolorio/OpenColorIO-gcc.patch81
-rw-r--r--testing/opencolorio/gcc9.patch26
3 files changed, 32 insertions, 87 deletions
diff --git a/testing/opencolorio/APKBUILD b/testing/opencolorio/APKBUILD
index e8a6cf7dd2a..c995c134d27 100644
--- a/testing/opencolorio/APKBUILD
+++ b/testing/opencolorio/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Mark Riedesel <mark@klowner.com>
# Maintainer: Mark Riedesel <mark@klowner.com>
pkgname=opencolorio
-pkgver=1.1.0
-pkgrel=2
+pkgver=1.1.1
+pkgrel=0
pkgdesc="A color management framework for visual effects and animation"
url="https://opencolorio.org"
arch="all"
@@ -11,8 +11,8 @@ makedepends="boost-dev cmake freeglut-dev glew-dev lcms2-dev python3-dev
tinyxml-dev yaml-cpp-dev"
subpackages="py3-$pkgname:py3 $pkgname-dev $pkgname-tools"
source="$pkgname-$pkgver.tar.gz::https://github.com/imageworks/OpenColorIO/archive/v$pkgver.tar.gz
- OpenColorIO-gcc.patch
ocio-1.1.0-yamlcpp060.patch
+ gcc9.patch
"
builddir="$srcdir/OpenColorIO-$pkgver"
@@ -64,6 +64,6 @@ py3() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib
}
-sha512sums="909874a9f91a8d229622810fc70233680c6e75203bd8555179322de2873da00bf302432e19f189b787ffcda3157ddec1e4601c97f75a36e16f644fe7d42f6998 opencolorio-1.1.0.tar.gz
-befed734f240d26c7cbeb020b540ea91d84c9422fa61dcb0ab16f56389f7c5c90d10e015c6cdbed2033047b7e31ceb4fd1b2707c2bef1a8e0f33959601471d5f OpenColorIO-gcc.patch
-ef4b0e880c587fcd004865fd938e7f1fb1bbb933abf1ccf352260ebe3a50145664e27b9f1119b72ced99afe4d19b49b0b6c249dd95faaec9c1332ffc44bc9811 ocio-1.1.0-yamlcpp060.patch"
+sha512sums="bed722f9ddce1887d28aacef2882debccd7c3f3c0c708d2723fea58a097de9f02721af9e85453e089ffda5406aef593ab6536c6886307823c132aa787e492e33 opencolorio-1.1.1.tar.gz
+ef4b0e880c587fcd004865fd938e7f1fb1bbb933abf1ccf352260ebe3a50145664e27b9f1119b72ced99afe4d19b49b0b6c249dd95faaec9c1332ffc44bc9811 ocio-1.1.0-yamlcpp060.patch
+b2be3e01d87b3b69fafdd5eff7adc99dd1f222184aaf338956aed5438f43960558423902ec544614cf0677a48849f0f88cd5c74f8dd5a06e20a91aa72a574883 gcc9.patch"
diff --git a/testing/opencolorio/OpenColorIO-gcc.patch b/testing/opencolorio/OpenColorIO-gcc.patch
deleted file mode 100644
index de05849f283..00000000000
--- a/testing/opencolorio/OpenColorIO-gcc.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From f39552d70098a98f7c1fb3b4f020b550ce2dd75a Mon Sep 17 00:00:00 2001
-From: Patrick Hodoul <patrick.hodoul@autodesk.com>
-Date: Mon, 27 Nov 2017 17:29:57 -0500
-Subject: [PATCH] Fix Linux compilation Fix gcc 5.4.0 build breaks Fix the temp
- filename for Linux
-
----
- src/core/Lut1DOp.cpp | 4 +++-
- src/core/MathUtils.cpp | 23 ++++++++++++-----------
- src/pyglue/PyAllocationTransform.cpp | 1 -
- 3 files changed, 15 insertions(+), 13 deletions(-)
-
---- a/src/core/Lut1DOp.cpp
-+++ b/src/core/Lut1DOp.cpp
-@@ -188,7 +188,8 @@ OCIO_NAMESPACE_ENTER
- {
- return simple_lut[clamp(index, 0.0f, maxIndex)];
- }
--
-+
-+#if defined(OCIO_UNIT_TEST) || !defined(USE_SSE)
- void Lut1D_Nearest(float* rgbaBuffer, long numPixels, const Lut1D & lut)
- {
- float maxIndex[3];
-@@ -218,6 +219,7 @@ OCIO_NAMESPACE_ENTER
- rgbaBuffer += 4;
- }
- }
-+#endif
- #ifdef USE_SSE
- void Lut1D_Nearest_SSE(float* rgbaBuffer, long numPixels, const Lut1D & lut)
- {
---- a/src/core/MathUtils.cpp
-+++ b/src/core/MathUtils.cpp
-@@ -327,17 +327,6 @@ OCIO_NAMESPACE_ENTER
- GetV4Sum(vout, vout, v2);
- }
-
-- namespace
-- {
--
-- void GetMxbResult(float* vout, float* m, float* x, float* v)
-- {
-- GetM44V4Product(vout, m, x);
-- GetV4Sum(vout, vout, v);
-- }
--
-- } // anon namespace
--
- bool GetMxbInverse(float* mout, float* vout,
- const float* m_, const float* v_)
- {
-@@ -372,6 +361,18 @@ OCIO_NAMESPACE_USING
-
- #include "UnitTest.h"
-
-+namespace
-+{
-+
-+ void GetMxbResult(float* vout, float* m, float* x, float* v)
-+ {
-+ GetM44V4Product(vout, m, x);
-+ GetV4Sum(vout, vout, v);
-+ }
-+
-+}
-+
-+
- OIIO_ADD_TEST(MathUtils, M44_is_diagonal)
- {
- {
---- a/src/pyglue/PyAllocationTransform.cpp
-+++ b/src/pyglue/PyAllocationTransform.cpp
-@@ -53,7 +53,6 @@ OCIO_NAMESPACE_ENTER
- ///
-
- int PyOCIO_AllocationTransform_init(PyOCIO_Transform * self, PyObject * args, PyObject * kwds);
-- PyObject * PyOCIO_AllocationTransform_equals(PyObject * self, PyObject * args);
- PyObject * PyOCIO_AllocationTransform_getAllocation(PyObject * self);
- PyObject * PyOCIO_AllocationTransform_setAllocation(PyObject * self, PyObject * args);
- PyObject * PyOCIO_AllocationTransform_getNumVars(PyObject * self);
diff --git a/testing/opencolorio/gcc9.patch b/testing/opencolorio/gcc9.patch
new file mode 100644
index 00000000000..e0aca496b5e
--- /dev/null
+++ b/testing/opencolorio/gcc9.patch
@@ -0,0 +1,26 @@
+diff --git a/src/core/Config.cpp b/src/core/Config.cpp
+index f5cb379..5ea178e 100644
+--- a/src/core/Config.cpp
++++ b/src/core/Config.cpp
+@@ -330,7 +330,7 @@ OCIO_NAMESPACE_ENTER
+ sanitytext_ = rhs.sanitytext_;
+
+ cacheids_ = rhs.cacheids_;
+- cacheidnocontext_ = cacheidnocontext_;
++ cacheidnocontext_ = rhs.cacheidnocontext_;
+ }
+ return *this;
+ }
+diff --git a/src/pyglue/PyAllocationTransform.cpp b/src/pyglue/PyAllocationTransform.cpp
+index 20bb50e..06b418a 100644
+--- a/src/pyglue/PyAllocationTransform.cpp
++++ b/src/pyglue/PyAllocationTransform.cpp
+@@ -53,7 +53,6 @@ OCIO_NAMESPACE_ENTER
+ ///
+
+ int PyOCIO_AllocationTransform_init(PyOCIO_Transform * self, PyObject * args, PyObject * kwds);
+- PyObject * PyOCIO_AllocationTransform_equals(PyObject * self, PyObject * args);
+ PyObject * PyOCIO_AllocationTransform_getAllocation(PyObject * self);
+ PyObject * PyOCIO_AllocationTransform_setAllocation(PyObject * self, PyObject * args);
+ PyObject * PyOCIO_AllocationTransform_getNumVars(PyObject * self);
+