aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2022-10-25 20:56:56 +0200
committeralice <alice@ayaya.dev>2022-10-25 18:59:32 +0000
commit63c86a6755af345a63919bd07f7ea82ebca14f5c (patch)
tree28b8949b9b05b7319050acd1e11d191bf1b8a230
parent3f4ba44e907e07ec7e946628d937a9b6ad987394 (diff)
main/file: upgrade to 5.43
-rw-r--r--main/file/APKBUILD9
-rw-r--r--main/file/fix-dsf-format.patch77
2 files changed, 83 insertions, 3 deletions
diff --git a/main/file/APKBUILD b/main/file/APKBUILD
index 347750c7aa7..e943f1c15a4 100644
--- a/main/file/APKBUILD
+++ b/main/file/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=file
-pkgver=5.42
+pkgver=5.43
pkgrel=0
pkgdesc="File type identification utility"
url="https://www.darwinsys.com/file/"
@@ -9,7 +9,9 @@ arch="all"
license="BSD-2-Clause"
makedepends="autoconf libtool automake"
subpackages="$pkgname-dev $pkgname-doc libmagic"
-source="$pkgname-$pkgver.tar.gz::https://github.com/file/file/archive/FILE${pkgver/./_}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/file/file/archive/FILE${pkgver/./_}.tar.gz
+ fix-dsf-format.patch
+ "
builddir="$srcdir/$pkgname-FILE${pkgver/./_}"
# secfixes:
@@ -47,5 +49,6 @@ libmagic() {
}
sha512sums="
-7df20a1818a59feaa92012c6e19c263db1ac006d19bdec9fd69f47da702dae040f53371f112c31c38e42a35279a668a9e98469bc19cc88bed781ba46db235942 file-5.42.tar.gz
+a961136cd89794bf45eb107fbe7785603b5d40363d0634c6c85e96d4ca9f85087c98442ca1fb0089beff60e9c3a49aa6acab8b67416e72b7d32c67ad5b1d1fa2 file-5.43.tar.gz
+d1f671e35181fbe7f5332585a50ff0fb889d37090f4cf5bcba851f26b07c8bebbc8f52f2e4a6ca5f5cec7fa087e40c9a1293a5acd1987c8ea91151f2ee94464f fix-dsf-format.patch
"
diff --git a/main/file/fix-dsf-format.patch b/main/file/fix-dsf-format.patch
new file mode 100644
index 00000000000..cd5fab574e9
--- /dev/null
+++ b/main/file/fix-dsf-format.patch
@@ -0,0 +1,77 @@
+Patch-Source:
+ https://github.com/file/file/commit/1294029cdb18d4c0997f2b52df435076b8444137
+ https://github.com/file/file/commit/e332d4e4a3c0d12a1e0d2a15876ba9d2e03a0bfb
+From e332d4e4a3c0d12a1e0d2a15876ba9d2e03a0bfb Mon Sep 17 00:00:00 2001
+From: Christos Zoulas <christos@zoulas.com>
+Date: Sun, 9 Oct 2022 13:40:22 +0000
+Subject: [PATCH] revert previous; the original dsf entry in audio was better
+
+---
+ magic/Magdir/audio | 11 ++++++++++-
+ magic/Magdir/dsf | 34 ----------------------------------
+ magic/Makefile.am | 3 +--
+ 3 files changed, 11 insertions(+), 37 deletions(-)
+ delete mode 100644 magic/Magdir/dsf
+
+diff --git a/magic/Magdir/audio b/magic/Magdir/audio
+index 0328f7b..7a0a192 100644
+--- a/magic/Magdir/audio
++++ b/magic/Magdir/audio
+@@ -1,6 +1,6 @@
+
+ #------------------------------------------------------------------------------
+-# $File: audio,v 1.124 2022/08/28 08:58:20 christos Exp $
++# $File: audio,v 1.126 2022/10/09 13:40:22 christos Exp $
+ # audio: file(1) magic for sound formats (see also "iff")
+ #
+ # Jan Nicolai Langfeldt (janl@ifi.uio.no), Dan Quinlan (quinlan@yggdrasil.com),
+diff --git a/magic/Magdir/dsf b/magic/Magdir/dsf
+deleted file mode 100644
+index e6c4b6e..0000000
+--- a/magic/Magdir/dsf
++++ /dev/null
+@@ -1,25 +0,0 @@
+-
+-#------------------------------------------------------------
+-# $File: dsf,v 1.1 2022/01/08 16:29:18 christos Exp $
+-# dsf: file(1) magic for DSD Stream File
+-# URL: https://en.wikipedia.org/wiki/Direct_Stream_Digital
+-# Reference: https://dsd-guide.com/sites/default/files/white-papers/DSFFileFormatSpec_E.pdf
+-0 string DSD\x20 DSD Stream File,
+->0x30 leshort 1 mono,
+->0x30 leshort 2 stereo,
+->0x30 leshort 3 three-channel,
+->0x30 leshort 4 quad-channel,
+->0x30 leshort 5 3.1 4-channel,
+->0x30 leshort 6 five-channel,
+->0x30 leshort 7 5.1 surround,
+->0x30 default x
+->>0x30 leshort x unknown channel format (%d),
+->0x38 lelong 2822400 simple-rate,
+->0x38 lelong 5644800 double-rate,
+->0x38 default x
+->>0x38 lelong x %d Hz,
+->0x3c leshort 1 1 bit,
+->0x3c leshort 8 8 bit,
+->0x3c default x
+->>0x3c leshort x %d bit,
+->0x40 lelong x %d samples
+diff --git a/magic/Makefile.am b/magic/Makefile.am
+index 9fec70c..d82a2f6 100644
+--- a/magic/Makefile.am
++++ b/magic/Makefile.am
+@@ -1,5 +1,5 @@
+ #
+-# $File: Makefile.am,v 1.182 2022/09/11 21:04:30 christos Exp $
++# $File: Makefile.am,v 1.183 2022/10/09 13:40:22 christos Exp $
+ #
+ MAGIC_FRAGMENT_BASE = Magdir
+ MAGIC_DIR = $(top_srcdir)/magic
+@@ -92,7 +92,6 @@ $(MAGIC_FRAGMENT_DIR)/dif \
+ $(MAGIC_FRAGMENT_DIR)/diff \
+ $(MAGIC_FRAGMENT_DIR)/digital \
+ $(MAGIC_FRAGMENT_DIR)/dolby \
+-$(MAGIC_FRAGMENT_DIR)/dsf \
+ $(MAGIC_FRAGMENT_DIR)/dump \
+ $(MAGIC_FRAGMENT_DIR)/dyadic \
+ $(MAGIC_FRAGMENT_DIR)/ebml \