aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2021-11-18 01:21:03 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2022-01-24 20:50:13 +0100
commit648dc50eb169056c3db57d6bfd40790264ae505e (patch)
treeb836e788c7e539891210befca4c6c5936be0f187
parent1114189f68e790455d3ed5723e9c3e8dfaf21676 (diff)
testing/pandoc: upgrade to 2.16.2
-rw-r--r--testing/pandoc/APKBUILD10
-rw-r--r--testing/pandoc/cabal.project.freeze74
2 files changed, 57 insertions, 27 deletions
diff --git a/testing/pandoc/APKBUILD b/testing/pandoc/APKBUILD
index 7491ba03c67..f1be3862580 100644
--- a/testing/pandoc/APKBUILD
+++ b/testing/pandoc/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=pandoc
-pkgver=2.14.2
-pkgrel=2
+pkgver=2.16.2
+pkgrel=0
pkgdesc="universal markup converter"
url="https://pandoc.org/"
-# ghc only supports x86_64
+# limited by ghc
arch="x86_64"
license="GPL-2.0-or-later"
makedepends="ghc cabal zlib-dev libffi-dev"
@@ -50,6 +50,6 @@ package() {
}
sha512sums="
-b6ea6e57fe500d4944d84007c693758a47890ef4880836ccdc7bf5b8d8f3e91c17f05e2d34892e308fdb99bacfa2098065af3d7f18d277f685eff81e810eee17 pandoc-2.14.2.tar.gz
-732a153601c4464fd9c35f1bb2b0e0af958a96b524423ee4189f1d0907a545c6198da3dcdbd9af256786e85e80d74b51c26fa0fb44cfb6c6f1d4ff12119e1544 cabal.project.freeze
+0e1026a93ee0dbd0523c4787b9cabec16d0a2e3b29a6914fd73859b9d6d9c0c71421b8949dfaa551c610c6dfa53de05f5d358cbeb43ad1213039b9ea6d63f9a1 pandoc-2.16.2.tar.gz
+457d390a5235196d3c3815a37fe41e678f58797e4ab791f1da16b30f020378292a022f2a3bbd49517213eb2d9676aa634bfa6c1fe37ee13f0b386c0c06cdf63f cabal.project.freeze
"
diff --git a/testing/pandoc/cabal.project.freeze b/testing/pandoc/cabal.project.freeze
index 41723442aa1..c532ee0f644 100644
--- a/testing/pandoc/cabal.project.freeze
+++ b/testing/pandoc/cabal.project.freeze
@@ -6,15 +6,17 @@ constraints: any.Cabal ==3.4.0.0,
HsYAML -exe,
any.JuicyPixels ==3.3.6,
JuicyPixels -mmap,
+ any.OneTuple ==0.3.1,
any.QuickCheck ==2.14.2,
QuickCheck -old-random +templatehaskell,
any.SHA ==1.6.4.4,
SHA -exe,
- any.aeson ==1.5.6.0,
- aeson -bytestring-builder -cffi -developer -fast,
+ any.StateVar ==1.2.2,
+ any.aeson ==2.0.2.0,
+ aeson -bytestring-builder -cffi +ordered-keymap,
any.aeson-pretty ==0.8.9,
aeson-pretty -lib-only,
- any.ansi-terminal ==0.11,
+ any.ansi-terminal ==0.11.1,
ansi-terminal -example,
any.ansi-wl-pprint ==0.6.9,
ansi-wl-pprint -example,
@@ -26,7 +28,7 @@ constraints: any.Cabal ==3.4.0.0,
any.assoc ==1.0.2,
any.async ==2.2.4,
async -bench,
- any.attoparsec ==0.14.2,
+ any.attoparsec ==0.14.3,
attoparsec -developer,
any.base ==4.15.0.0,
any.base-compat ==0.12.1,
@@ -48,7 +50,7 @@ constraints: any.Cabal ==3.4.0.0,
any.case-insensitive ==1.2.1.0,
any.cereal ==0.5.8.2,
cereal -bytestring-builder,
- any.citeproc ==0.5,
+ any.citeproc ==0.6,
citeproc -executable -icu,
any.clock ==0.8.2,
clock -llvm,
@@ -64,6 +66,8 @@ constraints: any.Cabal ==3.4.0.0,
any.conduit-extra ==1.3.5,
any.connection ==0.3.1,
any.containers ==0.6.4.1,
+ any.contravariant ==1.5.5,
+ contravariant +semigroups +statevar +tagged,
any.cookie ==0.4.5,
any.cryptonite ==0.29,
cryptonite -check_alignment +integer-gmp -old_toolchain_inliner +support_aesni +support_deepseq -support_pclmuldq +support_rdrand -support_sse +use_target_attributes,
@@ -89,30 +93,45 @@ constraints: any.Cabal ==3.4.0.0,
any.file-embed ==0.0.15.0,
any.filepath ==1.4.2.1,
any.ghc-bignum ==1.0,
+ any.ghc-bignum-orphans ==0.1.1,
any.ghc-boot-th ==9.0.1,
any.ghc-prim ==0.7.0,
any.haddock-library ==1.10.0,
- any.hashable ==1.3.5.0,
- hashable +integer-gmp -random-initial-seed,
+ any.happy ==1.20.0,
+ any.hashable ==1.4.0.1,
+ hashable +containers +integer-gmp -random-initial-seed,
+ any.haskell-lexer ==1.1,
any.hourglass ==0.2.12,
any.hsc2hs ==0.68.8,
hsc2hs -in-ghc-tree,
- any.hslua ==1.3.0.2,
- hslua +allow-unsafe-gc -apicheck +export-dynamic -hardcode-reg-keys -lua_32bits -pkg-config -system-lua,
- any.hslua-module-path ==0.1.0.1,
- any.hslua-module-system ==0.2.2.1,
- any.hslua-module-text ==0.3.0.1,
+ any.hslua ==2.0.1,
+ any.hslua-classes ==2.0.0,
+ any.hslua-core ==2.0.0.2,
+ any.hslua-marshalling ==2.0.1,
+ any.hslua-module-path ==1.0.0,
+ any.hslua-module-system ==1.0.0,
+ any.hslua-module-text ==1.0.0,
+ any.hslua-module-version ==1.0.0,
+ any.hslua-objectorientation ==2.0.1,
+ any.hslua-packaging ==2.0.0,
any.http-client ==0.7.9,
http-client +network-uri,
any.http-client-tls ==0.3.5.3,
any.http-types ==0.12.3,
any.indexed-traversable ==0.1.2,
+ any.indexed-traversable-instances ==0.1.1,
any.integer-gmp ==1.1,
any.integer-logarithms ==1.0.3.1,
integer-logarithms -check-bounds +integer-gmp,
any.iproute ==1.7.12,
any.ipynb ==0.1.0.2,
any.jira-wiki-markup ==1.4.0,
+ any.libyaml ==0.1.2,
+ libyaml -no-unicode -system-libyaml,
+ any.lpeg ==1.0.1,
+ lpeg -rely-on-shared-lpeg-library,
+ any.lua ==2.0.2,
+ lua +allow-unsafe-gc -apicheck +export-dynamic +hardcode-reg-keys -lua_32bits -pkg-config -system-lua,
any.memory ==0.16.0,
memory +support_basement +support_bytestring +support_deepseq +support_foundation,
any.mime-types ==0.1.0.9,
@@ -129,6 +148,7 @@ constraints: any.Cabal ==3.4.0.0,
any.parsec ==3.1.14.0,
any.pem ==0.2.4,
any.pretty ==1.1.3.6,
+ any.pretty-show ==1.10,
any.primitive ==0.7.3.0,
any.process ==1.6.11.0,
any.random ==1.2.1,
@@ -137,16 +157,20 @@ constraints: any.Cabal ==3.4.0.0,
any.safe ==0.3.19,
any.scientific ==0.3.7.0,
scientific -bytestring-builder -integer-simple,
- any.skylighting ==0.11,
+ any.semialign ==1.2.0.1,
+ semialign +semigroupoids,
+ any.semigroupoids ==5.3.6,
+ semigroupoids +comonad +containers +contravariant +distributive +tagged +unordered-containers,
+ any.skylighting ==0.12.1,
skylighting -executable,
- any.skylighting-core ==0.11,
+ any.skylighting-core ==0.12.1,
skylighting-core -executable,
any.socks ==0.6.1,
any.split ==0.2.3.4,
any.splitmix ==0.1.0.4,
splitmix -optimised-mixer,
any.stm ==2.5.0.0,
- any.streaming-commons ==0.2.2.2,
+ any.streaming-commons ==0.2.2.3,
streaming-commons -use-bytestring-builder,
any.strict ==0.4.0.1,
strict +assoc,
@@ -154,20 +178,23 @@ constraints: any.Cabal ==3.4.0.0,
any.tagged ==0.8.6.1,
tagged +deepseq +transformers,
any.tagsoup ==0.14.8,
- any.tasty ==1.4.2,
+ any.tasty ==1.4.2.1,
tasty +clock +unix,
- any.tasty-bench ==0.3,
+ any.tasty-bench ==0.3.1,
+ tasty-bench -debug +tasty,
any.tasty-golden ==2.3.4,
tasty-golden -build-example,
any.tasty-hunit ==0.10.0.3,
- any.tasty-lua ==0.2.3.2,
- any.tasty-quickcheck ==0.10.1.2,
+ any.tasty-lua ==1.0.0,
+ any.tasty-quickcheck ==0.10.2,
any.template-haskell ==2.17.0.0,
any.temporary ==1.3,
any.texmath ==0.12.3.2,
texmath -executable +network-uri,
any.text ==1.2.4.1,
any.text-conversions ==0.3.1,
+ any.text-short ==0.1.4,
+ text-short -asserts,
any.th-abstraction ==0.4.3.0,
any.th-compat ==0.1.3,
any.th-lift ==0.8.2,
@@ -182,7 +209,7 @@ constraints: any.Cabal ==3.4.0.0,
any.transformers ==0.5.6.2,
any.transformers-compat ==0.7.1,
transformers-compat -five +five-three -four +generic-deriving +mtl -three -two,
- any.typed-process ==0.2.7.0,
+ any.typed-process ==0.2.8.0,
any.unbounded-delays ==0.1.1.1,
any.unicode-collation ==0.1.3.1,
unicode-collation -doctests -executable,
@@ -195,7 +222,7 @@ constraints: any.Cabal ==3.4.0.0,
any.unix-compat ==0.5.3,
unix-compat -old-time,
any.unliftio-core ==0.2.0.1,
- any.unordered-containers ==0.2.15.0,
+ any.unordered-containers ==0.2.16.0,
unordered-containers -debug,
any.utf8-string ==1.0.2,
any.uuid-types ==1.0.5,
@@ -205,6 +232,7 @@ constraints: any.Cabal ==3.4.0.0,
vector-algorithms +bench +boundschecks -internalchecks -llvm +properties -unsafechecks,
any.wcwidth ==0.0.2,
wcwidth -cli +split-base,
+ any.witherable ==0.4.2,
any.x509 ==1.7.5,
any.x509-store ==1.6.7,
any.x509-system ==1.6.6,
@@ -212,8 +240,10 @@ constraints: any.Cabal ==3.4.0.0,
any.xml ==1.3.14,
any.xml-conduit ==1.9.1.1,
any.xml-types ==0.3.8,
+ any.yaml ==0.11.7.0,
+ yaml +no-examples +no-exe,
any.zip-archive ==0.4.1,
zip-archive -executable,
any.zlib ==0.6.2.3,
zlib -bundled-c-zlib -non-blocking-ffi -pkg-config
-index-state: hackage.haskell.org 2021-11-18T10:18:20Z
+index-state: hackage.haskell.org 2021-12-11T21:58:01Z