aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Jirku <box@wejn.org>2023-01-17 21:14:15 +0100
committerMichal Jirků <box@wejn.org>2023-01-17 20:42:05 +0000
commit64bbd67449291be46b7bb394091a1bc2edeeedde (patch)
treed2d70de9d241516206f5b65ec78ccfa4a2ef0258
parentec563188bd9c931e2bffcdf19ed4920311eb2e61 (diff)
community/elixir: upgrade to 1.14.3
Includes fixes for two issues: parallel compilation, and for the upstream issue 12345 (improper sed regexp).
-rw-r--r--community/elixir/APKBUILD12
-rw-r--r--community/elixir/issue-12345.patch17
2 files changed, 26 insertions, 3 deletions
diff --git a/community/elixir/APKBUILD b/community/elixir/APKBUILD
index deac5af6c70..b504186ea5d 100644
--- a/community/elixir/APKBUILD
+++ b/community/elixir/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Marlus Saraiva <marlus.saraiva@gmail.com>
# Maintainer: Michal Jirků <box@wejn.org>
pkgname=elixir
-pkgver=1.14.2
+pkgver=1.14.3
pkgrel=0
pkgdesc="Elixir is a dynamic, functional language designed for building scalable and maintainable applications"
url="https://elixir-lang.org/"
@@ -12,9 +12,14 @@ arch="noarch !armv7"
license="Apache-2.0"
depends="erlang-dev>=23.0 erlang-dialyzer"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/elixir-lang/elixir/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/elixir-lang/elixir/archive/v$pkgver.tar.gz
+ issue-12345.patch
+ "
build() {
+ # fix compile in 1.14.3, remove when the following is part of release tarball:
+ # https://github.com/elixir-lang/elixir/commit/0cce63e43f2fcbc8fe96fe2573e99b2279a69d65
+ sed -i 's/^.NOTPARALLEL: compile/.NOTPARALLEL:/' Makefile
LANG="en_US.UTF-8" make
}
@@ -30,5 +35,6 @@ package() {
}
sha512sums="
-ec492464553aa6bdaa37dbfd07b1fdc00d398242e269e73893d75b615e0fc44d360b2347378c45982281feed8d0c34c7fbdd09101ca12df0f7073cf52e43f04e elixir-1.14.2.tar.gz
+eec1e161364f823e26d79596d18b0ff7e6ade1c2c1f6f9ca84eb34d20fd90f434bbd29ef74cd41096e8f25e71d9cd1da0ec6f0a4f24c485124f9525b1ae2c4e0 elixir-1.14.3.tar.gz
+7ce0be877d8dbfe4e9b535bbbfbdd751427431bf0fd9e7c071c6008ce21c52dd6ad3d737ec72ed39b529ed8d25968dae5e0283792273a8d01a5d88c673ce3868 issue-12345.patch
"
diff --git a/community/elixir/issue-12345.patch b/community/elixir/issue-12345.patch
new file mode 100644
index 00000000000..3cf8c04bdb7
--- /dev/null
+++ b/community/elixir/issue-12345.patch
@@ -0,0 +1,17 @@
+Patch-source: https://github.com/wejn/elixir/commit/cf15f8a848034f4e8435f813e78ad7febac7da7c
+
+(manually tweaked offsets, because GH url returns the diff with off by two context)
+
+diff --git a/bin/elixir b/bin/elixir
+index 5a8cd9d87f..c891378475 100755
+--- a/bin/elixir
++++ b/bin/elixir
+@@ -234,7 +234,7 @@ set -- "$ERTS_BIN$ERL_EXEC" -pa "$SCRIPT_PATH"/../lib/*/ebin $ELIXIR_ERL_OPTIONS
+ if [ -n "$RUN_ERL_PIPE" ]; then
+ ESCAPED=""
+ for PART in "$@"; do
+- ESCAPED="$ESCAPED $(echo "$PART" | sed 's/[^a-zA-Z0-9_\-\/]/\\&/g')"
++ ESCAPED="$ESCAPED $(echo "$PART" | sed 's@[^a-zA-Z0-9_/-]@\\&@g')"
+ done
+ mkdir -p "$RUN_ERL_PIPE"
+ mkdir -p "$RUN_ERL_LOG"