aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2020-03-20 18:26:32 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-20 20:06:35 +0000
commit6529d8c34e12c8bd1915251eb0023aa0e789ba71 (patch)
treeb5fff1e0d051ac613f9c1b54f72f2b46bd4a387d
parenta1b4e3c1c4685194415837579139a368503cf0d8 (diff)
community/libgpiod: build python bindings and docs
-rw-r--r--community/libgpiod/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/community/libgpiod/APKBUILD b/community/libgpiod/APKBUILD
index 689ab1949ea..8b95e948a79 100644
--- a/community/libgpiod/APKBUILD
+++ b/community/libgpiod/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname=libgpiod
pkgver=1.4.2
-pkgrel=0
+pkgrel=1
pkgdesc="C library and tools for interacting with the linux GPIO character device"
url="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
arch="all"
license="LGPL-2.1-or-later"
options="!check" # no test suite
-makedepends="autoconf automake libtool linux-headers autoconf-archive"
-subpackages="$pkgname-dev"
+makedepends="autoconf automake libtool linux-headers autoconf-archive python3-dev doxygen help2man"
+subpackages="$pkgname-dev $pkgname-doc py3-$pkgname:_py3"
source="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/snapshot/libgpiod-$pkgver.tar.gz"
prepare() {
@@ -26,7 +26,8 @@ build() {
--mandir=/usr/share/man \
--localstatedir=/var \
--enable-tools=yes \
- --disable-static
+ --disable-static \
+ --enable-bindings-python
make
}
@@ -34,4 +35,11 @@ package() {
make DESTDIR="$pkgdir" install
}
+_py3() {
+ pkgdesc="Python bindings for libgpiod"
+ depends="python3"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
sha512sums="1c60bea50bb0e940273d90a122713b2693dbd5305afe313fad804b46add56b20d268f9903acca166b35f625e67b1bd05d05c9c995075937c96b22fb92655062a libgpiod-1.4.2.tar.gz"