aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-08-02 02:37:08 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-08-02 18:55:45 +0000
commit661380c48b20e22f83103acaa74e687eea8e1582 (patch)
tree5455079cc2a548e32b3ac7970ef0173dbd9b8eaf
parente4f5d66c1daeb5dc91ff7fdaec8337f7ee8d1e1d (diff)
main/ngrep: fix license
-rw-r--r--main/ngrep/APKBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/main/ngrep/APKBUILD b/main/ngrep/APKBUILD
index c3e8caefd7c..2e8d5eba5ac 100644
--- a/main/ngrep/APKBUILD
+++ b/main/ngrep/APKBUILD
@@ -3,26 +3,24 @@
pkgname=ngrep
pkgver=1.47
_pkgver="${pkgver/./_}"
-pkgrel=0
+pkgrel=1
pkgdesc="A grep-like utility that allows you to search for network packets on an interface"
url="http://ngrep.sourceforge.net/"
arch="all"
-license="BSD"
+license="custom"
makedepends="autoconf automake libpcap-dev pcre-dev"
options="!check"
subpackages="$pkgname-dbg $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jpr5/$pkgname/archive/V${_pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jpr5/ngrep/archive/V$_pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$_pkgver
prepare() {
- cd "$builddir"
default_prepare
update_config_sub
autoreconf -vif
}
build() {
- cd "$builddir"
export EXTRA_INCLUDES=$(pcre-config --cflags)
export EXTRA_LIBS=$(pcre-config --libs)
./configure \
@@ -38,10 +36,8 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm644 LICENSE \
- "$pkgdir"/usr/share/licenses/custom/$pkgname/LICENSE
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
sha512sums="47ba65878df6b555701c866721a8a935eabdcce636d398284cbfe5f63baf68c62d994a2f373ea4fc8f44fbed3eecee149f2ee48d39c71c04d34e5a088db8c657 ngrep-1.47.tar.gz"