aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2021-09-18 21:18:43 +0200
committerJakub Jirutka <jakub@jirutka.cz>2021-09-18 21:20:40 +0200
commit670f7b22caa3d98a993f9ef2055d9f5d040b66ba (patch)
tree7f97a86707ac09cfeada85da934141feaeee6919
parentb042aeecc95b4d9c2248c974bd40c3915b22ed27 (diff)
testing/b3sum: run cargo install with --locked
-rw-r--r--testing/b3sum/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/b3sum/APKBUILD b/testing/b3sum/APKBUILD
index d3fe9172055..3b7544bd2eb 100644
--- a/testing/b3sum/APKBUILD
+++ b/testing/b3sum/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=b3sum
pkgver=1.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Command line implementation of the BLAKE3 hash function"
url="https://blake3.io"
arch="all !s390x !armhf !mips !mips64 !riscv64" # armhf: 'vaddq_u32': target specific option mismatch
@@ -23,7 +23,7 @@ check() {
}
package() {
- cargo install --path . --root="$pkgdir/usr" --no-default-features ${_features:+--features "$_features"}
+ cargo install --locked --path . --root="$pkgdir/usr" --no-default-features ${_features:+--features "$_features"}
rm "$pkgdir"/usr/.crates*
}