aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2023-04-18 22:38:12 +0200
committerpsykose <alice@ayaya.dev>2023-04-20 11:15:13 +0200
commit67f16f0c38c480e14ca5aa9cd63c6099e36a7d01 (patch)
tree215b06de8f51ee532da9ba790ea94ce75ecb3ad1
parentff627796646f8dc3655e3bb17de3b72abd0481fd (diff)
community/py3-g*: split -pyc
-rw-r--r--community/py3-gast/APKBUILD3
-rw-r--r--community/py3-gatt/APKBUILD3
-rw-r--r--community/py3-genshi/APKBUILD3
-rw-r--r--community/py3-genty/APKBUILD3
-rw-r--r--community/py3-geocoder/APKBUILD3
-rw-r--r--community/py3-geographiclib/APKBUILD3
-rw-r--r--community/py3-geoip2/APKBUILD3
-rw-r--r--community/py3-geojson/APKBUILD3
-rw-r--r--community/py3-geopy/APKBUILD3
-rw-r--r--community/py3-geotiler/APKBUILD3
-rw-r--r--community/py3-gettext/APKBUILD3
-rw-r--r--community/py3-gevent/APKBUILD3
-rw-r--r--community/py3-gitdb2/APKBUILD3
-rw-r--r--community/py3-gitpython/APKBUILD3
-rw-r--r--community/py3-glad/APKBUILD3
-rw-r--r--community/py3-gnupg/APKBUILD3
-rw-r--r--community/py3-google-api-core/APKBUILD3
-rw-r--r--community/py3-google-auth-httplib2/APKBUILD3
-rw-r--r--community/py3-google-auth/APKBUILD3
-rw-r--r--community/py3-googleapis-common-protos/APKBUILD3
-rw-r--r--community/py3-gplearn/APKBUILD3
-rw-r--r--community/py3-gpxpy/APKBUILD3
-rw-r--r--community/py3-grapheme/APKBUILD3
-rw-r--r--community/py3-graphviz/APKBUILD3
-rw-r--r--community/py3-greenlet/APKBUILD3
-rw-r--r--community/py3-gtts/APKBUILD3
-rw-r--r--community/py3-guessit/APKBUILD3
-rw-r--r--community/py3-gunicorn/APKBUILD3
-rw-r--r--community/py3-gvm/APKBUILD3
29 files changed, 58 insertions, 29 deletions
diff --git a/community/py3-gast/APKBUILD b/community/py3-gast/APKBUILD
index 3c6b5eb8609..fdbc1aef3db 100644
--- a/community/py3-gast/APKBUILD
+++ b/community/py3-gast/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: psykose <alice@ayaya.dev>
pkgname=py3-gast
pkgver=0.5.3
-pkgrel=1
+pkgrel=2
pkgdesc="Python AST that abstracts the underlying Python version"
url="https://github.com/serge-sans-paille/gast"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/serge-sans-paille/gast/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/gast-$pkgver"
diff --git a/community/py3-gatt/APKBUILD b/community/py3-gatt/APKBUILD
index a8910a1b5e3..a047958ceeb 100644
--- a/community/py3-gatt/APKBUILD
+++ b/community/py3-gatt/APKBUILD
@@ -2,13 +2,14 @@
# Contributor: Martijn Braam <martijn@brixit.nl>
pkgname=py3-gatt
pkgver=0.2.6
-pkgrel=3
+pkgrel=4
pkgdesc="Python 2 and 3 compatibility library"
url="https://pypi.org/project/gatt"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://github.com/getsenic/gatt-python/archive/$pkgver/gatt-python-$pkgver.tar.gz"
builddir="$srcdir/gatt-python-$pkgver"
options="!check" # There's no testsuite
diff --git a/community/py3-genshi/APKBUILD b/community/py3-genshi/APKBUILD
index c1975db346e..9e0af26f35b 100644
--- a/community/py3-genshi/APKBUILD
+++ b/community/py3-genshi/APKBUILD
@@ -4,7 +4,7 @@
pkgname=py3-genshi
_realname=Genshi
pkgver=0.7.7
-pkgrel=1
+pkgrel=2
pkgdesc="Python toolkit for stream-based generation of output for the web"
url="http://genshi.edgewall.org/"
arch="all"
@@ -12,6 +12,7 @@ license="MIT"
depends="python3"
makedepends="py3-setuptools python3-dev"
checkdepends="py3-six"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/edgewall/genshi/archive/$pkgver.tar.gz"
builddir="$srcdir/genshi-$pkgver"
diff --git a/community/py3-genty/APKBUILD b/community/py3-genty/APKBUILD
index 21efea83632..f62cf163903 100644
--- a/community/py3-genty/APKBUILD
+++ b/community/py3-genty/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-genty
pkgver=1.3.2
-pkgrel=3
+pkgrel=4
pkgdesc="Allows you to run a test with multiple data sets"
url="https://github.com/box/genty"
arch="noarch"
@@ -13,6 +13,7 @@ checkdepends="
py3-mock
py3-pytest
"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/g/genty/genty-$pkgver.tar.gz"
options="!check" # Broken
builddir="$srcdir/genty-$pkgver"
diff --git a/community/py3-geocoder/APKBUILD b/community/py3-geocoder/APKBUILD
index 820e9d56062..1c7022b2fdd 100644
--- a/community/py3-geocoder/APKBUILD
+++ b/community/py3-geocoder/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-geocoder
pkgver=1.38.1
-pkgrel=3
+pkgrel=4
pkgdesc="A simple and consistent geocoding library"
url="https://github.com/DenisCarriere/geocoder"
arch="noarch"
@@ -10,6 +10,7 @@ license="MIT"
depends="python3 py3-requests py3-ratelim py3-click"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-requests-mock"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/g/geocoder/geocoder-$pkgver.tar.gz"
options="!check" # Requires both an API key and test files which are not present in the tarball
builddir="$srcdir/geocoder-$pkgver"
diff --git a/community/py3-geographiclib/APKBUILD b/community/py3-geographiclib/APKBUILD
index 5a51b8c6136..92a0d37489f 100644
--- a/community/py3-geographiclib/APKBUILD
+++ b/community/py3-geographiclib/APKBUILD
@@ -3,13 +3,14 @@
_pkgname=geographiclib
pkgname="py3-$_pkgname"
pkgver=2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Geodesic routines from GeographicLib"
url="https://geographiclib.sourceforge.io/"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools_scm"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-geoip2/APKBUILD b/community/py3-geoip2/APKBUILD
index 12fa8a15c08..ae3de0b8776 100644
--- a/community/py3-geoip2/APKBUILD
+++ b/community/py3-geoip2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-geoip2
pkgver=4.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="API for the GeoIP2 web services and databases"
options="!check" # Requires unpackaged mocket
url="https://www.maxmind.com/en/home"
@@ -12,6 +12,7 @@ depends="py3-requests py3-maxminddb py3-aiohttp py3-urllib3"
makedepends="python3-dev libmaxminddb-dev py3-setuptools"
checkdepends="py3-nose py3-mock"
_test_data_commit=2b37923df61aa3b5fb6c7edfbf4dc5fafa10258a
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/maxmind/GeoIP2-python/archive/v$pkgver.tar.gz
MaxMind-DB-test-data-$_test_data_commit.tar.gz::https://github.com/maxmind/MaxMind-DB/archive/$_test_data_commit.tar.gz"
builddir="$srcdir/GeoIP2-python-$pkgver"
diff --git a/community/py3-geojson/APKBUILD b/community/py3-geojson/APKBUILD
index 3a10498cf07..dea390f0aa4 100644
--- a/community/py3-geojson/APKBUILD
+++ b/community/py3-geojson/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-geojson
pkgver=3.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="Python bindings and utilities for GeoJSON"
url="https://github.com/jazzband/geojson"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/g/geojson/geojson-$pkgver.tar.gz"
builddir="$srcdir/geojson-$pkgver"
diff --git a/community/py3-geopy/APKBUILD b/community/py3-geopy/APKBUILD
index 8314663788c..37c2820586d 100644
--- a/community/py3-geopy/APKBUILD
+++ b/community/py3-geopy/APKBUILD
@@ -3,7 +3,7 @@
_pkgname=geopy
pkgname="py3-$_pkgname"
pkgver=2.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Geocoding library"
url="https://geopy.readthedocs.io/"
arch="noarch"
@@ -20,6 +20,7 @@ checkdepends="
py3-pytest-asyncio
py3-sphinx
"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/g/geopy/geopy-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-geotiler/APKBUILD b/community/py3-geotiler/APKBUILD
index 7b131576b0e..879efaf7f22 100644
--- a/community/py3-geotiler/APKBUILD
+++ b/community/py3-geotiler/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-geotiler
_pkgorig=geotiler
pkgver=0.14.7
-pkgrel=0
+pkgrel=1
pkgdesc="GeoTiler is a library to create map using tiles from a map provider"
url="https://github.com/wrobell/geotiler"
arch="noarch"
@@ -26,6 +26,7 @@ makedepends="
py3-setuptools
py3-wheel
"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/g/geotiler/geotiler-$pkgver.tar.gz"
builddir="$srcdir/$_pkgorig-$pkgver"
diff --git a/community/py3-gettext/APKBUILD b/community/py3-gettext/APKBUILD
index aa209ff37f0..a69c35a4bf8 100644
--- a/community/py3-gettext/APKBUILD
+++ b/community/py3-gettext/APKBUILD
@@ -3,12 +3,13 @@
pkgname=py3-gettext
_pkgname=gettext
pkgver=4.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python implementation of Gettext"
url="https://github.com/hannosch/python-gettext"
arch="noarch"
license="GPL-3.0-or-later"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/hannosch/python-gettext/archive/$pkgver.tar.gz"
builddir="$srcdir/python-$_pkgname-$pkgver"
diff --git a/community/py3-gevent/APKBUILD b/community/py3-gevent/APKBUILD
index 32284969f73..4521b83cd37 100644
--- a/community/py3-gevent/APKBUILD
+++ b/community/py3-gevent/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Michael Zhou <zhoumichaely@gmail.com>
pkgname=py3-gevent
pkgver=22.10.2
-pkgrel=3
+pkgrel=4
pkgdesc="Python3 library for seamless coroutine-based concurrency"
url="http://gevent.org/"
arch="all"
@@ -27,6 +27,7 @@ makedepends="
python3-dev
"
checkdepends="python3-tests py3-objgraph"
+subpackages="$pkgname-pyc"
source="https://github.com/gevent/gevent/archive/$pkgver/gevent-$pkgver.tar.gz"
builddir="$srcdir/gevent-$pkgver"
options="!check" # tests fail
diff --git a/community/py3-gitdb2/APKBUILD b/community/py3-gitdb2/APKBUILD
index 00abae0a32f..19b47610d90 100644
--- a/community/py3-gitdb2/APKBUILD
+++ b/community/py3-gitdb2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=py3-gitdb2
pkgver=4.0.10
-pkgrel=0
+pkgrel=1
pkgdesc="Git Object Database"
options="!check" # (failures=1,errors=9)
url="https://github.com/gitpython-developers/gitdb"
@@ -10,6 +10,7 @@ arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-smmap2"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/gitpython-developers/gitdb/archive/$pkgver.tar.gz"
builddir="$srcdir/gitdb-$pkgver"
diff --git a/community/py3-gitpython/APKBUILD b/community/py3-gitpython/APKBUILD
index 44c50c271b4..70ba7f43a7f 100644
--- a/community/py3-gitpython/APKBUILD
+++ b/community/py3-gitpython/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-gitpython
pkgver=3.1.31
-pkgrel=0
+pkgrel=1
pkgdesc="Python3 Git Library"
url="https://github.com/gitpython-developers/GitPython"
arch="noarch"
@@ -20,6 +20,7 @@ checkdepends="
py3-pytest-sugar
py3-toml
"
+subpackages="$pkgname-pyc"
source="https://github.com/gitpython-developers/GitPython/archive/$pkgver/GitPython-$pkgver.tar.gz"
builddir="$srcdir/GitPython-$pkgver"
diff --git a/community/py3-glad/APKBUILD b/community/py3-glad/APKBUILD
index b9e347d0607..5f24c4b046a 100644
--- a/community/py3-glad/APKBUILD
+++ b/community/py3-glad/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: psykose <alice@ayaya.dev>
pkgname=py3-glad
pkgver=2.0.4
-pkgrel=0
+pkgrel=1
pkgdesc="Multi-Language Vulkan/GL/GLES/EGL/GLX/WGL Loader-Generator based on the official specs"
url="https://github.com/Dav1dde/glad"
arch="noarch"
@@ -13,6 +13,7 @@ makedepends="
py3-wheel
"
checkdepends="py3-mock py3-nose"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/Dav1dde/glad/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/glad-$pkgver"
# only bigger integration tests
diff --git a/community/py3-gnupg/APKBUILD b/community/py3-gnupg/APKBUILD
index f74a4ded7b6..7645af06921 100644
--- a/community/py3-gnupg/APKBUILD
+++ b/community/py3-gnupg/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=py3-gnupg
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Python3 wrapper for the Gnu Privacy Guard (GPG or GnuPG)"
url="https://gnupg.readthedocs.io/en/latest/"
arch="noarch"
@@ -10,6 +10,7 @@ license="BSD-3-Clause"
depends="python3 gnupg"
makedepends="py3-setuptools py3-wheel py3-gpep517 py3-installer"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://pypi.io/packages/source/p/python-gnupg/python-gnupg-$pkgver.tar.gz"
builddir="$srcdir/python-gnupg-$pkgver"
options="!check" # hang
diff --git a/community/py3-google-api-core/APKBUILD b/community/py3-google-api-core/APKBUILD
index f7f93051d9e..5c8b790a1fa 100644
--- a/community/py3-google-api-core/APKBUILD
+++ b/community/py3-google-api-core/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-google-api-core
pkgver=2.11.0
-pkgrel=0
+pkgrel=1
pkgdesc="Google API client core library"
url="https://github.com/googleapis/python-api-core"
arch="noarch"
@@ -24,6 +24,7 @@ checkdepends="
py3-mock
py3-pytest
"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/g/google-api-core/google-api-core-$pkgver.tar.gz"
builddir="$srcdir/google-api-core-$pkgver"
options="!check" # missing some "proto" dep
diff --git a/community/py3-google-auth-httplib2/APKBUILD b/community/py3-google-auth-httplib2/APKBUILD
index 7773b89bc74..8f53ba8fd1f 100644
--- a/community/py3-google-auth-httplib2/APKBUILD
+++ b/community/py3-google-auth-httplib2/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-google-auth-httplib2
_pyname=google-auth-httplib2
pkgver=0.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Google Authentication Library: httplib2 transport"
url="https://github.com/googleapis/google-auth-library-python-httplib2"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-google-auth py3-httplib2"
checkdepends="py3-flask py3-mock py3-pytest py3-pytest-localserver py3-six"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/g/google-auth-httplib2/google-auth-httplib2-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
diff --git a/community/py3-google-auth/APKBUILD b/community/py3-google-auth/APKBUILD
index 82bad9d35b7..c5973889f31 100644
--- a/community/py3-google-auth/APKBUILD
+++ b/community/py3-google-auth/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-google-auth
_pyname=google-auth
pkgver=2.17.3
-pkgrel=0
+pkgrel=1
pkgdesc="Google authentication library for Python."
url="https://google-auth.readthedocs.io/en/latest/"
arch="noarch"
@@ -37,6 +37,7 @@ checkdepends="
py3-responses
py3-urllib3
"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/g/google-auth/google-auth-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
diff --git a/community/py3-googleapis-common-protos/APKBUILD b/community/py3-googleapis-common-protos/APKBUILD
index e8db1c16bf5..0eb8e999a1e 100644
--- a/community/py3-googleapis-common-protos/APKBUILD
+++ b/community/py3-googleapis-common-protos/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-googleapis-common-protos
pkgver=1.59.0
-pkgrel=0
+pkgrel=1
pkgdesc="Common protobufs used in Google APIs for Python"
url="https://pypi.org/project/googleapis-common-protos/"
arch="noarch"
@@ -20,6 +20,7 @@ checkdepends="
py3-grpcio
py3-pytest
"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/g/googleapis-common-protos/googleapis-common-protos-$pkgver.tar.gz"
builddir="$srcdir/googleapis-common-protos-$pkgver"
diff --git a/community/py3-gplearn/APKBUILD b/community/py3-gplearn/APKBUILD
index d2aff2988cf..d1e7cf927d5 100644
--- a/community/py3-gplearn/APKBUILD
+++ b/community/py3-gplearn/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
pkgname=py3-gplearn
pkgver=0.4.2
-pkgrel=0
+pkgrel=1
pkgdesc="Genetic Programming in Python, with a scikit-learn inspired API"
url="https://github.com/trevorstephens/gplearn"
# py3-scikit-learn is missing on s390x
@@ -15,6 +15,7 @@ depends="
"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://github.com/trevorstephens/gplearn/archive/$pkgver/gplearn-$pkgver.tar.gz"
builddir="$srcdir/gplearn-$pkgver"
diff --git a/community/py3-gpxpy/APKBUILD b/community/py3-gpxpy/APKBUILD
index f297644030f..b7f8c72dd53 100644
--- a/community/py3-gpxpy/APKBUILD
+++ b/community/py3-gpxpy/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-gpxpy
pkgver=1.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python3 GPX parser"
url="https://github.com/tkrajina/gpxpy"
arch="noarch"
license="Apache-2.0"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/g/gpxpy/gpxpy-$pkgver.tar.gz"
builddir="$srcdir/gpxpy-$pkgver"
diff --git a/community/py3-grapheme/APKBUILD b/community/py3-grapheme/APKBUILD
index f7089e96782..d28189a3db4 100644
--- a/community/py3-grapheme/APKBUILD
+++ b/community/py3-grapheme/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
pkgname=py3-grapheme
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Unicode grapheme helpers"
url="https://github.com/alvinlindstam/grapheme"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/g/grapheme/grapheme-$pkgver.tar.gz"
builddir="$srcdir/grapheme-$pkgver"
options="!check" # no tests in pypi version | GH tags not consistent | disable tests for now
diff --git a/community/py3-graphviz/APKBUILD b/community/py3-graphviz/APKBUILD
index 61dd6c46f03..2b7a4213e26 100644
--- a/community/py3-graphviz/APKBUILD
+++ b/community/py3-graphviz/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-graphviz
pkgver=0.20.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple interface for Graphviz"
url="https://github.com/xflr6/graphviz"
arch="noarch"
@@ -18,6 +18,7 @@ checkdepends="
py3-pytest-mock
py3-pytest
"
+subpackages="$pkgname-pyc"
source="https://github.com/xflr6/graphviz/archive/$pkgver/graphviz-$pkgver.tar.gz"
builddir="$srcdir/graphviz-$pkgver"
diff --git a/community/py3-greenlet/APKBUILD b/community/py3-greenlet/APKBUILD
index 36dab3c2ee4..c4b8665b236 100644
--- a/community/py3-greenlet/APKBUILD
+++ b/community/py3-greenlet/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: psykose <alice@ayaya.dev>
pkgname=py3-greenlet
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight in-process concurrent programming"
url="https://pypi.org/project/greenlet"
arch="all"
license="MIT"
makedepends="py3-setuptools python3-dev py3-gpep517 py3-wheel"
checkdepends="py3-objgraph py3-psutil"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/g/greenlet/greenlet-$pkgver.tar.gz"
builddir="$srcdir/greenlet-$pkgver"
diff --git a/community/py3-gtts/APKBUILD b/community/py3-gtts/APKBUILD
index fddb289e927..d5999879f68 100644
--- a/community/py3-gtts/APKBUILD
+++ b/community/py3-gtts/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-gtts
pkgver=2.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="A Python library and CLI tool to interface with Google Translate text-to-speech API"
url="https://github.com/pndurette/gTTS"
arch="noarch"
@@ -23,6 +23,7 @@ checkdepends="
py3-pytest
py3-testfixtures
"
+subpackages="$pkgname-pyc"
source="https://github.com/pndurette/gTTS/archive/v$pkgver/gTTS-$pkgver.tar.gz"
# Net required for tests
options="net"
diff --git a/community/py3-guessit/APKBUILD b/community/py3-guessit/APKBUILD
index 1ed19572b40..bee9bf9b797 100644
--- a/community/py3-guessit/APKBUILD
+++ b/community/py3-guessit/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Philipp Glaum <p@pglaum.de>
pkgname=py3-guessit
pkgver=3.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="Library for guessing information from video filenames"
url="https://pypi.org/project/guessit/"
arch="noarch"
@@ -25,6 +25,7 @@ checkdepends="
py3-pytest-xdist
py3-yaml
"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/g/guessit/guessit-$pkgver.tar.gz"
builddir="$srcdir/guessit-$pkgver"
diff --git a/community/py3-gunicorn/APKBUILD b/community/py3-gunicorn/APKBUILD
index 08c8193a270..0894a51588f 100644
--- a/community/py3-gunicorn/APKBUILD
+++ b/community/py3-gunicorn/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-gunicorn
_pkgname=gunicorn
pkgver=20.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="WSGI HTTP Server for UNIX"
url="https://gunicorn.org/"
arch="noarch"
license="MIT"
depends="py3-setuptools"
checkdepends="py3-pytest py3-pytest-cov py3-aiohttp py3-gevent"
+subpackages="$pkgname-pyc"
source="$_pkgname-$pkgver.tar.gz::https://github.com/benoitc/gunicorn/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-gvm/APKBUILD b/community/py3-gvm/APKBUILD
index 95389280e3d..d7807d9143e 100644
--- a/community/py3-gvm/APKBUILD
+++ b/community/py3-gvm/APKBUILD
@@ -4,7 +4,7 @@ pkgname=py3-gvm
_pkgname=${pkgname/py3/python}
# follow the same version of gvm-tools
pkgver=23.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="Greenbone Vulnerability Management Python Library "
url="https://github.com/greenbone/python-gvm"
arch="noarch"
@@ -12,6 +12,7 @@ license="GPL-3.0-or-later"
depends="python3 py3-paramiko py3-lxml py3-defusedxml"
makedepends="py3-gpep517 py3-installer py3-poetry-core"
checkdepends="py3-defusedxml py3-pytest py3-lxml py3-paramiko"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/greenbone/$_pkgname/archive/v${pkgver/_/.}.tar.gz"
builddir="$srcdir/$_pkgname-${pkgver/_/.}"