aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-10-22 11:22:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-10-22 17:25:33 -0300
commit68a733789003e9a2adbc1c889de199778c8566ce (patch)
tree03ac4dc100b2470f37314f9265235e94ea06e064
parent7a9c9f12c3138b421dca0b269388cd198ec30778 (diff)
downloadaports-68a733789003e9a2adbc1c889de199778c8566ce.tar.gz
aports-68a733789003e9a2adbc1c889de199778c8566ce.tar.bz2
aports-68a733789003e9a2adbc1c889de199778c8566ce.tar.xz
community/plasma: upgrade to 5.20.1
-rw-r--r--community/bluedevil/APKBUILD8
-rw-r--r--community/breeze-grub/APKBUILD4
-rw-r--r--community/breeze-gtk/APKBUILD8
-rw-r--r--community/breeze-plymouth/APKBUILD4
-rw-r--r--community/breeze/APKBUILD8
-rw-r--r--community/discover/APKBUILD8
-rw-r--r--community/drkonqi/APKBUILD8
-rw-r--r--community/kactivitymanagerd/APKBUILD8
-rw-r--r--community/kde-cli-tools/APKBUILD8
-rw-r--r--community/kde-gtk-config/APKBUILD8
-rw-r--r--community/kdecoration/APKBUILD4
-rw-r--r--community/kdeplasma-addons/APKBUILD4
-rw-r--r--community/kgamma5/APKBUILD8
-rw-r--r--community/khotkeys/APKBUILD8
-rw-r--r--community/kinfocenter/APKBUILD8
-rw-r--r--community/kmenuedit/APKBUILD8
-rw-r--r--community/kscreen/APKBUILD8
-rw-r--r--community/kscreenlocker/APKBUILD8
-rw-r--r--community/ksshaskpass/APKBUILD8
-rw-r--r--community/ksysguard/APKBUILD8
-rw-r--r--community/kwallet-pam/APKBUILD8
-rw-r--r--community/kwayland-integration/APKBUILD4
-rw-r--r--community/kwayland-server/APKBUILD4
-rw-r--r--community/kwin/APKBUILD8
-rw-r--r--community/kwrited/APKBUILD4
-rw-r--r--community/libkscreen/APKBUILD4
-rw-r--r--community/libksysguard/APKBUILD8
-rw-r--r--community/milou/APKBUILD8
-rw-r--r--community/oxygen/APKBUILD8
-rw-r--r--community/plasma-browser-integration/APKBUILD8
-rw-r--r--community/plasma-desktop/APKBUILD9
-rw-r--r--community/plasma-integration/APKBUILD8
-rw-r--r--community/plasma-nano/APKBUILD8
-rw-r--r--community/plasma-nm/APKBUILD8
-rw-r--r--community/plasma-pa/APKBUILD8
-rw-r--r--community/plasma-phone-components/APKBUILD8
-rw-r--r--community/plasma-sdk/APKBUILD8
-rw-r--r--community/plasma-thunderbolt/APKBUILD8
-rw-r--r--community/plasma-vault/APKBUILD8
-rw-r--r--community/plasma-workspace-wallpapers/APKBUILD4
-rw-r--r--community/plasma-workspace/APKBUILD10
-rw-r--r--community/plasma/APKBUILD4
-rw-r--r--community/plymouth-kcm/APKBUILD8
-rw-r--r--community/polkit-kde-agent-1/APKBUILD8
-rw-r--r--community/powerdevil/APKBUILD8
-rw-r--r--community/sddm-kcm/APKBUILD8
-rw-r--r--community/systemsettings/APKBUILD8
-rw-r--r--community/xdg-desktop-portal-kde/APKBUILD4
48 files changed, 207 insertions, 136 deletions
diff --git a/community/bluedevil/APKBUILD b/community/bluedevil/APKBUILD
index 1e966ebe44..215c80957d 100644
--- a/community/bluedevil/APKBUILD
+++ b/community/bluedevil/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=bluedevil
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Integrate the Bluetooth technology within KDE workspace and applications"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kiconthemes
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends="kded bluez"
@@ -29,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="38a2703b9a5407166aba7227612cd861f473688a883dfaf9276c0809ec717f15c6cc2493bd7bcb2255f42a79edf1dd266ddcd20647897ee657452ae138af46dc bluedevil-5.20.0.tar.xz"
+sha512sums="eacd7396cc0b55b3b20107f40c2059c8426f1ffa840e11015f8d140fd451a4de381bfac614cb4d0a21bca6ccb361f98a8cf156955a662b813d1a8b17c8daf121 bluedevil-5.20.1.tar.xz"
diff --git a/community/breeze-grub/APKBUILD b/community/breeze-grub/APKBUILD
index 1c861e9023..c8a070e80d 100644
--- a/community/breeze-grub/APKBUILD
+++ b/community/breeze-grub/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=breeze-grub
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Breeze theme for GRUB"
arch="noarch !s390x !armhf" # armhf blocked by extra-cmake-modules
@@ -20,4 +20,4 @@ package() {
install -d "$pkgdir"/usr/share/grub/themes
cp -r breeze "$pkgdir"/usr/share/grub/themes
}
-sha512sums="0954036373179357a6c32c47725a119964c94b808ef5b3325cea79ddc7f2decf2b5e7ce02421b258884b03b708a3e30adcdd212fae6e30cae23f49e1c783b558 breeze-grub-5.20.0.tar.xz"
+sha512sums="9739cda1708e07c1e8e332d2212ca20b45ba7b45ef670574181502e39f8eef9d81b040cf48b7d0aa19684ba5d3c6cfaf07cb28699cfdacea80dad0017729debb breeze-grub-5.20.1.tar.xz"
diff --git a/community/breeze-gtk/APKBUILD b/community/breeze-gtk/APKBUILD
index 5f9e4a7062..506065c8d9 100644
--- a/community/breeze-gtk/APKBUILD
+++ b/community/breeze-gtk/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=breeze-gtk
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="A GTK Theme Built to Match KDE's Breeze"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by breeze
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-only"
depends="gtk-engines"
@@ -27,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="0eabe2961a6c78872bc0e4f6fb2e453d6686ba5b6abb0989e0b721fe9c87792172f25bf7afd3b3d8b3e31d1462348b0a6ad9a735d9d45577de089dc72cb80076 breeze-gtk-5.20.0.tar.xz"
+sha512sums="1ab35f561bccddf745f0bb50c1c617de6c957194f9d57a9aa430bc3cde291ef4a8ff16e2dc040502a959fdc367bc44a35b20c646d04cae17088cb98587437630 breeze-gtk-5.20.1.tar.xz"
diff --git a/community/breeze-plymouth/APKBUILD b/community/breeze-plymouth/APKBUILD
index ee83c87e74..3af1c3774c 100644
--- a/community/breeze-plymouth/APKBUILD
+++ b/community/breeze-plymouth/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=breeze-plymouth
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://kde.org/"
@@ -25,4 +25,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="ba268f4971cf17311b78d0b1a977e6795221638258dbf9cfe99eb988d1c320d135d5efc7eab057ac6bfac620149db52b32edf074cba07c816a67b0a83e558183 breeze-plymouth-5.20.0.tar.xz"
+sha512sums="ebedae057a766ed4588c4f2af17e8e82e4e1a1b074f7ebfc04be3eb19812a893e6cfe7a16154facea36848de3a56d8bcf83251a5cd3845b890e5360f59d51f19 breeze-plymouth-5.20.1.tar.xz"
diff --git a/community/breeze/APKBUILD b/community/breeze/APKBUILD
index 52fe544e04..f8bdc7d35c 100644
--- a/community/breeze/APKBUILD
+++ b/community/breeze/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=breeze
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Artwork, styles and assets for the Breeze visual style for the Plasma Desktop"
-arch="all !armhf" # disable on armhf due to missing qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kiconthemes
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later"
depends_dev="kdecoration-dev kpackage-dev ki18n-dev kguiaddons-dev kconfigwidgets-dev kwindowsystem-dev kiconthemes-dev"
@@ -28,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="bb76c1b60ce7ff7b8fbabda232d1d50fe86fc0e2d56ad7feadb582b89ec796851f97f3339c7423cbb6e14db2fe609aeb4f5d046a2f26f8c6fed2336de2d0a16a breeze-5.20.0.tar.xz"
+sha512sums="63b1737a048f0675591e8395d5b3a39fa65a32987936676433827b72d1c9a867b8f29ffe1f77799916e53c12880d54c42772d260b45933ca949f9153628e7b51 breeze-5.20.1.tar.xz"
diff --git a/community/discover/APKBUILD b/community/discover/APKBUILD
index 692aaab36c..35e6636b62 100644
--- a/community/discover/APKBUILD
+++ b/community/discover/APKBUILD
@@ -1,9 +1,11 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=discover
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by flatpak
+arch="all !armhf !s390x"
url="https://userbase.kde.org/Discover"
pkgdesc="KDE Plasma resources management GUI"
license="LGPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
@@ -79,4 +81,4 @@ backend_fwupd() {
"$subpkgdir"/usr/lib/qt5/plugins/discover/
}
-sha512sums="70bda593c21f2b1cd039e254847c00b488beb3f9fc5560bce245656c277a38bd4be25b065730f832b6bedcbd2213f1c8b751cc1f3959c14b4c6480cc06d015a2 discover-5.20.0.tar.xz"
+sha512sums="97a774c38de586cf6e817feb29f58d2d18c793dd0c5a65d628225fc67ac3ab5b866e40e0a5dccfac51cff549109d369c031bcd1194ead5cb1c38729a3e17b7e5 discover-5.20.1.tar.xz"
diff --git a/community/drkonqi/APKBUILD b/community/drkonqi/APKBUILD
index f65ccff9c0..bed28dfdeb 100644
--- a/community/drkonqi/APKBUILD
+++ b/community/drkonqi/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=drkonqi
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Manages the power consumption settings of a Plasma Shell"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by kconfigwidgets
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtx11extras-dev ki18n-dev kcoreaddons-dev kservice-dev kconfigwidgets-dev kjobwidgets-dev kio-dev kcrash-dev kcompletion-dev kxmlrpcclient-dev kwidgetsaddons-dev kwallet-dev knotifications-dev kidletime-dev syntax-highlighting-dev"
@@ -30,4 +32,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="81b3bde1a786b5a8d341a1af21c4f92ab20c758d0a3f2d5dadfb2d07556bb4582e7fa852082220535ed2dade7d2b0f65f1d154a671bb6667a29cff07f7a1a267 drkonqi-5.20.0.tar.xz"
+sha512sums="a2d3672495d4b77392c7c5d7710f9fef7a2566817c32b3b93f8cf67ee5d9896d427a12a0257142f86aeb5973438d785e3b6cc3f9f45a47450811557c5c8fa329 drkonqi-5.20.1.tar.xz"
diff --git a/community/kactivitymanagerd/APKBUILD b/community/kactivitymanagerd/APKBUILD
index b8872e73cb..913cb711b1 100644
--- a/community/kactivitymanagerd/APKBUILD
+++ b/community/kactivitymanagerd/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kactivitymanagerd
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="System service to manage user's activities and track the usage patterns"
-arch="all !armhf" # disable armhf due to missing qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kxmlgui
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-only OR GPL-3.0-only"
depends="qt5-qtbase-sqlite"
@@ -28,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="f2f6664f511e397b3d246390175a7ae7d89a866076cff5833c97152212942165294cb7d224114a5a1b75ccb9c82402c4a3e16a0404e89390572497a34c711e4c kactivitymanagerd-5.20.0.tar.xz"
+sha512sums="05ebdebaca326ff57b173dca6003557b7fbd113782ec643269cdca16ebf3fdcf5e11602a9102d863cbd87e8b9e764588aa00782b48c4acb9fb7516f45e826c14 kactivitymanagerd-5.20.1.tar.xz"
diff --git a/community/kde-cli-tools/APKBUILD b/community/kde-cli-tools/APKBUILD
index 43b5078a2b..bd628beedb 100644
--- a/community/kde-cli-tools/APKBUILD
+++ b/community/kde-cli-tools/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kde-cli-tools
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Tools based on KDE Frameworks 5 to better interact with the system"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by libksysguard
+arch="all !armhf !s390x"
url="https://cgit.kde.org/kde-cli-tools"
license="(GPL-2.0-only OR GPL-3.0-only) AND GPL-2.0-or-later AND GPL-2.0-only AND LGPL-2.1-only"
makedepends="extra-cmake-modules kdoctools-dev qt5-qtbase-dev qt5-qtsvg-dev qt5-qtx11extras-dev kconfig-dev kiconthemes-dev kinit-dev ki18n-dev kcmutils-dev kio-dev kservice-dev kwindowsystem-dev kactivities-dev kdeclarative-dev kdesu-dev plasma-workspace-dev"
@@ -32,4 +34,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="f3637edb92cf955e255d31bd857633716ac6072f2a2e0c95f070a2e91c83c624f1ea14e156c5b390dde48a4795bdafe412454b1c2dfeedd643cb8c91e2f23fd1 kde-cli-tools-5.20.0.tar.xz"
+sha512sums="d73a3466999caa36bbe3bc78578ce88f15b7ea7a96f1f79a95db51e3f70f25ac627b87d07154fe5d2e8c04dcef1309506a17c8443c497961e98af7f3555cb1c5 kde-cli-tools-5.20.1.tar.xz"
diff --git a/community/kde-gtk-config/APKBUILD b/community/kde-gtk-config/APKBUILD
index fbf2257e5f..46f80f006f 100644
--- a/community/kde-gtk-config/APKBUILD
+++ b/community/kde-gtk-config/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kde-gtk-config
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="GTK2 and GTK3 Configurator for KDE"
-arch="all !armhf" # qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kcmutils
+arch="all !armhf !s390x"
url="https://cgit.kde.org/kde-gtk-config"
license="GPL-2.0 AND LGPL-2.1-only OR LGPL-3.0-only"
depends="gsettings-desktop-schemas"
@@ -43,4 +45,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="04f1e3053b896e4c61d1e215b68c4eb97070d4062b1a394346d7236e1e80a6a8af080e970576af32498d5c74b63b21dafc9c12a92636ce6c03eac84442de0db1 kde-gtk-config-5.20.0.tar.xz"
+sha512sums="108c1b53a6e6b7f54f95ded3193358b222964e84806c8d1759368bc995f0fd825bd1a6fc520c38a62e870c1487ec920672b1879af25a55d7a597dbfac7c09ac0 kde-gtk-config-5.20.1.tar.xz"
diff --git a/community/kdecoration/APKBUILD b/community/kdecoration/APKBUILD
index 701a50009a..f96f6b4420 100644
--- a/community/kdecoration/APKBUILD
+++ b/community/kdecoration/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdecoration
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Plugin based library to create window decorations"
arch="all !armhf"
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="d0c50a45233ce11ca27a121f466e7cf6149368104025280874c11ee6adcc28a36be570979c0a7b89b66af174b302f132f44599a06783a5cb218c85610a87d946 kdecoration-5.20.0.tar.xz"
+sha512sums="87412989faf6ef60c7986ba3f145b530625ad5f209c0b827d8ba2db4bfe99e4bbfa7cf9556135c19fef7a8c128f510a115b295687485dc35fd428c078bd012ed kdecoration-5.20.1.tar.xz"
diff --git a/community/kdeplasma-addons/APKBUILD b/community/kdeplasma-addons/APKBUILD
index b88da9faef..57e6cf6714 100644
--- a/community/kdeplasma-addons/APKBUILD
+++ b/community/kdeplasma-addons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdeplasma-addons
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="All kind of addons to improve your Plasma experience"
# mips, ppc64le and s390x blocked by qt5-qtwebengine
@@ -37,4 +37,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="45484ddb8ef8eee0a793ff3d57dfd3fd143c4892eff7224cec847fc7c11becc0f10b54bc8533d331bc504df75e8c31522064165dee08d8b60093dbe4c626472f kdeplasma-addons-5.20.0.tar.xz"
+sha512sums="49dc4d3394ea68e3e92acbabef0137927f305cb522713fea54d9fbe7fc1f29375f26b2937d32cf99eba2467ba4ebf00c90129f4c8c5fecaf07db3a59479fcc3b kdeplasma-addons-5.20.1.tar.xz"
diff --git a/community/kgamma5/APKBUILD b/community/kgamma5/APKBUILD
index 82325b7903..a8d858c6f0 100644
--- a/community/kgamma5/APKBUILD
+++ b/community/kgamma5/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kgamma5
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Adjust your monitor's gamma settings"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by kconfigwidgets
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later"
makedepends="qt5-qtbase-dev kconfig-dev kconfigwidgets-dev kdoctools-dev ki18n-dev extra-cmake-modules"
@@ -28,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="8681f10c9706f9e2da0262ad64cec5615e3894574116d37877dfb8fe82bf859e3bcba7d0a446ae7e4eeb6c193c94e0725bce8a572f15ce458ea323c66fdf53c4 kgamma5-5.20.0.tar.xz"
+sha512sums="51f5c2662a50122ca3046f0621c1903ae79a1d26c980a3fab9ca5c59dd112f7f947b315d447c82480bfeb8a5e695e300b35a36b998e8d0a0d6c4a2eb70d4dd8f kgamma5-5.20.1.tar.xz"
diff --git a/community/khotkeys/APKBUILD b/community/khotkeys/APKBUILD
index c81d450852..036b9de3e9 100644
--- a/community/khotkeys/APKBUILD
+++ b/community/khotkeys/APKBUILD
@@ -1,9 +1,11 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=khotkeys
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by libksysguard
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
pkgdesc="Key Accelerator Application"
license="GPL-2.0-only AND LGPL-2.0-or-later"
@@ -29,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="4d1315cec456af364023416e4ff526e143790a75cdb5fbdbd14a63fe13fee12f2cc7d0cccd7a2a4b4d21597b7511ead18a174614e71c41d658b1bb6fbc07393b khotkeys-5.20.0.tar.xz"
+sha512sums="8032d6a60b42ec595d66e70106dffaca79c9044187fc16fc757165a14a6a3a1fc0b5adb1aedefb00304fae32ee9125b00ee7c5f7b740d6361c505d45e4d5d7ef khotkeys-5.20.1.tar.xz"
diff --git a/community/kinfocenter/APKBUILD b/community/kinfocenter/APKBUILD
index 9ac34a8087..7a45b81be3 100644
--- a/community/kinfocenter/APKBUILD
+++ b/community/kinfocenter/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kinfocenter
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="A utility that provides information about a computer system"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by kconfigwidgets
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
makedepends="extra-cmake-modules qt5-qtbase-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev kdoctools-dev ki18n-dev kiconthemes-dev kcmutils-dev kio-dev kservice-dev solid-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kdeclarative-dev kpackage-dev solid-dev kwayland-dev glu-dev"
@@ -28,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="8e544db63341cf29e578271b29272d2407c014ddf181ba61f83c6200643e66433e06c067620bd18c9a0a5e337d794800c0e5ca762a2ff733c1de76551fdd5b11 kinfocenter-5.20.0.tar.xz"
+sha512sums="5441b9617a322e4bd28aed56230891cf52f429d999f817879a3cbfe545ec2fea061e1ab24b39daa7433e48aade9619bee95609ba8b687bf8212f221eeb9d303c kinfocenter-5.20.1.tar.xz"
diff --git a/community/kmenuedit/APKBUILD b/community/kmenuedit/APKBUILD
index 0c780d11d1..e2cbc8a91d 100644
--- a/community/kmenuedit/APKBUILD
+++ b/community/kmenuedit/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kmenuedit
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="KDE menu editor"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kmenuedit
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev ki18n-dev kxmlgui-dev kdbusaddons-dev kiconthemes-dev kio-dev kitemviews-dev sonnet-dev kdoctools-dev kglobalaccel-dev kinit-dev"
@@ -28,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="9948194bcc75b3b8ef21292ab47ead450476a468dc7777b0613a8bf65bd946ed38bd6264329d27e28879f1c02cee78e739e02463d0b6950696135d1f5dae0ab0 kmenuedit-5.20.0.tar.xz"
+sha512sums="ba1182c6012ca3bfa2890dd116d1f78b216e407854b3d6f5279d8a1eccf3d763c9780e716925bbdf52124361a3b4779b93bba8ac86284bbdb4a5018bb6d7c5a4 kmenuedit-5.20.1.tar.xz"
diff --git a/community/kscreen/APKBUILD b/community/kscreen/APKBUILD
index 8d597103c4..6024049c52 100644
--- a/community/kscreen/APKBUILD
+++ b/community/kscreen/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kscreen
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="KDE's screen management software"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kconfigwidgets
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends="hicolor-icon-theme"
@@ -31,4 +33,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="c8b8f87263f92cbf572497a717e20d4d85edc1ae9ac2dc01142dfd93bc048e09176485a0687baa7047af5dd23638afdcd05a0d3bf15a34a02d9c447fa0af473a kscreen-5.20.0.tar.xz"
+sha512sums="ea67234cda4202b08e78b8fecca6791752a5c7ecd9087f4e5b96834bc7045cdf426142e35136558ab299267615759ea6679dbd935b59b15937d62fa100c2945d kscreen-5.20.1.tar.xz"
diff --git a/community/kscreenlocker/APKBUILD b/community/kscreenlocker/APKBUILD
index 0fd4d0aedc..0310ba5523 100644
--- a/community/kscreenlocker/APKBUILD
+++ b/community/kscreenlocker/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kscreenlocker
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Library and components for secure lock screen architecture"
-arch="all !armhf"
+# armhf blocked by extra-cmake-modules
+# s390x blocked by kdeclarative
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only)"
depends="linux-pam elogind"
@@ -37,6 +39,6 @@ package() {
install -m644 "$srcdir"/kde-np.pam "$pkgdir"/etc/pam.d/kde-np
}
-sha512sums="229c81a41995205ba6b06c09d75f75d6eecdd5e0c8fbc428b0b411b1abafe14b9dc8e0e1afc5468e6c851d899fefca98b6d5bc8b0464a5e8f73ff291a14b1beb kscreenlocker-5.20.0.tar.xz
+sha512sums="f19b48a68343136e1ee088d7e63de819d4d8554c6f2c87bebd2ece6800b05bfe7017d6d762fd8ea2046a1dbb522cbafd0389df31c7c09a6af42e4c07dce065d1 kscreenlocker-5.20.1.tar.xz
56e87d02d75c4a8cc4ed183faed416fb4972e7f223b8759959c0f5da32e11e657907a1df279d62a44a6a174f5aca8b2ac66a5f3325c5deb92011bcf71eed74c3 kde.pam
565265485dd7466b77966d75a56766216b8bcc187c95a997e531e9481cf50ddbe576071eb0e334421202bcab19aa6de6b93e042447ca4797a24bf97e1d053ffd kde-np.pam"
diff --git a/community/ksshaskpass/APKBUILD b/community/ksshaskpass/APKBUILD
index c2e98d4541..6b633c11f8 100644
--- a/community/ksshaskpass/APKBUILD
+++ b/community/ksshaskpass/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=ksshaskpass
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="ssh-add helper that uses kwallet and kpassworddialog"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kwallet
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev kcoreaddons-dev ki18n-dev kwallet-dev kwidgetsaddons-dev kdoctools-dev"
@@ -28,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="a0e7cad3debde539da8432a84324a42f98206a2d5c22201dca89fe35dda15259eb5aa32ae20ded6c33b7db0b6ba4e4f44fa5b3ea703ecd3e7055e23005dcc563 ksshaskpass-5.20.0.tar.xz"
+sha512sums="6cdeb41fc0d6b857dc2ce3a35ffa81b9cf054841592f84cd73f3d932055257eee012795e03d2b91cb50ce797e20a2ddbb9698506efd22c5b3d394ba70e2d190a ksshaskpass-5.20.1.tar.xz"
diff --git a/community/ksysguard/APKBUILD b/community/ksysguard/APKBUILD
index 63e051b7c2..93a42a8425 100644
--- a/community/ksysguard/APKBUILD
+++ b/community/ksysguard/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=ksysguard
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Track and control the processes running in your system"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by libksysguard
+arch="all !armhf !s390x"
url="https://userbase.kde.org/KSysGuard"
license="GPL-2.0-only"
makedepends="extra-cmake-modules kconfig-dev kcoreaddons-dev kdbusaddons-dev kdoctools-dev ki18n-dev kiconthemes-dev kinit-dev kitemviews-dev kio-dev knewstuff-dev knotifications-dev kwindowsystem-dev libksysguard-dev"
@@ -28,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="db3fa91c7b9c578766a4011ad8e60d9c0028189f8505d101e4f0cf8e1bf63e951adcb0feba3825696b33b1fa2c958c0e8ac08575b66c3d1a9258508a87af7178 ksysguard-5.20.0.tar.xz"
+sha512sums="32545635aa6bdceaa65cb9401c5bea31ea249d1770751e298b809770ef78e8670d92675d20d0c608d32fe5696725cfbe21c2c58934e15944cb718733cca38c33 ksysguard-5.20.1.tar.xz"
diff --git a/community/kwallet-pam/APKBUILD b/community/kwallet-pam/APKBUILD
index 8c5e2e3037..e8bc2a7e09 100644
--- a/community/kwallet-pam/APKBUILD
+++ b/community/kwallet-pam/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwallet-pam
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="KWallet PAM integration"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by kwallet
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-or-later"
makedepends="extra-cmake-modules linux-pam-dev libgcrypt-dev socat kwallet-dev"
@@ -23,4 +25,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="99c715222adb5c1d825981d2898528e01ee84887fd12e6cc9dfcab86edd5c3325a71bfb394d7d9e60f4cc1388d1e36410b34f579e2c840a121867787460f7b09 kwallet-pam-5.20.0.tar.xz"
+sha512sums="ebb82a91347c83ac77faf6d28df3e1d31852dd394419237fda937ac649c0f2d0e67492bf0b5ffb27daef12191b5c72066b0d6f560832a4fce2dc7bcb28525f8d kwallet-pam-5.20.1.tar.xz"
diff --git a/community/kwayland-integration/APKBUILD b/community/kwayland-integration/APKBUILD
index 6ce93a59fb..32180e7a0f 100644
--- a/community/kwayland-integration/APKBUILD
+++ b/community/kwayland-integration/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bhushan Shah <bshah@kde.org>
# Maintainer: Bhushan Shah <bshah@kde.org>
pkgname=kwayland-integration
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="KWayland integration"
url="https://www.kde.org/workspaces/plasmadesktop/"
@@ -24,4 +24,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="088e59c0337bd6876802b3f2732d43c9f5120894eb2ecbf9364cd0e8638488d2bb4d9ed5487425ae274e10f14a2445b76dda2c229d5bf7f83ec9f7ab67ad334f kwayland-integration-5.20.0.tar.xz"
+sha512sums="042f0cd633f9d88eeaf70f18b6165eb24b9b087d3a26e7b9cacde6dbfb2fec81a529ed6d98b93d17e3014e730b61cedd00f905f5fbedc40d80f9d26385fa8b25 kwayland-integration-5.20.1.tar.xz"
diff --git a/community/kwayland-server/APKBUILD b/community/kwayland-server/APKBUILD
index 12361a13a0..fc98dd6290 100644
--- a/community/kwayland-server/APKBUILD
+++ b/community/kwayland-server/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwayland-server
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Wayland Server Components built on KDE Frameworks"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -25,4 +25,4 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="c5dab0a86e4a355294c9b2b793f4d0aa091d260abd85b7fe9523941792493c6cbce640e00957247996456acc8baca7ff4d42af84f5b30089844c8eb752fea4ba kwayland-server-5.20.0.tar.xz"
+sha512sums="5aa4cb89ff4fca9c82026a5ee0e4a1af87fe4f5cb4442f12ff2c71f3367e64c5615b4a44e5036347e1aca6dc951ca0ea4110fb56fe47dfd3cb293369cff62a6a kwayland-server-5.20.1.tar.xz"
diff --git a/community/kwin/APKBUILD b/community/kwin/APKBUILD
index 8eab31264b..32255238aa 100644
--- a/community/kwin/APKBUILD
+++ b/community/kwin/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwin
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="An easy to use, but flexible, composited Window Manager"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kscreenlocker
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-only"
depends="qt5-qtwayland qt5-qtmultimedia kirigami2 xorg-server-xwayland"
@@ -36,4 +38,4 @@ package() {
# Remove CAP_SYS_NICE from kwin_wayland to make them work again
setcap -r "$pkgdir"/usr/bin/kwin_wayland
}
-sha512sums="1565f2226b00706b02a20b3d49c9d14ee351bb47c183a3a0bd69d9662db802bd5b340eaa9817f5f01c07b3b0c60a10df32698b4605f8e0242c5fd5436307753a kwin-5.20.0.tar.xz"
+sha512sums="6628d7b6eb033b715c22590524074b1272890741697715105b2599c3e7d13d3bbdaaefe144018d9fc8c5df05e9a7017395b2b80b9ce638429c818897beff97f9 kwin-5.20.1.tar.xz"
diff --git a/community/kwrited/APKBUILD b/community/kwrited/APKBUILD
index 40ac3635d7..d5ed732635 100644
--- a/community/kwrited/APKBUILD
+++ b/community/kwrited/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwrited
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="KDE daemon listening for wall and write messages"
arch="all !armhf" # qt5-qtdeclarative-dev unavilable on armhf
@@ -23,4 +23,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="3bc33d0e1747042e3d2ab6c438b0fdf01e50073798b217f106e6d00d2b534322572f8263ef6b687c8f3d819b143431b59eaa473b17073dfb19d46e483d9174fb kwrited-5.20.0.tar.xz"
+sha512sums="7834a7d6277e0879aa1fb8a66eec2d97bc8a5e30f532d1871c4484a5c504ec1895b2095c91d291278bb78a5a97148d706b1fabf1a1f2a971138f6d9ca65e80a3 kwrited-5.20.1.tar.xz"
diff --git a/community/libkscreen/APKBUILD b/community/libkscreen/APKBUILD
index 7eec0e610e..abbcc27d69 100644
--- a/community/libkscreen/APKBUILD
+++ b/community/libkscreen/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libkscreen
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="KDE screen management software"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="d516cff6572abe02406451e71efc19749c42eb719f8506df492a462af1a3436ac16f4546ae974328572e0c169cc2a74e7bf055c5ab3c0de13729f9f254506ec1 libkscreen-5.20.0.tar.xz"
+sha512sums="cdf1a46bfbe4703b9b2732afc061dbef8d7b57f29dc93d0971eb97bc68cc86d35ab1f48f4e18cf23805283da059d7d94ede17927e7ae1679c479eb8dcf67d4c4 libkscreen-5.20.1.tar.xz"
diff --git a/community/libksysguard/APKBUILD b/community/libksysguard/APKBUILD
index 5d3ffa26dc..5b1b3d8421 100644
--- a/community/libksysguard/APKBUILD
+++ b/community/libksysguard/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libksysguard
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="KDE system monitor library"
-# mips, mips64, s390x, blocked by kauth, kconfigwidgets, kiconthemes
-# kio, knewstuff, plasma-framework
+# armhf blocked by extra-cmake-modules
+# mips, mips64, s390x blocked by kauth
arch="all !armhf !mips !mips64 !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-or-later AND (GPL-2.0-only OR GPL-3.0-only)"
@@ -50,4 +50,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="8265461921a978c7ea202a577a3ad430b9ea6ea0479665ef11741ae89583c2bb7f58cb1aa82794b1badb4b3356f0305fa8d6efdbaddc6563bfceec099501dd28 libksysguard-5.20.0.tar.xz"
+sha512sums="77e785e6285d71672bb077d93e4a2692b3750b05ec4a64620dd054c77702c5fabe1f9a69b69ffb860b7288a45b6eb8b55f362b832bd55e56a88cc64e69650f91 libksysguard-5.20.1.tar.xz"
diff --git a/community/milou/APKBUILD b/community/milou/APKBUILD
index 11e2813414..84dd4c20c6 100644
--- a/community/milou/APKBUILD
+++ b/community/milou/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=milou
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="A dedicated search application built on top of Baloo"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kdeclarative
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev ki18n-dev kdeclarative-dev kservice-dev plasma-framework-dev krunner-dev kitemmodels-dev"
@@ -27,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="b66e2f0437930b12e88bdd39df67c969b0a07fb54880cd76dd738e8b79b9aa993bbf3d80d04cce6bc9ef51e0b09853919bb38cff5dc606da74b99709cffb45eb milou-5.20.0.tar.xz"
+sha512sums="c2ea0733a11dfde0119849868d5718ba706c67297f6949c30cbb581c8dfd5bfd17d66a56a1f73163876c65ff13621e5de5666a4c5d0782677fe66afce4a33019 milou-5.20.1.tar.xz"
diff --git a/community/oxygen/APKBUILD b/community/oxygen/APKBUILD
index 6bb87d6afe..39aea4fd4b 100644
--- a/community/oxygen/APKBUILD
+++ b/community/oxygen/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=oxygen
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Artwork, styles and assets for the Oxygen visual style for the Plasma Desktop"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by frameworkintegration
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev ki18n-dev kconfig-dev kguiaddons-dev kwidgetsaddons-dev kservice-dev kcompletion-dev frameworkintegration-dev kwindowsystem-dev xcb-util-dev kwayland-dev kcmutils-dev kdecoration-dev"
@@ -27,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="9a90a5e18932375955c1db1cfb29ec7a00bae3c7afbea27b47d13f53c614d760022d52bbc4114b5858b9d090be90c2cbe585e3026a53583039fc479ae0b0d185 oxygen-5.20.0.tar.xz"
+sha512sums="0d39c5ea2299bddd2665f9bf20b9a2d2ac743763e107a3b00bf00136dc50660efc3d47e7d933c1f0f940ebbf6e71344e58dc31094e0d5ad44d4ff5bae607cee9 oxygen-5.20.1.tar.xz"
diff --git a/community/plasma-browser-integration/APKBUILD b/community/plasma-browser-integration/APKBUILD
index 8a0e6b7530..12f1c58e41 100644
--- a/community/plasma-browser-integration/APKBUILD
+++ b/community/plasma-browser-integration/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-browser-integration
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Components necessary to integrate browsers into the Plasma Desktop"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by kio
+arch="all !armhf !s390x"
url="https://community.kde.org/Plasma/Browser_Integration"
license="GPL-3.0-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev kio-dev ki18n-dev kconfig-dev kdbusaddons-dev knotifications-dev krunner-dev kactivities-dev purpose-dev kfilemetadata-dev"
@@ -28,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="59184545c26f8592048b0473ac4852612fe59098bce8bf67d624e904c1d9d451a47ac7f27cfdabeec75bf0f9b7ac49be712acecd7286810cc7612f09bb20e2e3 plasma-browser-integration-5.20.0.tar.xz"
+sha512sums="e385815e54b3ab9ae3ee6d948c606da76cbf76d7079fc5de48a942cd421e173125c5fdb19c5fbf13d80d4ae21487b2d400681b28ab90c226b17c8c57fdaf303d plasma-browser-integration-5.20.1.tar.xz"
diff --git a/community/plasma-desktop/APKBUILD b/community/plasma-desktop/APKBUILD
index bf8d1f9916..39c829c6e4 100644
--- a/community/plasma-desktop/APKBUILD
+++ b/community/plasma-desktop/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-desktop
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="KDE Plasma Desktop"
# s390x, mips, mips64 blocked by ibus
@@ -17,10 +17,11 @@ depends="
qqc2-desktop-style
setxkbmap
"
-depends_dev="
+makedepends="
attica-dev
baloo-dev
eudev-dev
+ extra-cmake-modules
fontconfig-dev
ibus-dev
kaccounts-integration-dev
@@ -32,6 +33,7 @@ depends_dev="
kdbusaddons-dev
kdeclarative-dev
kdelibs4support-dev
+ kdoctools-dev
kemoticons-dev
kglobalaccel-dev
ki18n-dev
@@ -56,7 +58,6 @@ depends_dev="
xf86-input-libinput-dev
xf86-input-synaptics-dev
"
-makedepends="$depends_dev extra-cmake-modules kdoctools-dev"
checkdepends="xvfb-run iso-codes"
source="https://download.kde.org/stable/plasma/$pkgver/plasma-desktop-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang knetattach"
@@ -89,4 +90,4 @@ knetattach() {
cd "$builddir"/build/knetattach
DESTDIR="$subpkgdir" make install
}
-sha512sums="d34560977b75854a80cd75a9a15c9fed614ea9c36a724c2e5df9ae6e3439762a34d7afe33892beae2e7dff3fc555673f27069c43bb0bf774ad8740e3476be651 plasma-desktop-5.20.0.tar.xz"
+sha512sums="1b18b046dca64bcd1e99464b2c378b9df85281c09a7f9fdb67d522475a6f49269a5c22ca424cba260c092f065e8026e6abe76cfa9ea514e0a19470f467185e0e plasma-desktop-5.20.1.tar.xz"
diff --git a/community/plasma-integration/APKBUILD b/community/plasma-integration/APKBUILD
index d053dd7454..f7c324d6c3 100644
--- a/community/plasma-integration/APKBUILD
+++ b/community/plasma-integration/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-integration
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Qt Platform Theme integration plugins for the Plasma workspaces"
-arch="all !armhf" # Blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kconfigwidgets
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.1-only AND ((LGPL-2.1-only WITH Nokia-Qt-exception-1.1) OR (GPL-3.0-only WITH Nokia-Qt-exception-1.1))"
depends="font-noto ttf-hack qqc2-desktop-style"
@@ -32,4 +34,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="fd6d00e14bff37e14b407c9e6d6f5c1b4fe7a98218f714e8b79924862b8c1d0a83b367509a5924587f29f6ea5d1d8dc32643621e17ba01a0b682d2775653bbc3 plasma-integration-5.20.0.tar.xz"
+sha512sums="1b9b2692b283250ea829f29d272336a36ddc14fe1e8d3f4b92807a61822f4dd71d1fc5ef4c706db26bee6d54191f836a4c1c91726b6e90c8f22b502d69317ee2 plasma-integration-5.20.1.tar.xz"
diff --git a/community/plasma-nano/APKBUILD b/community/plasma-nano/APKBUILD
index 400c34a68a..8b83b76360 100644
--- a/community/plasma-nano/APKBUILD
+++ b/community/plasma-nano/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-nano
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="A minimal Plasma shell package intended for embedded devices"
-arch="all !armhf"
+# armhf blocked by extra-cmake-modules
+# s390x blocked by plasma-framework
+arch="all !armhf !s390x"
url="https://invent.kde.org/kde/plasma-nano"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends="qt5-qtvirtualkeyboard"
@@ -28,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="a42636ec134c6546309eb245e882debbf38d3984bc7d4721aa1d99cf84cf9a1ccd0fa6deb6bfd4c80cfb958bb3cd19b977900b5c390d818e0fbdb348572145d5 plasma-nano-5.20.0.tar.xz"
+sha512sums="08ef15e8bcab0a95c45e10ede4aefa1749e3c6f8b9bf6fa3483b1d1199a2bf46a8a465a9431de5ea69bde417a9f14084444683d4470da1843dd18ffbf8055db0 plasma-nano-5.20.1.tar.xz"
diff --git a/community/plasma-nm/APKBUILD b/community/plasma-nm/APKBUILD
index 74040ed379..090b7cb7a9 100644
--- a/community/plasma-nm/APKBUILD
+++ b/community/plasma-nm/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-nm
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Plasma applet written in QML for managing network connections"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by plasma-framework
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-or-later"
depends="kirigami2 networkmanager"
@@ -44,4 +46,4 @@ mobile() {
"$pkgdir"/usr/share/kservices5/wifisettings.desktop \
"$subpkgdir"/usr/share/kservices5/
}
-sha512sums="db78e2c65a09cf6d77032c1a63ba0d66bac3946944a25f08f7267bfb776a39736189668ab3e2eaa815f09f0d7993bdc1384f9267e035053e40051b23a204d7f5 plasma-nm-5.20.0.tar.xz"
+sha512sums="e3a61dd7381585472b079802b6523596910e84b6f837562b38b917c8dd64efd4ba50a70acc3cce3f167a9dfde74bb292cf487c0dcc2c125ad1393167ff68305f plasma-nm-5.20.1.tar.xz"
diff --git a/community/plasma-pa/APKBUILD b/community/plasma-pa/APKBUILD
index dd3e17795e..90300df8e3 100644
--- a/community/plasma-pa/APKBUILD
+++ b/community/plasma-pa/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-pa
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Plasma applet for audio volume management using PulseAudio"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by libksysguard
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-only OR LGPL-3.0-only AND GPL-2.0-only"
depends="pulseaudio kirigami2"
@@ -29,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="2440a8d0891d1c2dd3ac0b914f4de9b89a97d87b1ece8f2eaaeb2e28eaa9e0c6015392eed89f290ebc6fcc35805ce7c20d3b87c07dd1c99a186d3c7c1b476160 plasma-pa-5.20.0.tar.xz"
+sha512sums="cfcad57a6fe6d5cd3983812d8900df5722fbf4f37bfdfa497c1fd0e53d182b0dd34f681dc825ccdc7f962572abd9fa6470b4474743352d4c66a4d69ecddb5d02 plasma-pa-5.20.1.tar.xz"
diff --git a/community/plasma-phone-components/APKBUILD b/community/plasma-phone-components/APKBUILD
index ef3e530443..e32b59837d 100644
--- a/community/plasma-phone-components/APKBUILD
+++ b/community/plasma-phone-components/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-phone-components
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Modules providing phone functionality for Plasma"
-arch="all !armhf"
+# armhf blocked by extra-cmake-modules
+# s390x blocked by libksysguard
+arch="all !armhf !s390x"
url="https://www.plasma-mobile.org/"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends="plasma-nano qt5-qtquickcontrols2 plasma-workspace dbus-x11 kactivities plasma-pa plasma-nm libqofono breeze-icons"
@@ -30,4 +32,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="88bc3a46279baddcde285bddf9695e884b635635c6c87fc12c88080ce623abcc58b6e41daa9f358c9a6300cce324274096fafa7fe79570ac0a40da1131b56698 plasma-phone-components-5.20.0.tar.xz"
+sha512sums="e98d2a3d2d9b098a26d2d7b4854675c52c34e0b7f9bdac1bd9d796bb51a41cc5b4f372c91c8569ab3befff3ff449963a3d8d45c8c7fc716c726db1ddb8f2bfc6 plasma-phone-components-5.20.1.tar.xz"
diff --git a/community/plasma-sdk/APKBUILD b/community/plasma-sdk/APKBUILD
index 3674b33011..fc5448176f 100644
--- a/community/plasma-sdk/APKBUILD
+++ b/community/plasma-sdk/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-sdk
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Applications useful for Plasma Development"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by kconfigwidgets
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later"
depends="kirigami2 qt5-qtquickcontrols"
@@ -31,4 +33,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="220f205930e9064ae74c3856db9f5075beaa9a8e24bd6bae485cdbca73f115ea21856e55522d5e1c729e981bf3242486b72a90299e79f859a7db746f774ae945 plasma-sdk-5.20.0.tar.xz"
+sha512sums="d27c9d36aa45c3f25e69855e2f115da87f8cd810dd4addf48babb73a83c5d78621b8de53e585d971514ca42f84f2f3b80323ddf0a7e07a139f4d0b81d6d92898 plasma-sdk-5.20.1.tar.xz"
diff --git a/community/plasma-thunderbolt/APKBUILD b/community/plasma-thunderbolt/APKBUILD
index 15efd01de7..3af72f3c44 100644
--- a/community/plasma-thunderbolt/APKBUILD
+++ b/community/plasma-thunderbolt/APKBUILD
@@ -1,9 +1,11 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-thunderbolt
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
-arch="all !armhf !armv7" # Limited by bolt -> polkit, armhf also limited by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by bolt
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
pkgdesc="Plasma integration for controlling Thunderbolt devices"
license="GPL-2.0-only OR GPL-3.0-only"
@@ -31,4 +33,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="c99ff7a606e90b38ef10ce85c4adc375a4425b0d383db58829f8ccf61eeefa290c1f8a2c0b20b10b72af3bf607b4dea2ca0be98f0c6704fcb8e7247f32bfacab plasma-thunderbolt-5.20.0.tar.xz"
+sha512sums="dc3f69751bd1485dbde1d00821b47d3d62025deca0d7e590e8892f863cae9070989308a19131328cce13aa0c1187ee2bcd6c1ef43d3cb23df302d4c9d1f6f57c plasma-thunderbolt-5.20.1.tar.xz"
diff --git a/community/plasma-vault/APKBUILD b/community/plasma-vault/APKBUILD
index 4fb2f30ce2..34825cdfb7 100644
--- a/community/plasma-vault/APKBUILD
+++ b/community/plasma-vault/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-vault
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Plasma applet and services for creating encrypted vaults"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by libksysguard
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only AND LGPL-3.0-only)"
makedepends="extra-cmake-modules qt5-qtbase-dev kactivities-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev ki18n-dev kio-dev plasma-framework-dev kwidgetsaddons-dev networkmanager-qt-dev libksysguard-dev"
@@ -28,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="b16cdd8c40305d402bb378da12b48d39265150f06c10fc7e7b7415934fc10029fdbb21337b9605900a22780f26cea0592c092d3cd622a56ffae4d91b994f9992 plasma-vault-5.20.0.tar.xz"
+sha512sums="e63e900ba39cea6175db72021cda10f172b9720bb58e57d2b8a1de7a86c84acc36dac610adc0c5eeb73bf0dd415cbc5762b4f3748611a15fb0a92700ea3bccca plasma-vault-5.20.1.tar.xz"
diff --git a/community/plasma-workspace-wallpapers/APKBUILD b/community/plasma-workspace-wallpapers/APKBUILD
index 60a6ed6f70..f3e88d7382 100644
--- a/community/plasma-workspace-wallpapers/APKBUILD
+++ b/community/plasma-workspace-wallpapers/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-workspace-wallpapers
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Wallpapers for the Plasma Workspace"
arch="noarch !armhf" # armhf blocked by extra-cmake-modules
@@ -23,4 +23,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="1e7f3d85f09572ccc613f8c6c6364a32b0c28a5a3843660daf6e96897a5867cec556dd9981c3607b7ea3e635716ad63b1b53400c6a09b777b30624d9e2a12ada plasma-workspace-wallpapers-5.20.0.tar.xz"
+sha512sums="a2a89220ea2acf3d5d3c97633f358f046db6894825eda94711276f66d3c2be215f774cb01413b271da8be593a07e6604ef7d4b04d44281e09405479940946002 plasma-workspace-wallpapers-5.20.1.tar.xz"
diff --git a/community/plasma-workspace/APKBUILD b/community/plasma-workspace/APKBUILD
index bc2f1e8419..d68e7905b8 100644
--- a/community/plasma-workspace/APKBUILD
+++ b/community/plasma-workspace/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-workspace
-pkgver=5.20.0
+pkgver=5.20.1.1
pkgrel=0
pkgdesc="KDE Plasma Workspace"
-arch="all !armhf" # armhf blocked by kirigami2 -> qt5-qtdeclarative
+# armhf blocked by kirigami2
+# s390x blocked by kactivitymanagerd
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later AND GPL-2.0-or-later AND MIT AND LGPL-2.1-only AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-only"
depends="
@@ -64,7 +66,7 @@ depends_dev="
"
makedepends="$depends_dev extra-cmake-modules kdoctools-dev libxtst-dev"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/${pkgver%.*}/plasma-workspace-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-libs $pkgname-doc $pkgname-lang"
build() {
@@ -85,4 +87,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="3b49ad852a1c2cfb1b4f304a25423506825b94ca80809e0e9ea55e1efa100b0b5411b3591087c35750f971e78dc640d851a367fae7c33902d02610d21511a613 plasma-workspace-5.20.0.tar.xz"
+sha512sums="db7acbe7fc441429ffcefea152fe4036344a4f3fce3a83b0b3ccce781e5e453944541342b64f5e89535296976c837d45e25c03843d01ee083ff9d0a04ec2a8cf plasma-workspace-5.20.1.1.tar.xz"
diff --git a/community/plasma/APKBUILD b/community/plasma/APKBUILD
index 49a347af43..d451c8f3e6 100644
--- a/community/plasma/APKBUILD
+++ b/community/plasma/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Plasma (Base) meta package"
url="https://kde.org/plasma-desktop"
@@ -40,7 +40,7 @@ depends="
sddm-breeze
sddm-kcm
systemsettings
- udisks2
+ udisks2
xdg-desktop-portal-kde
xdg-user-dirs
"
diff --git a/community/plymouth-kcm/APKBUILD b/community/plymouth-kcm/APKBUILD
index 9b6b2820e9..4b904a62c4 100644
--- a/community/plymouth-kcm/APKBUILD
+++ b/community/plymouth-kcm/APKBUILD
@@ -1,9 +1,11 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plymouth-kcm
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by knewstuff
+arch="all !armhf !s390x"
url="https://cgit.kde.org/plymouth-kcm.git"
pkgdesc="KCM to manage the Plymouth (Boot) theme"
license="GPL-2.0-or-later"
@@ -30,4 +32,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="7a7444711adec1c48986a50d5dffddba4e399b5528c43bb2d94a9fc29cd76db16ae826ad765bf60157d0b8e866034e8e3d3e6b8fd3749373e6e591624520e088 plymouth-kcm-5.20.0.tar.xz"
+sha512sums="851befab4e136d2f0b3216c43c6a19ceb7dd8bade7ad9379eacd96795c34bfc47420fa5cb9842644432a980c55fb6d0d1fe6e43a42c6d400b2c2f12b908fea1c plymouth-kcm-5.20.1.tar.xz"
diff --git a/community/polkit-kde-agent-1/APKBUILD b/community/polkit-kde-agent-1/APKBUILD
index 540f8e84df..6dcbd38fc1 100644
--- a/community/polkit-kde-agent-1/APKBUILD
+++ b/community/polkit-kde-agent-1/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=polkit-kde-agent-1
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Daemon providing a polkit authentication UI for KDE"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by polkit-qt-1
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later"
depends="polkit-elogind"
@@ -29,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="6a3f3e642b8d420d5c1e1d4cfa42d02c03cd4659bf4524705b289227258f92d81a567afa870784e09b8ad70dc3c359f1e6200f1ee81f3e142f32e7707138b52c polkit-kde-agent-1-5.20.0.tar.xz"
+sha512sums="049afc2d87efc8896b3157f658a92665286a1affe1b52afe1c89d9bf0e3edbe1988e255725e4c23427ed59c5d48e0324eef3b0630ba7876acd2cfb82c3f8c50d polkit-kde-agent-1-5.20.1.tar.xz"
diff --git a/community/powerdevil/APKBUILD b/community/powerdevil/APKBUILD
index 23aaf66abd..5c70a84b43 100644
--- a/community/powerdevil/APKBUILD
+++ b/community/powerdevil/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=powerdevil
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Manages the power consumption settings of a Plasma Shell"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# s390x blocked by libksysguard
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends="upower"
@@ -30,4 +32,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="09d0893ba0876fc7e1a90cde315cf3aefe3028b99fe3b7edd9fcf7f37b1552175b6514b9a49a68878497215d1ee73938c3efa8b63ddeb4e3be8aeb96b6d640c3 powerdevil-5.20.0.tar.xz"
+sha512sums="550d3015e3a17feaf13882e62d251bab2b0c8d749d6f628b06877ce7af4c03a4a201af8ac0441d16db3de934126771cd37f92935796d9bc889779c3707c611a8 powerdevil-5.20.1.tar.xz"
diff --git a/community/sddm-kcm/APKBUILD b/community/sddm-kcm/APKBUILD
index 959c0b8f73..bfcc012ce8 100644
--- a/community/sddm-kcm/APKBUILD
+++ b/community/sddm-kcm/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=sddm-kcm
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="Config module for SDDM"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by plasma-workspace
+arch="all !armhf !s390x"
url="https://www.kde.org"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later AND GPL-2.0-only"
depends="sddm systemsettings"
@@ -28,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="57694ce045bb24d1cbf054140c8bc07cdf28adf81726951e542acaaa393d4d575da5a203878a1f0f86f528f5648d22dd12450e9ba954f2e60adaeda5df6a3cd6 sddm-kcm-5.20.0.tar.xz"
+sha512sums="50df0f065ec10a40f7896afd10715c4d5a161d93468538546a001c8ff206b38ecae944960209aaf9406fcf72ad7c56f3609ee7eace353ee2e6d0e7844becc587 sddm-kcm-5.20.1.tar.xz"
diff --git a/community/systemsettings/APKBUILD b/community/systemsettings/APKBUILD
index e9455c07bf..27bb9562a9 100644
--- a/community/systemsettings/APKBUILD
+++ b/community/systemsettings/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=systemsettings
-pkgver=5.20.0.1
+pkgver=5.20.1.1
pkgrel=0
pkgdesc="Plasma system manager for hardware, software, and workspaces"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt5-qtdeclarative
+# s390x blocked by libksysguard
+arch="all !armhf !s390x"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later"
depends="kirigami2"
@@ -29,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="01436f2e290355d83ba32d5f662fe4b39aa8856f6c2c202d84a516cb3cefce0c26a7162def8c70eafeb71d2e446c8e955b3cf42b2149ad653867171121940d16 systemsettings-5.20.0.1.tar.xz"
+sha512sums="5ae4e0e897e3f007ce7654699009e1e0cbe213d14901c762e1f49f716c16e7e688587767328685a57d1e60ee26cd4d515ef8b849d80c1d7f567ae06ead35a9e8 systemsettings-5.20.1.1.tar.xz"
diff --git a/community/xdg-desktop-portal-kde/APKBUILD b/community/xdg-desktop-portal-kde/APKBUILD
index 9ef6816a4c..d9e914397b 100644
--- a/community/xdg-desktop-portal-kde/APKBUILD
+++ b/community/xdg-desktop-portal-kde/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=xdg-desktop-portal-kde
-pkgver=5.20.0
+pkgver=5.20.1
pkgrel=0
pkgdesc="A backend implementation for xdg-desktop-portal that is using Qt/KDE"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -39,4 +39,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="7aeee7085fc194c52c0a1d4b3c5c8569cc29cdda3dde8562e3ba57de1b205da68ce41234afcd916dba070c3d5643001183e2b5c6913b9f775d3a61f7808532e6 xdg-desktop-portal-kde-5.20.0.tar.xz"
+sha512sums="c6ff135dced3ec5394675ae6b4c730fe6cc7534b0d760e7c55cce4f376cdd31d699978577823eea5087c8b43ca849d28c6e759c5331ab2564735b90131edea5a xdg-desktop-portal-kde-5.20.1.tar.xz"